connect telemetry through TCP & UDP

hi Silvio!

i have tried 4G telemetry as like you but i have failed continously to connect

the mission planner with 4G network.

attached pls find the screen capture of my trial.

when i push the connect button under the condition of TCP, it showed "host name" pop-up and i wrote

it accordingly. then next window arose to insert remote port number. so i wrote many port number in the column, for example, 8080 or 8090 or 2000 or 14550 but there was no use and the window's remark was the sentence "trying to connect" or" no heatbeat packets received" or "connect failed".






also i changed the connection mode by UDP again, then pop-up showed as "enter local port" and i again wrote many port numbers as above but failed. pop-up was showed as "waiting for UDP" continously.




which port number is ok to connect the telemetry under 4G networks? or is there another problem to do 4Gmetry?

your prompt reply will be appreciated!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • @Sijongmu, how are you doing with your connection problem? I ask as I am in the exact situation, "connection timed out, no heart beat packets received" or something to that.

    I have a similar set up to you APM > RPi > 3G router (I replaced the dongle with the router as I need an extended antenna, you can do this with some dongles but the router is much more robust).

    I think the cable Efstratios is refering to is a FTDI cable. I don't know much about them but what I can tell you is that it is in the FTDI chip that is in the cable or the UBS end.

    But I don't think that that has anything to do with the problem we are encountering, and here's why I say that.

    As I mentioned I first had a 3G dongle in the APM/RPi set up (sakis3g etc) but I couldn't connect, no heartbeat packets. That and I kept burning out dongles, if you don't have an antenna connected to the dongle they fry.

    So I bought the 3G router, first I connected the APM to the RPi via the UART2 pins down the starboard side of the APM to a DB9/RS232 level shifter module (the APM works on 5v, the RPI works on 3.3logic (the RPI takes 5v but only uses 3.3v) to you have to put the connection through a level shifter) that connects straight to a serial port on the 3G router.

    Again No heart beat packets :-((((( Ok I thought it was the RS232 module.

    So I then connected the APM to the RPi via the UART2 pins on the APM to the GIO pins of the RPi. Assigned the RPi with its own IP and the traffic is directed to the GIO pins of the RPi with a port address. The 3G router forwards the traffic from the APM to port 5760 and the 3G router has a DyDns. The RPi uses Ser2net to do the serial to net conversion.

    And guess what, no heart beat packets.

    So then I tested with the FTDI cable from APM to RPI and still the same, no heart beat packets.

    I am of the mind that the problem lies either in the port 5760 (I haven't tried 14550) or the mavlink.

    If there is anyone that can assist us please do?

    Cheers, RS

    • hi richard!

      thanks for your explanation. the different things between you and me is the router and level shifter.

      first, i also connected APM-RPI2-4G router. i used 4G router but it's almost same string with you.

      so already i commented above to Efstratios, normal usb port cable will be possible to connect APM-RPI.

      my connecting port of APM 2.6 was belows position.


      did this point made the 4G telemetry connection impossible? i didn't consider UART2 pin.

      would you tell me UART2 pin's position exactly? just i expected apm-rpi connnection would be

      sufficient with connection RPI usb port-APM side port only.

      also about level shifter, i don't have knowledge about it. i simply connected apm-rpi2 which

      was supplied the power independently(apm from powermodule and rpi2 from powerbank in my case).

      yes, your guessing can be right. i inserted the port number as 14500, 2000,8080 or 8090 but i didn't

      tried port no 5760. well i have a short knowledge about port no.

      about mavlink, i guess there my apm 2.6 was no problem by using the 915MHz radio telemetry.


    • Hi Sijongmu, I was told about the UART2 as from what I understand if you are using a power module you shouldn't use the USB port as they are on the same circuit. Again don't take my word for it as I am very much learning as I go.

      The UART2 pins: remove the APM from the protective casing, it's the four screws on each corner of the casing.

      Remove the board from the case, turn the board over so all the in/out put pins are facing down (if you are using vertical pins), now turn the board so the FWD arrow is facing away from you and you will find the UART2 points on the left hand side of the board aprox mid way down. They will be header less so you will have to solder header pins. You will also have to create an opening in the casing. I just used a 5mm drill and drilled four holes and then used a small file to straighten the sides.


      I have just learned that the level shifter is not required, so you connect APM > RPi : TX > RX, RX > TX, GND > PIN 6. As the APM and RPi are using independent power supplies I'm not sure if + is needed. I have yet to confirm this, I will keep you posted.

      Hope this helps.

      But if you are going to use the UART2 > GPIO pins you will have to assign the RPi with an IP and assign the GPIO pins a port and direct the traffic accordingly. I followed this:

      Hope this helps, let me know how you get on?

      If anyone else can help please do.




    • hi Richard!

      as per your guide, i opened the case of apm 2.6(it was not easy^^) and i found the UART2 point accordingly. flwg point is right?


      then what is the next step?

      as i understood, it needs some soldering to connect the cable in the pin and some

      drilling to pass the cable through the case. so which cable should i use? just 3 pin(white,

      red, black cable) is ok? also, i don't know what is the green connector out of apm case.


      and how is the wiring details with the left devices and what is the connector in left device.

      is it a Odroid? RPI doesn't have such port as i know.

      additionally, i want to clarify that above all works should be done to realize LTE telemetry

      in mission planner?

      awaiting your reply!

    • @sijongmu, Give me 30min I'll pull mine apart and take some images and post.

      Yes, the image indicating the bottom of the board is correct. You will need UART2 TX & RX (as you have pointed out) and GND. I also put in a 5v pin, but I have now learned that with your and my set up of having independent power supplies for the APM and the RPi the +(5v) is not required.

      It must be noted that the GND is very important (you probably already know this but I thought I would mention it anyway), every component in the configuration must share a common GND.



    • @sijongmu, 

      Here are some images of my APM 2.6, this was my first attempt and a bit rough but it dose the trick, oddly enough I did my 2.5 second and is much better. I use my 2.5 in my machine (if I ever get Telem over 3g working) and use my 2.6 for testing.

      3702881228?profile=original 3702881068?profile=original




      If you have any questions just let me know. If you are new to header pins let me know and I will tell you what I know.



    • @sijongmu,

      Now two address your coloured arrows above.

      Light blue: This is the 3G router. We are looking at the serial is the serial port. The serial port is a DB9 female fitting.

      Purple: this is a DB9 gender changer. As the APM uses TTL one must use a RS232 TTL converter. As RS232 TTL converters come in two protocols DTE and DCE. We need DCE, most DCE RS232 TTL converters come with a female DB9 fitting/plug. As the serial port DB9 fitting on the router and the DB9 fitting on the RS232 TTL converter both have female DB9 fittings a gender changer is required.

      Green: This is the RS232 TTL converter module.

      Yellow: this is the UART2 header pins.

      I got this from Toby Mills:

      But I don’t know anyone that was able to get it working using UDP so I gave up and now like you have included a RPi in the system.

      I am really new to this so I can’t say for sure if the above information regarding formats and protocols are correct so if someone else could confirm or correct that above information.

      Hope this helps.


    • hi Richard!

      you are really my good teacher^^. i don't know the electricity and role of each pin

      so much. pls advise your good knowledge of GND theory without hesitate^^.


      re APM case, i understood well and i will make the holes to connect to the header pin in the apm. also i don't know about the header pin. pls expain it to me as beginner's level. and where can i buy the pin?. near electric shop, rc shop or hobbyking? is it common thing in the market?


      about Router connection, My 4g router has USB port only. then how about this method?  Router-USB port(USB CABLE)-USB pin side-header pin in APM.

      of course, i will cut the usb cable pin side and try to make jack to fit to the header pin.


      re RS232 converter and Fatbox, it's difficult for me to understand well. so i will review it later if i get sufficient time.


      about your wiring, as i know, you succeeded to realize 3G LTE telemetry(TCP meothod) through the mission planner. then i think, you are correct anyhow.


      awaiting your reply!







    • Hi sijongmu,

      This isn’t my field so whatever information you care to take from this please confirm from another source.

      GND: A common ground (GND) must ground all electrical devices in any structure that is not grounded by earth. So boats, cars, planes, etc and I am talking of any size, so the car you drive the boat you go fishing in etc, and that includes models. I THINK that is so the entire systems can create a circuit. If a common ground is not shared then this creates interference in the circuit, and in some cases can damage the device.

      You really need to google this one if you want an exact explanation.

      So in your set up the APM needs to GND to the RPi and the RPi needs to GND to the router. This includes the Battery systems. But this is all easy, the Batt’s have (-) which works to GND to the Router, the USB has a GND built in, then you will have to attached a cable from the GND of the GPIO pins on the RPi to the GND pin of the APM UART2 pin.

       Header Pins: You can buy header pins in many places, electronic shops, electronic repair shops etc, or you can buy them from the web, Hobby King, 3DR, DIY Drones, etc.

      Below you will find two of the most common header pins: straight and right angled.


      3702943461?profile=originalAs for the female plugs you can us single plugs or I use Futaba plugs.



      3702943435?profile=original3702943511?profile=originalFor the best connection I solder.

      As for the RS232 level converter and the Fatbox, you need to ignore this as it does not apply to your set up.

      I hope this helps.



    • Hello,

      In my case the only reason i wasn't receiving any hearbeat packets was that simply i didnt activate the mavlink on the correct port.

      If you are using mavproxy to forward the mavlink to the intern make sure first that the autopilot is actually connected to your board(whatever this is). To do so just insert - - console at the end of the - - master.... command.

      If the autopilot is actually connected then you should be able to see reaction while you move the autopilot and also indication that the linkn is on.

      After that the only thing is to press the udp connection on your ground station and keep the default port. Make sure yyou dont block the connection to this port. I use a vpn on my laptop in order to bypass any firewall.

      Odroid + lubuntu + mobile 4G router works fine for me. No need of sakis3G to establish connection

      If i can help you more please tell me. I had troubles figuring as well how to do that.
This reply was deleted.