Hi,

I have almost the same problem as droter and kbcopter in this forum. My observations:

One of the 3DR radios (433 mhz vers.) seems to be ok but I am not sure. It flashes the green LED, but the red LED is NOT flashing upon power up. It seems to respond to the 3DR radio config tool - i.e. it is able to load settings, save settings, and upload firmware. The green LED is blinking and the red LED is reacting to the config tool when an AT command is sent to it. However, it cannot seem to connect to APM Planner 1.1.88 and has an error message of "No Heartbeat packets received". When I try the config in APM Planner  I am able to load settings, but I cannot upload firmware giving an error message unlike using the 3DR Radio config software. This radio's noise level is almost the same level as the RSSI level. It fluctuates but on  the average its the same on the 3DR config tool.  Another issue, it does not save new settings (e.g. tried tx = 20), and loads previous settings.

The other 3DR radio  is solid green LED and flashing red LED (1 sec. interval) on power up. 3DR config tool cannot connect at load settings and save setings giving an error message of "Failed to enter command mode". With the upload firmware button it gives an error of " Failed to identify Radio". However, if I short the CTS and GND pins before power up as mentiond on the 3DR page, this radio goes solid red (correctly entering bootloader mode) and I am able to upload firmware. The red LED also seems to be reacting properly to the upload.  Unfortunately, after flashing it goes back to solid green LED.

It seems that the radios I got are bad too.

Help!

Views: 13149

Reply to This

Replies to This Discussion

Serg,

I seem to having the same problem. When I power the "Air" and "Ground" radios both have a solid green LED, but the Air radio has a blinking red LED and the Ground has a dim red LED.

In the Mission Planner I can see the settings on both the Air and Ground and I can update the firmware on both (when I plug them into my computer. Can't do it wireless), but I cannot get the Mission Planner to connect.

Does anyone have any idea how to fix this?

-Jake

Jake,

 At least for your units, they seem seem to have 'bound' together.  But they are still not working based on the docs. Also I think the red LEDs should be blinking in a synchronized manner when both radios are communicating with each other and sending messages.

Have you emailed 3DRobotics about it? There are already a couple of us who recently bought these units and who seem to have gotten bad radios. This can sometimes happen. I hope 3DRobotics can fix this soon.

- Serg

Where did you get these radios? 3DR is not yet selling 433s with the USB connection because they need to be revised. If you bought one of those from another source, they are pirated clones and will not work. 

Chris,

The 433 Mhz radio units were bought from the DIYDrones store. They came with the telemetry kit. These are the units  with the FTDI cable.  

Gotcha. Contact customer support: help@3drobotics.com

Thanks. I already did. I think its just this one radio unit. The other seems ok. 

Serg,

The radios are working again. Part of it appears to be magic and the other part is because I had the quad plugged into the computer at the same time as I tried to connect wirelessly, which the wiki (correctly) says you cannot do.

-Jake

I had the same problem as shown above with one of two units in the 3DR config tool. ct failed twice to enter comand mode of the radio. After connecting aother unit to the config tool (ct) which worked properly from the begining (firmware upload, setting (write) and loading (read) the settings, no problems) i reconnected the other one. After two further trials ct finally succeded to enter the command mode. Since then both of them are working perfect with the ct.

 

But none of the two is able to be connected with the MissionPlanner 1.1.92.

i wonder if the connection problem with Missionplanner still exists when i upload a earlyer firmware like 1.3. to the radios.

Mine is 1.5

Is this possible?

I wouldn't suggest that.  The radios are transparent serial links the firmware won't have anything to do with MP connectivity.

The problem I had was that MP wasn't updating properly.  It was downloading and installing updates but not actually bumping up in versions.

I'd uninstall and reinstall MP, then double check your com port and speed settings.

I already did and now did it one more time.

No result: wether i can connect them with MP 1.1.92 nor they can conect each other after powering them up (one by connection with pc and the other connected to my apm 2). blinking green leds on both side (distance 2m). Here it seems to be the same problem as in this post http://diydrones.com/forum/topics/just-can-t-get-them-to-work-pleas...

i added pics of 3DR config and of my layout (green light is not soli on both modules, its blinking approx 2 times/second)

thanks for further help

Attachments:

I guess that thread says it all.  Check your settings and that's about all you can do.

Can you try...

ATI6 (TDM timing report)

and

AT&T=TDM

I'm curious what you'll get for these commands.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service