• Well I made some progress - I think?  I have 3.2 and also have apm planner 2.0.15 (instead of 3.1.5 and 2.0.14). Now it shows "autotune" in the log as the mode (first stabilize, then alt-hold and then autotune).  The copter I suppose - maybe? - does something different?  Not certain.  But I get zero ATUN messages in the log.  I have log set to only log "default" messages.  Is this correct?  I didn't see a bitmask to log anything.

      @rob burrows - yes - I have stabilize and alt-hold on ch5 and autotune on ch7.  alt-hold definitely still is working while in autotune mode but I left it flying for 4 minutes and now want to see the progress.  I can't tell if it did anything.

      In 3.1.5 I could go into terminal mode and type I believe "enable all" and it listed the things that I could log and ATUN wasn't on the list so I assumed it always logs this.  In 3.2 terminal mode doesn't seem to do much - it doesn't respond to typed commands - just keeps sending data to the terminal - some of which is readable at first but then the rest is not (random looking graphics characters).  I grabbed the log with the GUI but anyway - the problem seems to be no ATUN messages.

      • Developer

        Hi George,

        Can you post a log please.

        • I had to add bit 16 to the log I think.  Anyway I got two ATUN events this time.  When I first switched to autotune it definitely rolled hard (in a perfect, controlled, safe way) and then did one more 16 seconds later and then never again.  The wind was very light - gusting to 5mph.  But I'm in a small area - about 60 feet by 60 feet and had to adjust probably too often for autotune to run.  I guess I need to find a larger place to fly where there aren't any people.

          There were many times where I didn't touch the controls for 10 seconds but maybe autotune had already given up?  If I switch out of autotune mode and in again will it start from the begining or continue?

          Anyway - here it is - attached.  The pitch needs tuning badly as you can see from the log.


          • Developer

            Ok, there are two issues that will cause the problem.

            The first is you don't appear to have done your radio calibration because all the RCX_TRIM numbers appear to be 1500. I looked at this because I could see your Roll request is not zero and this will stop autotune from happening. This means your radio calibration is way out because you have the default, large dead bands set.

            The second thing that may be a problem is your copter appears to be wobbling around with up to 10 degrees swings. Was this in windy or gusty conditions. You still may be able to get autotune to run with a proper radio calibration but if you can't you will need to work though a basic manual tune before you can proceed.

            Can you tell us a little about your copter and prove some photos?

            • Ah!  When I upgraded to 3.2 it seemed to have remembered all the parameters so I didn't do the radio calibration again.  I'll do that before I fly it again!  It remembered the gyro calibration.  Don't know why it lost the radio calibration.  Thanks for that tip!

              Well the roll oscillations were all me - hitting the stick too hard maybe.  The pitch oscillations are definitely there - that's why I want to tune it.  I have a long moment of inertia in pitch now that I have the camera mounted way the hell out front of CG and the battery way the hell out the back.  It was fine before I did this so I think that's the problem and I'm hoping I can compensate that with better PID values.  Some day.

              Since I took this picture I strengthened all 4 arms to be like the 2 thicker arms.  But on new props (these ones are beat up).  Cut a few inches off that aluminum bar and the battery is also about an inch closer but still way out there.  I don't want an acrobatic quad but I don't want it to oscillate in pitch so much either.  I've also mounted the APM better and have less vibrations - it's glued to thin neoprene foam which is glued to the yellow plate.  I spent quite a bit of time getting the vibrations under "1" whatever the unit is.  So the APM gyros are nicely connected for fast no-slop but vibrations are still reduced.


              • Developer

                Sorry to jump in but a small point is that the the RC calibration has been done at some point.  The ground station is responsible for implementing the radio calibration routine and I suspect it's not setting the RCx_TRIM because we don't actually use them (as far as I know anyway).

                I agree though that the RC calibration needs to be done because, as Leonard says, there is a very small but persistent desired roll (it's about -0.5 degrees of lean) that is likely the cause of why autotune is not starting (because it thinks you're trying to override the roll).

                • I just noticed I also get ERR,16,2 quite a bit: intertial nav bad variance according to here:


                  • Ah, there we go Randy.  Thanks! :)

                  • Developer


                    The bad variance error is normally caused by a misbehaving compass.  It could be anything that causes the compass to give a bad heading including:

                    1. incorrect orientation

                    2. compass calibration hasn't been done since more equipment was added to the vehicle which has affected the offsets

                    3. bad interference from power wires, escs, motors

                  • We each may have our own opinion "slykittenbox" but not a very constructive comment and doesn't belong here at DIYDrones. Both systems have advantages over each other

This reply was deleted.


gotham liked gotham's profile
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23