Replies

      • Hello Leonard, and thanks for your quick analysis !

        For the first problem I think is that should not use 10000mAh beacause is to heavy

        Here are my setup :

        2680g (2880g with 10000mAh)

        Rctimer 5010 360Kv

        Prop 16x5.5 carbon

        Skywalker Quattro (4x 25A UBEC) ESC

        About the second problem how can I clearly identify the real cause ?

        I will first go to a new ESC calibration, then go to default PID

        • Developer

          Hi Alex,

          How many cells are you running?

          Can you provide a photo of your copter?

          • I'm running 4S 8000mAh

            Here is the quad

            3702843191?profile=original

            • Developer

              Hi Alex,

              I suspected round arms. They are always a problem to get lined up properly!!

              One way to do it is put a straight edge over the base of each motor mount or the top of the motor. Then eyeball it with the arms to see if it is straight. The other option is to remove the motors and place straight edges between motor mounts. How ever you do it, take your time and get it as good as you can.

              Do an ESC calibration.

              Set:

              MOT_THST_BAT_MAX,16.8
              MOT_THST_BAT_MIN,13.2
              MOT_THST_EXPO,0.75
              MOT_THST_MAX,0.95

              Back off the gains to the default if it will fly safely on them.

              Do an autotune with Autotune AGGR set to 0.05.

              This copter would probably fly very nicely on 6s if you had the esc's to handle it. Power module is also a problem of course. I have hex with 16 inch props running on 4s but use 540kv. You my also increase the size of your props to 18" provided you don't add any more weight.

              • Unfortunately Leonard, my esc can't handle 6s power

                Anyway, I've updated to 3.3RC5 and changed parameter as provided, I will give you a feedback when I can do a new fly, it's very windy at this moment here.

                Just for the story, this frame is a piece of .... I will buy another one with better quality.

                Thanks for all your works !

                • Hi Leonard just for update,

                  here are the new result of my last autotune attemptStill a little bit windy today so the autotune process take long time .

                  3702926251?profile=originalFull log is here :

                  Gdrive log file

                  Please feel free to take a look

                  2015-06-11 16-02-43.log
  • Doesn't anybody have a clue? Or time to help me sort this out?
    Please, I'm really really stuck
    Thank you all
    • Developer

      Hi Mathieu,

      It looks like you are loosing your number 3 motor. I can clearly see it dropping while at the same time going to maximum. The autopilot is doing everything it can to fight against it but it just can't do it. This is a pretty clear mechanical / electrical failure.

      Your tune looks ok in roll but is funny in pitch. Also the Stab P value in your autotune doesn't match your screenshot. I suspect your gimbal was shaking during the pitch phase of autotune and that has caused what I see. We know gimbals can cause problems with auto tune.

      I am very sorry about your crash. Let me know if there is any way I can help.

      • Hi Leonard,

        Thank you so much for taking the time to address my questions.

        One thing bugs me: I ran an auto analysis of the logs and

        - 1st log shows Test: Autotune = GOOD - [+] Autotune 19002-119777

        - 2nd log shows Test: Autotune = UNKNOWN - No ATUN log data

        Is it normal that autotune data disappeared. Or does it only show in the log of the autotune flight?

        - 3rd log shows Test: Autotune = UNKNOWN - No ATUN log data

        Next 2 logs are attached

        - 4th log shows Test: Autotune = UNKNOWN - [?] Autotune 4491-7201

        - 5th log shows Test: Autotune = UNKNOWN - No ATUN log data

        ...

        When you refer to motor 3, it's this one?

        3702702067?profile=original

        I've checked and eveything seems fine with that motor/wiring/bullet connectors/ESCs...

        I cannot understand why it would suddenly suffer mechanical/electrical problem after autotune while it was working fine before (although I did mention a pretty hard landing at the end of Autotune).

        I've  reinstalled arducopter 3.2 from scratch, all PID settings back to standard and everything seems fine now (haven't had the opportunity to fly though - just handholding the copter).

        Just a question, since I'm not familiar with log analysis but want to learn: where in the log do you find data related to motors?

        One thing for sure: I'll follow your advice and remove the gimbal next time I run Autotune (if I dare to try again :)

        Thank you for your insights Leonard and we are grateful for all the hard work you guys put into these so we can fly :)

        Cheers,

        Mathieu

        PS: Sorry, it's off topic but - In auto analysis TEST: PM is either WARN or FAIL. Is it something I should worry about?

        2015-05-31 09-25-37.bin

        2015-05-31 09-43-40.bin

        • Mathieu - try connecting your receiver directly to your ESC module and while holding the copter down safely use your transmitter to move the motor from full off to full on back and forth very quickly, pause at different speeds and make sudden and extreme changes.  See if you can get the ESC/motor combination to stall.

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…