Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi again,

    Just a couple of quick questions - I get the warnings Battery Low and RSSI Low... have set up my battery in MP (2200 size and 1-3 cell) but OSD shows only 10.8V consistently and 0% RSSI.

    I've searched through this thread, but can't find a solution - do I need more sensors than just what APM2.5 provides to get this data displaying correctly?

    Again, thanks for any assistance! :)


  • Just to add some more info for the topics I've started above, the problems seem to have started when I uploaded a hex I compiled myself using Arduino... then, blank screens when OSD is plugged into both the OSD Config tool and APM using the hex files available here (Versions 1.9, 2.0 and 2.1), until I then uploaded the same self-compiled hex (2.1) using OSD Config tool - now, I see booting and "Waiting for Mav..." using the config tool, but still get total static on blank screen with APM.

    Is it possible that the Arduino tool uploaded more than just the hex file, maybe overwriting or not including some files that APM2.5 expects to see?

  • Hi Gábor,

    I was looking to do the coding myself for the EzUHF RX RSSI & Link Quality output, because I thought it wouldn't be that hard to display ch 6 and 7 in % like I said here

    But it took me 4 days to find out how to download the sourcecode from the google page. :-)

    Now I am looking in the code, but I can't find out how this al works. It is just to complicated.

    Is it possible that you can to the coding for the EzUHF - RSSI version ? Or maybe to help my out here?


  • Hi Gabor/Burt/Anyone else,

    I had my MinimOSD Extra working perfectly with Ver. 2.1.2, panel switching warnings all working.  I recently decided to upgrade to Arducam 2.0.  I have been having problems since.  The 1st panel seems to work after the most recent flash, previously it would have flashing characters and missing info.  The 2nd panel is all messed up the characters are all over and in the wrong positions.

    The first time I uploaded the firmware or charaset (can't remember) a message (in Config Program) popped up which said something like "error remapping eeprom.......", then another message said "eeprom remapped....." (can't remember exactly as it was a few days ago and haven't seen the messages since).

    Further I have a second camera, both are 12vdc, one is Pal and one NTSC, the NTSC camera shows the data (messed up) and when I push the reset button the screen shows the MinimOSD reboot showing the reboot screen.  When the PAL camera is attached the osd data is not shown and when I push the reset button the video scrren goes blank and the comes back on still with no osd data and no boot screen.  To get osd data to be show I need to cycle off/on the 12vdc camera/transmitter power source.  Any ideas?  I have double checked my wiring, all good.  Would changing to a single power source for the OSD help (solder blobs)?

    Also is there a way to completely reset the OSD eeprom and start from scratch?

    Thanks for your help!


  • Hi,

    Just to add to the mystery - I loaded up the new 2.1 which I compiled myself... this now seems to load pretty stable each time when connected to FTDI cable and gets to the piont where it says 'Waiting for ... heartbeats'. However, when I plug back into the APM2.5, the screen goes blank after booting.

    Thanks for any help you can add!


  • Hi guys,

    I am having an issue with my MinimOSD... I seem to be able to successfully update the charset and firmware ok, I have reverted back to 2.0.

    When I plug in the OSD, I see the splashscreen (V.2.0) and booting graphics, but after booting, the screen usually just goes blank. Occasionally, it says 'waiting for mavlink heartbeats', and then displays the 'Overspeed' warning, but that's all - it usually quickly goes blank thereafter.

    I have tried plugging in to PC through FTDI cable and viewing output, but same issues. I use a 5V camera, powered by the video tx, through the OSD board and the red power light shows. Sometimes, I get a video picture only for a few seconds and then blank again. Have tried pressing reset while uploading firmware but same problems.

    Please, any ideas?? :(


  • I'm having much better success with the latest minimOSD-extras preview release (r438.hex) than I was with ArduCAM 2.0, BUT I've got a garbage paramater I can't seem get rid of. If I toggle off every element, I still have one strange 3 digit number floating at about position x16 y4. This number is around 295 to 297 with 1 decimal of precision which fluctuates. I have no idea what this number means nor am I able to configure it in anyway using the ArduCAM Config tool. Is this just an issue/bug with the pre release version?

    Also, the voltage displayed by minimOSD is always about .3 less than what is configured in Mission Planner and MP is pretty spot on to what I read on my multimeters. I've been having this problem with both ArduCAM 2.0 and the minimOSD-extras. For example: Measured Voltage 15.124, Calced Voltage 15.107 to 15.132, Mission Planner between 15.11 and 15.14. Battery A on minimOSD shows 15.47. So why is minimOSD displaying the totally wrong voltage? How is it even going about calculating this incorrect number while it is bang on in Mission Planner?

    P.s. I was previously using ArducamOSD 2.0 but never able to get panel switching to work. If I attempted to switch to Panel 2, minimOSD would show a second garbled panel which was not configured at all how I set it and then quickly switch back to Panel 1 whether Warnings were enabled or not. I was seriously considering that my board must have been defective, but I am having better success with minimOSD-extras, that said, I was also have issues with the OSD freezing after about 3 to 10 minutes of running and this doesn't seem to be totally gone with minimOSD-extras as I just had it freeze on my a few minutes ago :(

  • Hi


    Now I have a new problem: I can’t toggle between the panels.

    After booting I see panel #1, when switching to the second position there is some data fleshing for a moment and the OSD is showing the first screen.

    When toggling to the 3rd screen, the first screen remains but breezed. The data get refreshed only if I toggle back to position #1. Any idea?

    I’m still missing symbols, the “little house, the clock, the ALT”, is it a resolution problem?



  • SO I just received my minimosd to replace the one I had that quit working.

    My configuration is that I tie the digital and analog side together by a blob of solder in the 2 places suggested.

    Now my problem is uploading the char sets!  I know that you are suppose to power both sides to do that.

    Is it okay for me to power the 12v side now that I have tied the 2 sides together with the solder blob?

    I don't want to fry it, yet it will not take the char set..

    please advise and that you all very much for all the great work here!


  • just flown today, it's great to have the osd back for fpv flying! sure the computer with 3dradio connected works great, but the osd helps a lot.

    unfortunately i forgotten the easycap, so, no video recorded. maybe i can fly tomorrow, and for sure next week i'll fly. i just realized the call sign didn't appeard, maybe i've uploaded the wrong charset. i'll check it later.

    another question, will wind direction work with APM2 running arduplane 2.5? the 2.66 had some bugs, and i decided to go back to the stable 2.5...worked very well today. but as i was doing this, i disabled the wind meter.

This reply was deleted.


DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
6 hours ago
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord:
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar
Nov 9, 2021