Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • OK all...I'm sure this has probably been addressed previously but I haven't found it.  I'm having issues with the MinimOSD (latest firmware and all) and a GoPro Hero 3 camera (latest firmware as well).  Here's the situation:

    • Had OSD working properly with Hobby King camera prior to buying the GoPro
    • I've now installed the GoPro but I get no video from it.  I can see the OSD information but no video from the GoPro.
    • I am using a proper USB to composite cable for the Hero 3 (i.e. the 10-pin mini USB)
    • I can get video out of the GoPro if I go directly from camera to a video display device such as a computer (in other words...I've verified that the USB cable works properly)
    • I've updated the OSD firmware and character set a couple times now...no change.
    • I'm powering the OSD and transmitter from a dedicated power supply at exactly 12 volts
    • I'm not sending power to the GoPro but I am sharing the ground with the OSD and transmitter
    • I've tried bypassing the transmitter and sending OSD and video directly to the display device via hardwire connection...no change.
    • I've turned on the Hero 3's wifi while connected to the OSD just to see if I can get video from the camera that way.  Video feed over wifi is successful.
    • Here's the most interesting symptom...If I slowly decrease the voltage I provide the OSD from 12 volts down to ~9.5 volts, I can get the camera video to sporadically appear.  Sometimes it takes the place of the OSD overlay and sometimes it is combined with the OSD overlay...just depends on the voltage I send the OSD.  So....it's acting like the OSD is just plain overpowering the video signal from the camera.
    • The OSD and the camera are both set to NTSC video standard

    So there's my situation.  I've come to the end of ideas on where to go from here.  Any help or guidance would be greatly appreciated.

    Cheers,

    Wayne

  • Admin

    Hi All,

    This has been a good, informative thread and I do not want to have to close it because of politics. As DS has said, start a new thread to address the political aspect of drone safety and the media. Please lets continue to just address the MinimOSD in this thread.

    Regards,

    TCIII Admin

  • Hi every one

    My Minim OSD does not want to display current draw or RSSI. Both values are however correctly displayed in my Mission Planner when I connect it over USB on Laptop.

    I use APM2.5 and a 3DR power module. The OSD is brand new.

    All settings are correct: Current sensing on pin A12 and RSSI on pin A0.

    Volts are correctly displayed in OSD and MP (pin A13).

    Has any one came accross this problem yet?

  • Hi every one

    My Minim OSD does not want to display current draw or RSSI. Both values are however correctly displayed in my Mission Planner when I connect it over USB on Laptop.

    I use APM2.5 and a 3DR power module. The OSD is brand new.

    All settings are correct: Current sensing on pin A12 and RSSI on pin A0.

    Volts are correctly displayed in OSD and MP (pin A13).

    Has any one came accross this problem yet?

  • Interesting bug I think.  loaded the latest and with fonts and all.  I get a good first screen with all the data correct.  then every minute or so I get a small crowded OSD in the middle of my screen with 8 lines of info right in the middle of the screen. then after a minute or so it flips back to the good screen.   the config I pushed was default first screen and nothing on the second screen.  why is it switching on its own.  and why is it going to this little screen that I did not config?

    Ideas?

  • Moderator

    Hello All,

    I was at the field today hoping to get another flight in using Arduplane Code v 2.72 (very nice so far), but alas it was too windy at ground level for safe take off/landing. So I spent my time instead testing out my antenna tracker and the new firmware for the MinimOSD. A friend of mine walked the plane around the field for me! LOL it was a sight to see him walking around with my giant Super Sky Surfer!!

    Anyway I have MinimOSD code version 2.3.05 loaded and I noticed something odd, the compass rose is off by 180 degrees. I didn't think to see if the heading was displayed correctly in degrees. Has anyone else reported this? If so is it a bug or am I doing something wrong? If it is the former is there a new version available?

    Otherwise it looks great!

    Regards,

    Nathaniel ~KD2DEY

  • Another copter r596 video...

    https://www.youtube.com/watch?v=0jIAQLyUy5w

    Steve

  • I just finished my customizations to the minimOSD-extra 2.3 (latest trunk) and 2.3.0.5 mcm file, with Arducopter 3rc1. First I have to thank Miguel and Gabor for their hard work. All is well on my copter and I may go do some flight testing today, but I figured I'd point out a few minor bugs I found on the bench.

    1- The imperial climb rate character does not display. Not sure how to properly fix it, but I just hardcoded "0x1E" in place of "climbchar" in the climb rate panel (osd_panels.h).

    2- Panel switching+warning display is buggy if I boot with a low batter warning. If I boot everything up with a low battery and select either screen2 or off screen (ch8 switching), it flickers between the intended screen and screen1, without any sign of a warning. When I switch to screen1 the OSD stops flickering and the warning displays properly. This is repeatable. Now while in this "flickering state", if I plug in a good pack (2 lipo setup for video and Motors), the warning goes away, and the off screen and screen2 operate properly. Then, if I unplug the motor lipo, the OSD properly switches to screen1 with the warning (no flicker).

    I hope I clearly reiterated bug 2... kind of a complicated one I guess, and since it only happens initially without motors plugged in, it's probably irrelevant to safe operation anyways (but maybe a good programmer should take a closer look to make sure this can't happen in flight). I'm not sure what is causing bug1, but the f/min values appear to be correctly calculated. I love the landing aid. I think it has been mentioned before, but instead of the "-" sign for descent and nothing for climb, it would be nice to have a visual CR indicator. My buddy has this OSD that uses vertically stacked arrows as a visual CR indicator; for climb first one hollow up arrow appears, then 2 hollow arrows, then 3, then the first hollow arrow turns solid, then the 2nd, then all 3 go solid at a set "max CR". Same thing using down arrows for descent, no arrows for CR=0. So it has 13 intuitive steps a pilot can use to instantly asses climb performance... no digesting numbers required and acceptable resolution. A 13 step bar graph with center mark would also work (like in the MP HUD).

    Cheers,

    Kev

    ps: After some flight testing if all is perfect, I'll post my source, hex, osd, and mcm for anyone interested. It's what you would expect from me... very minimalistic with cropped coordinates and all... but adjusted so my cheap ebay SD-DVR playback screen doesn't overlap GPS numbers, and so everything fits in the margins of my el cheapo Phillips 9" monitor. ;)

  • The download provides 3 char sets but doesnt say which is the best or describe the differences.

    WHich is the latest ? The one called latest ? 

  • What is the difference between minim osd-extra and arducam ? Which firmware is the recommended ?

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…