I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


Views: 292480

Reply to This

Replies to This Discussion

try reading 8 posts back

Permalink Reply by Paul on September 22, 2015 at 12:07pm

Did you try this in Missionplanner 


Thanks.. I did get it to work. Not by using the Missionplanner Button, but by manually adjusting the SR parameters...

Thanks !  

Hi all!

My OSD periodically switched to this view:

This is a bug or feature? ;)

Feature. It's the summary of your last flight. Time, distance from home, distance covered, etc


And the question is, can I turn off or something configure this feature?

Not that I'm aware of, I think the memory available on the chip is very small .

I am getting not very far with my minimOSD v2.0 and (seemingly) any APM unit running AC3.2.1.

APM units are a 2.5 (with internal compass disconnected), and a newer (full-size) APM Pro.  Both are powered via a clone power module (v1.0 on one, v5.0 on another), and have GPS (NEO-6M on one, NEO-8N on the other).

If I load up minimOSD-2.0, I get everything - battery status, updated GPS sats, the lot.

BUT, with any other version (i've been sticking to stable releases, such as 2.2-extra and 2.4-extra R800) I get the dreaded non-updating zero values.

I've fiddled with SR0 and SR1 parameters, used the Enable Telemetry function from the OSD page on MP, but to no avail.  Weird thing though is that if I connect to MP with the battery connected, then disconnect from MP (with battery still plugged in) I get all values shown as expected.  But then, if I disconnect and reconnect the battery, it's back to the big fat zeroes.

The only thing I haven't tried is UART0 - the APM 2.5 I haven't soldered in the headers, and with the APM Pro if I use that port then MP will connect but won't read any parameters and hangs.

TBH I don't mind minimOSD-2.0 at all really - though I do miss the minimised Heading Rose and the Total Distance features of the Extra versions.

Any ideas?  I've (like many) spent a number of days trying to nail this but with no luck.

Download Mission Planner 1.3.16 from HERE

Change the sr parameters like in the picture (set SERIAL1_BAUD to 57) and save. Disconnect and restart and see if it works.

Rssi problem.

I am running minim osd R800 with latest firmware & charset and using an ezuhf to control pixhawk. I have set it up as per the youtube video here -


It says to use link quality on channel 8. All works well except I have a second percentage beside my rssi so it looks like this on screen:

RSSI 99%8%

Am I doing anything wrong?


I always get a similar problem...too many %% signs.  I believe that it is a bug in the firmware (one which I wish they would correct).  My "fix" is to simply switch between OSD screens using channel 6 or 7, as set up in the MinimOSD OSD software.  This corrects the problem.

See page 283 of this thread for further discussion on this issue...I don't think that it ever got resolved.

I've tried those parameters before (and other permutations i've found others using)...sometimes SR0 parameters get reset though the next time I reconnect to MP.  Kinda like how with the Battery Monitor I can never select "3DR Power Module" - it always resets back to "Other" regardless of how I hold my tongue.

I'm running MP 1.3.32 at the moment - could that version be the culprit?

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service