I just bought the APM 2.5+ Assembled with the 915Mhz Telemetry. I also bought the uBlox GPS.  When I plug the APM into the USB and launch the Terminal I get:

Init ArduCopter V2.9

Free RAM: 1819
FW Ver: 120
----------------------------------------


load_all took 1440us
No dataflash inserted COMPASS INIT ERROR

Press ENTER 3 times to start interactive setup

I've tried using an older firmware and everything, it always shows "No dataflash inserted COMPASS INIT ERROR"

What am I doing wrong?

ǝʌɐp

Views: 6751

Reply to This

Replies to This Discussion

Press 'enter' 3 times to enter CLI mode. type 'test' then 'compass' What happens?

I get a screen of "not healthy".

FYI: This happens with or without the GPS plugged in, if that makes a difference.

have you solved this problem?  I am having the same issue with my 2.5+, in cli it says no data flash when it boots also when i do a test on "logging" I get the same, no data flash.  This first happened a few days ago, then went away......now the same problem is back.  I have reloaded the firmware, including a different firmware.......still no success.  I am trying to look at my logs to get Arducopter 2.9.1 working.  Any help would be great.

Contact help@3DR as this sounds like a board failure.

My 2.5+ has quit working as well with the "No dataflash inserted COMPASS INIT ERROR."

I tried doing a factory reset, and other stuff as described above. Nothing works.  Does anyone have any ideas?

 

I had to send it in for a warranty repair.  They sent a new one that worked for about a day, then started getting the same error!!!  I've never flown the new one.  Just put it in the copter and set it up.

Odd thing is, the ones that went bad are the ones with side pins.  Now when I sent the first one for warranty, I ordered myself a second one with the pins on top.  I've been using it for over a week and no problems.  It's even had a couple of hard landings. (Not crashes, but about a 3-4 foot drop.)  So maybe the side mounted APMs are a bit more error prone.

Which type are you having problems with?

Dave

My 2.5+ has the pins mounted on the side.

I hope that 3DR takes a look at this issue.

Well i've just fix my board. it's U3 in sch PartNo. TPS79133 cause this.Repair costs 0.5$ in china

http://diydrones.ning.com/forum/topics/apm-2-5-no-dataflash-compass...

Have you checked board voltage – maybe that’s the problem?

I have the same trouble with a new unflown board, no dataflash, no compass, and the onboard sensors are not working. I just uploaded the latest 3.0 rc-1 firmware and there is now some additional output now instead of just hanging on "Init Gyros"

*NOTE* CLI Works only on first connect of power, log download only over USB

Opened com port

 

Init ArduCopter V3.0.0-rc1

Free RAM: 2197

FW Ver: 120

----------------------------------------

 

load_all took 1336us

3No dataflash inserted3ArduCopter V3.0.0-rc1]

ArduCopter V3.0.0-rc1]

ArduCopter V3.0.0-rc1]

ArduCopter V3.0.0-rc1] ?

Commands:

  logs

  setup

  test

  reboot

  help

ArduCopter V3.0.0-rc1] test

test] ?

Commands:

  pwm

  radio

  gps

  ins

  battery

  tune

  relay

  wp

  altitude

  sonar

  compass

  optflow

  eedump

  logging

  nav

test] ins

Hit Enter to exit.

INS

Failed to boot MPU6000 5 times

Failed to boot MPU6000 5 times

Failed to boot MPU6000 5 times

Failed to boot MPU6000 5 times

Failed to boot MPU6000 5 times

Failed to boot MPU6000 5 times

Failed to boot MPU6000 5 times

PANIC: failed to boot MPU6000 5 times

 

contact 3DR help@3drobotics.com as this sounds like a board failure.

I've the same issue and found very low volt at U3 (TPS79133) output pin.

Problem still exist after replacing U3. It looks like other components overloaded the 3.3V circuit!

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service