APM 2.5 RTL Flies AWAY, not to Home???

Hey guys, I kow this sounds like a simple increase the Nav Roll P Gains or I gains, the PIDs, however, I have tried one extreme to the other with no success of getting this thing turned back around.  I do not have telemetry, however, before launching, I have 9 Sats and a 3D lock according to telem via USB. When I launch, stablize and FBW are working fine.  When I got to RTL, Here are the two scenarios I get:

1) The plane will RTL almost like a waypoint, fly through it and bank to the NW and fly out with no signs of turning around. I let it fly for a ways before I take back over just to make sure.

2) The plane will simply bank NW and fly from whereever it is at the time I engage RTL and fly away from me.


I have tried the Nav Roll P gains from 0.800 all the way to 2.700 with no response; and the I gain from 0 to 1.000 with no change, all using 25% increases each time. Ive tried setting home manually on Flight Planner and uploading it to the APM before flight..  Since none of this seemed to work, I went in the settings and turned off Compass Learn and calibrated it manually, found my declination of 6 degrees 3" and put that in and still nothing... siiiggghhhhh Ive tried cracking this for the past three days and Im at a point that I just dont know what else could affect this.  Ive tried three diferent peoples Parameters for crying out loud that all work with their planes, but with mine, make it go spaz in anything but manual mode.  As far as LOGS, I havent got a clue as to what Im looking at, but from what I can gather, it show what the plane did during flight, but doesnt show the expected result or user input as it only records pitch yaw and roll axis and nothing else.  Even then, sometimes I cant even get them to download, and Ive never been able to get them pulled up on google earth...

SMH.. I would really appreciate any input from you guys.  Im just ready to FPV this thing and its been nothing but headache. Seems like it took forever just to get the spaz kill out of stablize to where it would fly right. Now its this..  Please Help.

Oh, and the plane is Skywalker 1900. No Mods, just standard, shown in my pics on my profile. Im running a 3536 1000kv motor, 900 Mhz Vtx (that is just riding for now for weight. Hasnt been on), APM 2.5 board with Mediatek GPS (Not attached to board) Firmware is Ardu Plane 2.67. and I have attached my params as they sit right now.





You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi All.
    My AP is arduplane 2.5, fw 2.73 and even thou everything looks OK and my AHRS_GPS_USE = 1, RTL and LOITER does not work as expected. LOITER will start ok but after one round will fly away.
    When RTL engaged, it will come home but then fly away and I have to switch to Manual to get it back home before it flies to nowhere. I am using GPS from http://www.rctimer.com/index.php?gOo=goods_details.dwt&goodsid=763 which works great and by telemetry I see on my GS that when RTL  is engaged the yellow line always point to HOME, even when it reaches home and then fly away  - it always point to HOME but still flies away - so, it looks like it knows where home is perfectly, but disregards this fact and flies away..

    I can't find anything on the web to help me understand what is going on here.
    I am disappointed.

    Please help.
    Thank you.

  • try uncheck "hold default alt " ,it will  turn back to home immediately

  • Developer

    Hi Jamie,

    The most obvious error in your config file is that you have AHRS_GPS_USE set to zero. That means your plane won't be using the GPS for navigation, it will be using dead reckoning. That is why it navigates so badly!

    I'd be very interested to know how you ended up with AHRS_GPS_USE set to zero. It is an advanced option that is meant to be used by developers to test the dead reckoning code. It shouldn't ever be used for normal flight.

    If it was just a misunderstanding of the documentation for the parameter then I will improve the documentation. If however you ended up with this set through some upgrade process then see if you can remember the process. Perhaps there is a bug that results in this being set through some upgrade process.

    Either way, set AHRS_GPS_USE back to 1 and you will start to be able to navigate again.

    I've also looked through your other parameters, and I think HDNG2RLL_P may be a bit high. I'd suggest 0.8 or so. Your KFF_PTCHCOMP also looks high to me.

    The other parameter that looks very strange is THR_SLEWRATE, which is set to 10. That will make for extremely slow throttle response. On an electric airframe a slewrate of 0 is usually best, although setting it to 1 or 2 will also work.

    Cheers, Tridge

  • Ok, so I have all the logs downloaded, but theres quite a few to choose from from my day of flight testing.. and I couldnt begin to tell you guys.  Theres the KML, GPX, RLOG and TLOG and the text document. Im not sure which one to post. I tried to post the folder, but that didnt work out too much.. anyways, I will be more than gracious enough to email them to anyone who is willing to help me out.

    Thanks again

  • Moderator


    You may not have RADIO Telemetry.....however if I remember correctly you can connect your APM to the MP via USB then go to the Terminal window and select 'Log Download'. If you can download your logs from the on board flash memory and post them here, you will get a lot more help with your question. The logs together with your parameter file for the flight will tell the whole picture.



This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022