• Hi, All,

    I'm trying to use this cps with APM 2.5, i understand that i need to save the file in the gps, but i got a problem, it seem i can communicate with U centre software, i'm running the software on a MacBook pro with Virtual MAchine with win 7, i got a solid red light on the module but nothing more.

    any help from anyone? 

  • Hello everybody!

    I just have finished my investigation on NEO-6M accuracy performance. I'm glad to share my findings.

    I have CRIUS NEO-6M. I've spent about a week to compare performance at different "Dynamic Models" with varying NAV5 and NAVX5 parameters. (If you don't know what I'm talking about, please refer to the following documents:

    u-blox 6 Receiver Description Including Protocol Specification

    Ublox GPS Tutorial).

    Using U-Center software I've found the "best" (to me) set of parameters and stored it to the GPS receiver.

    (note: CRIUS comes from stock with default factory settings for NEO-6M)

    After that I tried to check my modified GPS receiver on APM2.5 by leaving my copter outdoor for about 10 minutes and to collect some statistics with shape of track on MP. And what I see: any modifications don't take effect on performance since you plug GPS receiver to APM. Performance is always almost the same.

    I began to dig through the code at AP_GPS_UBLOX.cpp. (at the bottom of this post you will find modified file for ArduCopter-3.0-RC2)

    I have disabled any attempts to modify NEO-6M settings and it took significant effect !!!

    I have few questions for developers:

    1) When we try to put U-blox to binary mode we send configuration string:


    Actually, only part of string in bold puts U-blox to binary mode and sets serial port speed to 38400.

    And question is: What the first part of configuration string does? I did not found any information at U-blox pdf.

    2) Why we always trying  to change engine settings and dynModel?

    If I choosed some specific settings for my GPS receiver, code will rewrite it anyway(and even many times) during code run.

    3) AP_GPS_UBLOX::_parse_gps(void)

    if (_fix_count == 100)

    // ask for nav settings every 20 seconds
    Debug("Asking for engine setting\n");
    _send_message(CLASS_CFG, MSG_CFG_NAV_SETTINGS, NULL, 0);

    In real we ask for engine settings only once, because there is no resetting of _fix_count to zero.

    In addition I would like to say about SBAS. Since I live in Russia I have no chance to use any SBAS  system working on L1 GSM frequency. I have detected the signal from GAGAN only, but signal was too weak because it has coverage on India mainly. But if you live in Europe you can try EGNOS. I believe SBAS dramatically improve accuracy performance.

    For Russians  the best solution is to use LEA-6N with specific firmware and antenna to receive GLONASS/GPS signals.

    Please ask me any questions if it is interesting to you. (Hope it is ;) )


  • So this is in a plane not a copter ?
  • thanks for all the assistance.... here's my cable set up....

    3692702163?profile=original3692702069?profile=originalHere's what I get in u-center

    3692702225?profile=originalThe upload looks like this...


  • I was able to get the settings changed and the when I connect it to the apm2.5, it gets a fix. However, as soon as it gets a 3D fix, the artificial horizon in Mission Planner moves a little on it's own while the apm is still and also the altitude reading is very high. But if I disconnect the gps from the board, it doesn't do this.  Is this normal?  I don't have this behavior with my apm 2.0.

  • I don't see the file
  • Do not use the 3dr it is Optimized for aircraft not multi-rotors to help loiter use the file I attached..
  • I use it on my apm2.5 and it works perfect. I got mine from hobbyking. I just uploaded the 3dr firmware and its plug and play. Here is my video
  • I have the Ublox 6M-Neo GPS which I got form RCTimer and have used previous for my CRIUS AIOP v2 board, and I was wanting to use it on a APM 2.5 board. I'm having problems flashing my board with the ublox.txt file provided in this thread with the u-center software.

    I made a usb-FTDI cable with a FTDI adapter, wired it as I was supposed to, but can't tell if I am really connected to the GPS. The com port created when I attach my cable to the computer running windows 7 is recognized by the u-center software... Though, I'm a little dyslexic and for some reason have problems with the whole TX-RX reversal thing, but I sketched out the wire layout so I'm pretty sure I got it right.

    When my cable is connected through the header pins to the GPS it powers, the red RX led on the FTDI adapter flashes about once every one to two seconds. There is no GPS fix indoors or out indicated by the u-center software.

    When sending commands or a file to the GPS, the green TX led flashes ever so briefly. In the configuration upload window in the u-center software (v 7.02,) I get timeout errors saying the receiver isn't acknowledging as the file uploads a line at a time.

    Some threads say this the error is normal, but when I connect the GPS to APM 2.5 board it is not recognized. I'm not confident anything has happened.

    Oh yeah, the com connection indicator at the bottom of the board does flash green when the GPS is connected and I have tried various baud rates, making sure the com port in Windows device manager is configured at the same speed.  I have tried the configuration file upload process with the TX-RX line reversed, just in case my dyslexia has gotten the better of me. Still no joy... Is there any other way to confirm connection of the GPS to the u-center software or other software?

    I'm building my first quad and would just buy a compatible GPS to the APM 2.5 but burned up $65 worth of ESCs, somehow, and I need to replace them first, but I'm getting really frustrated.

    Any help is appreciated. Thanks.

  • Maybe a bit off-topic but might help.

    My Blogpost regarding a 3D printable Mount for the Crius PCB.


This reply was deleted.