• I made the GPS work connected to the laptop with u-center 8.10 and the default configuration but not with the config file recommended. In the u-center screens I can get 3D fix and at least 5 or 6 satellites (inside my appartment, just pointing the antenna to the window) but with the config file for CN06, the u-center doesn't show any information but the 3D fix confirmation.

      Tomorrow I'll load it back to the quad and see what happens.

      • >but with the config file for CN06, the u-center doesn't show any information but the 3D fix confirmation.

        Thats fine. Just click debug messages and you´ll see more informations ;-)

        • That's it! Excellent! Thanks a lot, gervais! I think now it is working fine, I can get 2D/3D fix in seconds inside home, just pointing to the window. Time to test on the field.

          • Struggling to follow you guys but I think you're saying the config file only sends the absolutely needed data (I knew that but am curious if that's what you're saying). 

            I haven't messed with mine in eons - need to finish configuring the darn thing!  Need to connect power to the flight controller and config the Tx.

    • After around 3h with direct view to a clear sky I got the GPS 3D Fix. Now it takes only a few seconds to fix GPS. I thought it should take only 10 to 15 min for the first time but I was wrong, I found a few reports of first fix taking several hours.

      Nevertheless... I still cannot see the test working in the CLI, I'm still getting a garbled message as shown in the image attached to my last post. Any clue?


  • Something important to know, I blew my regulator with magnetometer that come with the gps unit

  • We should look what has been changed in AC3.1  AP_GPS_UBLOX and after that consider if need to change it for Neo-6M.

    I made few months ago some testing to find out what config settings APM AC2.91b code actually overwrites succesfully to ublox. Basically i did it like this:

    A. First i wrote new settings with FTDI cable, U-Center and CN06v2.0_NEO6M_ublox_6_APMMPNG_config(Arducopter).txt setting file. Verified that settings has properly saved by reading back again and comparing.

    B. Connected Ublox to APM and power on. Waited 3D Fix.

    C. Keeping APM and ublox powered i disconnected RX and TX from gps "on the fly". This way keeped APM changed settings in ublox memory.

    D. Connected RX and TX + GND to FTDI and readed settings with U-Center and saved to file.

    E. Compared two setting file and found:

    1. APM turns SOL -message on. Without it we cant get HDOP and SAT COUNT (i had already noticed that  those were missing).

    2.In the NAV5 message APM wants to change Pedestrian mode [0x03] ---> Airborne with <1g Acceleration [0x06].

    All other APM  settings seems to be same as in the CN06v2.0_NEO6M_ublox_6_APMMPNG_config.txt(Arducopter).txt

    I might check again with similar way differencies with AC3.1 and config file.



  • The AP_GPS_UBLOX file that's on here wont work with the new firmware. I tried compiling several times and come up with bunch off errors on that file. Does anyone has the updated one?

  • Hi,

    just for your information.. move your ESCs away from APM and GPS as far as possible. So nearby your motors. That helped for me to get +1 Sat. Some ESCs harmonics influence GPS..

    BTW to avoid APM is resetting GPS you must change the APM firmware. It's described in some very early posts of that discussion.

    Regards Christian

  • No, Scott. Changing and saving the settings doesnt help at all.

    According to Michael Naumov, AC overwrites your changes anyways, until you change the code.

    After that I tried to check my modified GPS receiver on APM2.5 by leaving my copter outdoor for about 10 minutes and to collect some statistics with shape of track on MP. And what I see: any modifications don't take effect on performance since you plug GPS receiver to APM.

    See here:

    That is the reason U-BLOX CN-06 V2 is running out of the box.

    So it doesnt matter whatever the U-Center shows you...

This reply was deleted.