APM Copter 2.9.1.b has been released


APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello all,

    I just ran into some strange effects.

    Setup: APM2.0, Arducopter 2.9.1b self compile (due to my flashing issue with APM).

    Story so far: After the initial update to 2.9.1, Hexa flies quite nicely in Stabilize and Alt-Hold - better than ever before in fact. However - loiter is a BIG no-no. The moment I switch modes, the copter takes off in random directions and occasionally at scary speeds. I can stop it though, if I just steer something - anything. In that case it just flies around like in stabilize until I release the sticks. a few moments later it goes crazy again.

    OK - the Mediatek GPS has not been known to be great and I had been planning to upgrade to the uBlox LEA anyways but for the record: Loiter DID work with 2.7. and 2.8 - just not as well as I would have liked.

    So I bit the bullet and got a uBlox and also a pair of 433 MHz radios for telemetry. The radios are a story in themselves but I have them working now (also within legal boundaries in Germany, I hope).

    Conversion today: unsolder the MTK from the APM2.0 shield (check - no damage, no shorts); I don't want to carry around stuff I am no using. Connect the uBlox - works like a charm at first attempt. Get a 3Dfix with 8 sats and HDOP1.9 indoors.

    Here comes the fun now: with my electronics stack sitting on the desk, fed by a battery, I connect APM wirelessly and notice how the articficial horizon is super-nervous. In fact it does all sorts of random stuff and the GPS also wanders +-5 meters.This is with the board lying on the desk. When I move the board, things stabilize quite a bit and the horizon follows my movements. Set it down and it gets nervous again. Sounds familiar? My Loiter-Behaviour?

    Disconnect the GPS (which is possible now thanks to the pluggable connection; the MTK before was always there) - artifical horizon dead stable and just does what I do with the board. Reconnect GPS - nervous; disconnect - stable...

    Is it possible that there is a fundamental flaw in the code somewhere that mixes up the slightly wandering GPS coordinates with INS-information? Interpolates GPS movement and uses that as input to the INS?

    I could imagine that being

    • in the Serial code - maybe mixing a buffer for the GPS and the MPU6000 (which is on I2C, I believe?)
    • In the new INS code - as mentioned, this behaviour was not there in 2.7 (I didn"t fly 2.8 a lot, but generally Loiter was stable as far as I recall)

    I recall seeing a thread about Loiter performance with uBlox and MTK a while ago but I can't find right now.

    Maybe someone can enlighten me.

    Regards, Otto

  • I just updated my APM to the latest version of 2.9.1.b and then i did an auto trim i found my Quad flew more stable with the default setting's then it did after the auto learn why would it do this ? i am also going to try my first loiter and wish to know if the setting's for loiter are in inch or meters.

    Thanks for all that you guy's do 


  • Hello all,

    after upgrading my firmware from 2.8.1 to 2.9.1b on my APM1 , the  altitude_hold does not work any more. I am using the XL-MaxSonar EZ0. I want only to fly near the ground with a maximum height of 3m. In 2.8.1 firmware I was able to achieve this very precisely (error ~ 5cm). Now with the new 2.9.1b firmware the ArduCopter altitude_hold is not precise any more. for example when i hold ArduCopter 1 meter above the ground, the altitude value in Mission Planner is jumping over the time. Even after disabling the sonar the height measurement is still worse than in older version of firmware. I found it more practical to keep the sonar for low level altitude_hold (4 meter) while using the pressure sensor for higher level.


  • Hi,

    I uploaded 2.9.1.b, but I have some problem with my hexa. Stabilized mode is very smooth, but loiter is very wobblish. I tried to tune the params, but without success. Bigger problem when I switched to RTL and the hexa approached the starting point it tilt to the right and went away. I had to switch back to stabilize to save my hexa.  

    Here is my log file maybe somebody can help me what is wrong. 


    2013-05-01 19-00 77.log

  • Developer

    I pray every volunteer testers to leave your feedback about the version 3.0.0.rc1 available only for expert users on GitHub (downloadable here), you can interact and leaving your comments in this discussion but of course, first update your APM, calibrate manually the compass and declination, try it and post your impression!
    Remember: there's safety system on V3, you can't arm the motors if you compass or accelerometers value are wrong or out of range!

    In the first post there's my parameters.

    Thanks, Marco

  • Hmmm... I just took a look at the news on, they now offer an external acc board for better alt hold. They use a 3 axis R9500 mems sensor, which is working on the basis of thermal changes and promises not to be affected that much by vibrations like "normal" acc sensors.
    Could this be implemented as external acc sensor on the apm?
  • How about an option in the next Mission Planner to let you choose Internal or External Compass and if External Compass, allow your choice of orientation ??

  • Why there are new or different parameters between 2.9.1b and 2.9.1b_dev?

    I did a compare the list of parameters between 2 release and I did see new parameters in 2.9.1b_dev which are not in 2.9.1b or vice versa.

    This is somehow confusing. I understood that between 2.8.1 and 2.9.1 there are new difference, but I did not expect between  2.9.1b and 2.9.1b_dev.

    I did load 2.9.1b_dev as firmware, but using the 2.9.1 param (save in file) and looks Quad it responding different.

    Should I keep the default params coming with the firmware release and just adapt the parameters I need?

    When I said  Quad it responding different I am refering to Loiter and Auto and GPS (MediaTek) functionality.

    With 2.9.1b I can not more use the Loiter or Auto, GPS is jumping as crazy.

    When I switch from AltHold to Loiter, Quad is reacting aggressive (someone said as a Porsche .. I totally agree)

  • So is it just me or does there seem to be an abundance of "I crashed" posts lately with the new firmware out?

  • 1st, much appreciation of the work done by the devs.

    Old noob here who just spent more than a week getting bluetooth to work (yea no USB) with FW: 2.8.1 & MP: 1.2.44 ... had BT etc working perfectly, and was ready to calibrate and tune ...

    Then I succumbed to that "Update now" to MP: v1.2.48 and now BT is KAPUT ... I assumed I needed to upgrade FW and got v2.9.1b ... but still no BT.  I have exhausted my troubleshooting skills. Error detail enclosed ... please HELP!

This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022