ArduCopter 2.6 released!

Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!


Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.


The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.


Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]


Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]


PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).


Happy flying!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I tried to run and auto pilot mission last weekend. Im not sure I have the settings correct. The plan basically was to auto take off to 5 meters then after 30 second to go up to 20 meter, then 100, back to 40 then 20 and then land. But all it did was take off to 5 meters and just stayed there.. Can someone please look at the file and let me know whats wrong with it?

    ElevMiss 5m 20m 100m 20 RTL.txt

  • Just had a look at some old logs.

    This is what my mag log looks like:


    Is this how it is supposed to look like?

    Seems like a lot of noise to me.

  • What’s the LED_MODE parameter? I noticed that on 2.5 the default is 0 and on 2.6 it’s 9?

  • I still have an issue with GPS... I get a solid blue light on the GPS Unit, but the mission planner (connected via Xbee) does not pick up GPS signal. 0 satcount, but solid blue light... My GPS location does not show on the mission planner.

    I am running APM1 with 2.6 (modified for octo quad)

    Any help would be appreciated.


  • Having a strange RTL issue with 2.6 : when activated, my tri always bank toward an apparently stochastic direction and maintain it's angle until I switch over to stab. I have the APM2 with stock MTK GPS, and a well tuned loiter. MinimOSD should display an arrow showing home direction and distance but doesn't, so I don't know if it's osd-related or AC having trouble to set the home point. Is there any way to tell where the home location is with telemetry and MP ?

  • Hi,
      I’m  setting up my APM2 with V2.6 software on a Tricopter V2.5 with DT750 motors, 9x5 2 blade props, 20 AMP Hobby King Blue series ESCs and a 3cell lipo  .  I have the yaw pretty much sorted out and it  flies well in Acro and attitude modes on the stock parameters.
    However I have a trim problem in Acro mode. With the stick neutral it tries to rotate backwards and I have to use about 3/4 of the available trim for it to stay put. It seems that the controller is not seeing the the neutral position on the stick as neutral.
    I have tried the following
    1- I recalibrated the radio twice.
    2- I recalibrated the ESCs.
    3- I swapped the rear motor with a one from the front 
    4- I checked the C of G and tried moving it forward and this helped a little.
    5- I moved the forward arms backwards about 20 degrees each and I could get rid of the trim but it still feels like it is not seeing the neutral position properly.
    6- I put my rabbit controller back on put the C of G and the arms back in the right place and it still flies fine.
    Any advice would be appreciated
  • Hi,

       I have some problems with logging.

    Some time is working, most the time not.

    Usually I get following messages:

    Init ArduCopter V2.6

    Free RAM: 2346
    FW Ver: 118

    load_all took 7768us

    Press ENTER 3 times for CLI

    GArduCopter V2.6] logs

    8 logs
    Log 1,    start 1,   end 1
    Log 2,    start 1,   end 1

    I erase all and get:

    Log] !!Allow 30-90 seconds for erase
    ?3 ?Erasing logs                                      ???3?Log erase complete                                logs enabled:  ATTITUDE_MED GPS PM CTUN NTUN CMD

    No logs


    After flying get again first message...

    Any ideas?

  • I have an issue with GPS...

    I get a solid blue light on the GPS Unit, but the mission planner (connected via Xbee)

    does not pick up GPS signal.

    0 satcount, but solid blue light...

    Im at a loss!

  • index.php?action=dlattach;topic=28978.0;attach=204759;image

    look at the video.. my problem video result still not smooth.

    my quad frame X650, 2.2kg (included 4s , vtx,gopro), APM2 FC, v2.6

    i use MC6500PRO camera gimbal and MP set gain set to 3 (faster response for camera gimbal)

    quad all stock PID except STAB ROLL / PITCH "P"  value is 3.5.

    the quad seem flying smoothly.


    1) is it i need to lower my STAB ROLL / PITCH "P"  value to let says 2.0? to get smooth hover/flying so that my gimbal will stabled and not to push to hard?

    2) i have no idea how to set YAW setting. when STAB mode, push YAW stick slowly and quad bounce back

    thanks for answer..

  • Just built my first Octo. Hobbyking F-30A , Turnigy SK3 3530-1150. (2)Turnigy 6000mAh.  APM1-2560, with firmware 2.6

    During a calm flight everythng is fine. If I bank hard, it seems like the ESC's go nuts.

    You can hear the strange sound in the video

    Do you guys think this is a ESC problem, flight controller problem, or something else?  Any advice would be awesome.



This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25