ArduCopter 2.9.1 Runaway on Auto-Takeoff

I have been working on making my flights more autonomous and so far I have had a great deal of success.  The setup shown in the video has made eight successful fully automated flights with no operator input from takeoff to landing.  This flight was different, and I would appreciate some assistance trying to determine what went wrong.

I planned a simple mission with a takeoff to 50 meters, three standard waypoints, a RTL, and land.  The quad ascended about 2 meters and made a hard bank into the trees.  Wind was about 20kts to the SE, so the quad was flying almost into the wind.  Below is a recreation of the actual flight path the aircraft took.  The KML appears to show the aircraft traveling in the opposite direction.

Note: The "Home" location shown below is from the second time the motors were armed when I flew out of the tree.


Damage Pics:



2013-03-13 12-30-54.tlog

2013-03-13 14-48 5.log


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had the external compass installed 180º wrong. So it was doing the same as your copter. I just put it right and now it works great! 

  • Hmmm...I had a very similar thing happen today.  I performed a flawless autonomous flight and after landing and waiting for a few minutes tried the exact same flight.  The copter took off and headed at top speed in almost the exact opposite direction.  I hit RTL to no avail and tried to go to manual but it was too late.  It is a minor miracle that mine was not damaged more than it was.  I lost a video transmitter antenna, some landing gear, a battery, and a couple of props...

    Logs are attached and video is here:

    The telemetry is baffling to me as it shows the copter knew exactly where it was supposed to go and that it new it was heading in the opposite direction....

    2013-03-23 17-13-40.rlog

  • Hi CodyO,

    Does the light blue track on the mission planner stay stable around the copter on the ground before launch?

    I find that the Media Tech GPS is slow and not as good as the UBlox Lea6 version. It can show the gps tracking around my general location to around 10-20 m when on the ground and near trees and takes up to 5 mins to lock on. The Ublox gets reception indoors sometimes! I give the unit some time to lock on, even when the system says 3D gps is locked. Just check on the mission planner that the little blue track isnt looking like a worm thats been cut in half :)

    Also, get your telemetry log and look at the stats as its playing. see if all gps sats were good and maybe the magnetometer can be seen too? Someone else might give advice on this.

  • Sorry about the bad flight!

    Grab something like this and hook it to an unused channel if possible. Great for locating tree-dwelling copters.

  • Well, it's back on its feet.  This frame is an absolute beast!  The bottom plate needed some hammering to flatten it back out.  I bent the arm back into place on the edge of the workbench. Liberal application of plastic epoxy has the landing gear back together. New props too, orange this time to make the aircraft more visible in pine trees!

    I felt like I was living an episode of Star Trek, but I scanned the launch area with my cell phone and I discovered a strong magnetic distortion near the ground.  This must have confused the sensors on takeoff.  It looks like verifying compass direction will be added to the pre-flight checklist.


  • Wind was strong could have affected the flight characteristics, compass not calibrated is my guess since it went off in opposite direction.
  • It was an interesting video to watch. Can't make any comments unfortunately; new to APM:)))

    I am pretty sure someone will chime in...

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25