ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.


4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,

    Yesterday while I was filming some aerial footage for a commercial I crashed the octo, I was returning to land after a take when suddenly I lost control, at the same time I saw one motor stopping, and as I can't retake the control, I pull down the throttle and I wait for the crash. This flight was the 9th of the day without problems in the same location. Only in one flight I saw a problem like the fence limit but I don't use it, I was flying forward and suddenly in one point it pitch back like if it was crashed with a wall, but after this the flight was normal.

    The main battery (6S) ends with 20 volts during crash and up to 23 volts after shut down the motors.
    The APM2.5 battery (2S) ends with 8 volts and I am using the align regulator to power it via output rail.

    As consecuence the gimbal is broken, my 7D is scraped, the lens is broken, one brushless motor of the gimbal broken, but the octocopter is right only has two arms a little bent, but all propellers are ok.

    If you want I can put some pictures.

    Anyone can help to discover the cause of the accident. Thank you very much.

    P.D. the tlog file was made with Droidplanner in a SGS2.

    2013-07-20 17-32-58.tlog

    2013-07-21 11-56 13.log

    • Buona sera sono Francesco di Italia.
      fastidio perche 'ho bisogno di un vostro grande gentilezza e Pablo Il mio sogno' "inventare un nuovo lavoro", fotografo, ma sono senza lavoro, e vorrei costruire farmi un Drone a otto lame per introdurre dove provare a lavorare con fotografi DRONE ..
      Purtroppo ho pochi soldi e non posso permettersi di fare errori e che avrei avuto bisogno QUI, (se potete) Il vostro aiuto mi guida passo dopo passo con le immagini, o meglio credo in costruire il mio primo drone (io sono un radioamatore, quindi capisco un po 'di elettronica) e ho grande pazienza e l'artigianato, ma devo imparare da voi (se poteste farmi dire, da maestro).
      sarei enormemente grato , mi dice cosa comprare (e come impostare che immagino essere la cosa più complicata).
      Tuttavia, se si decide GRAZIE gia 'rispondo.

  • the release fly very well ! but i'm not capable to setup althold , every time to switch in this mode fall down until touch ground and stay  about 10 cm and stay here , or lift up in the sky...

    there is definitely a problem that I can not identify ( hardware??)

    Whati is the right procedure to setup please?

    I have APM 1
    xbee 900
    Hexaframe like dij (compatibile)
    4S 5000mA
    Mediatek gps

    I do not care to be accurate as of version APM 2.5 , i'd like only to fun fly

    2013-07-21 11-34 5.log

    2013-07-21 11-34 5.kmz

  • This is a minute version of a recorded flight with 3.0.1. Reported by MinimOSD there was a lost in altitude, from 78 to 0 feet in mid-air after switching to Loiter.  The MSL altitude, showed no drastic change.  I assume Home Altitude is using the pressure sensor, the MSL uses GPS.  I am not sure if there is anything to be concerned about, but I just land, re-armed and continued testing. I wonder what would happen if I was in Altitude Hold Flight Mode?   APM is in a 3DR case and black sponge in it.  Unfortunately, I was doing a lot of tuning, completed another CompassMot and wiped out the log files.  I also noticed the loiter was leaning.  Anyone with a suggestion, let me know.  Thanks.

  • Randy, got a question. I have tried ArduCopter 2.6, 2.9.1 and 3.0.1 and Im having the same issue over and over. I got the previous yaw situation worked out, but now Im having another yaw issue. When I start the flight, the Copter goes up, I put it to a hover and let it stay there. After a few seconds, it will rotate left approximately 90 degrees, hover for a few seconds, rotate 90 degrees, hover and repeat this process until I land it. Is there a calibration that I missed somewhere along the way?

  • A huge thank you to the developers and a special thank you for you Randy, all your useful videos and dedication much appreciated.

    I just wanted to give something back and share a vibration dampening scheme I used for a while and had not realized just how good it is, I was all ready to try Moongel and various pads, no need to now.


    Full details here

    RC Groups - View Single Post - APM 2.5 / Ardupilot Mega / RCTimer Arduflyer Discussion Thread (upda…
    RC Groups - the most active Radio Control model community: electric and fuel rc airplanes,rc helis,rc boats and rc cars. Features discussion forums,…
  • RTL is working, so I believe my GPS is working properly; however, after moving to 3.0.1 (which, for me, coincided with a Mission Planner upgrade), my KMZ files are plotting everything at about 12,000 ft rather than 6,000 ft.  Does anyone know what might be causing this or how I can fix it?


  • Well, four good flights and my copter is out of commission again. 

    I flew two flights last night and two flights today at the park and everything worked great!  I stopped my fourth flight a little early because winds were picking up.  On the way back to the car I noticed that the wind was spinning one of my props --- only one of them. 

    I tried flying again, but now I can't safely get it off the ground.  The props all start spinning at the same time, but one runs faster than the others and tries to flip it over.  Once the props are spinning, if I set the throttle to zero, the faster prop still gets power and spins for another two seconds or so.  It's not simply decelerating more slowly, it definitely seems to be getting power for another two seconds.

    Sorry, the video is sideways.  Any ideas?  I tried recalibrating the ESC's, but it did not solve the problem.

    Thank you,






  • I just wanted to drop a note to give my thumbs up for the "compass learn" functionality.  I've been unable to use 'live calibration' --- tried it 7 times and got 7 very different results.  I used the compass learn and now my RTL seems to be functioning well!


  • Great Job, thanks :) my first cuad with 2.91b  had problems to mantain alttitude  hold and loiter,and unstable in windy days; updated to 3 and solve the problems, now perfect loiters and I can fly in windy days too; I closed with tape lateral pins near the baro because if I blow there, the altitude  go down, i supose that help too

This reply was deleted.


Santiago Perez liked Santiago Perez's profile
19 hours ago