ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.


4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Your best bet is to use google to search the site. Do a search like this: gimbal
  • any idea why the search function is not working to search other forum topics ? It just comes up every time with

    Our apologies - we couldn't find any discussions matching your search.

    regardless what key work I type in there.

    I am looking for any topics related to using a brush-less gimbals with it controlled via the APM boards gimbals controller and how to set this up. I even typed in the word "brushless" and "gimbal" on their own but still same result.

    Any ideas?

  • Quick question,

    When is the gps glitch fix coming to the beta release or is this only happening with the new pixhawk controller?


  • Hi!

    I Just crasched my new F800 due to some strange behaviour of the APM...

    The Flight started normally and i was flying in alt hold. Suddenly the motors went totally erratic. Swiched to stabilise and it disappeared but came back again, tried AUTO and RTL but still erratic. Back to stabilize and taught I had control for a moment then it started again and then all motors suddenly stopped at 10 m altitude and she fell like a dead crow... The tlog stopped as well in air...

    When i came to the crash sight all esc:s where beeping like lost signal the APM looked like it was still running.

    If you look at the graph the throttle values went berserk at time 13:57

    I would appreciate some help on this issue!

    So I dare to take her up again after repairs.


    2013-09-19 13-44CRASH.tlog

    s800 FINAL.param

  • So my quad has been flying great for probably 20+ flight now.  Flew it once yesterday and it flew great.  landed to put a fresh battery in.  Took back off and it was wobbling back and forth like the PID's weren't set up.  Any ideas?  didn't change anything but a fresh pack (same kind and size)  Hooked it up to the computer and all the settings are the same. 

  • Hello,

    is acro mode changes are in 3.1rc2 ? 

  • Has anyone use the gimbal function for brushless gimabls? How is this done?

  • Hi Randy,

    Some PID's (Selected for Ch6) are not in the dataflash log even the Group PID is selected for the logs.

    e.g. Stabilize P. Attached Param file and the log.

    Michael told me thats not a Problem of MP.


    2013-08-25 09-54 1.log

    Param Report.param
  • Developer

    We uploaded AC3.1-rc2 to the beta firmwares area today.  Just one significant change which is a bug fix for the MOT_SPIN_ARMED issue.  The maximum value that could be provided was 127.  This has been updated so it can be anything below THR_MIN.  Because of the change in the underlying variable, when you upgrade you may find that you need to update the parameter if you want it to be different from the default which is 100.

    Also I forgot to mention that it is now possible to remap the first four channels using RCMAP_ parameters.  Apparently you just set the inputs channels that you want to use for roll, pitch, throttle and yaw by setting RCMAP_ROLL, RCMAP_PITCH, RCMAP_THROTTLE and RCMAP_YAW to anything from 1 ~ 8.  Please note though that there may be an issue with the throttle failsafe when the receiver loses power.  I believe that channel 3 will always be pulled low even if that is say mapped to roll, pitch or yaw.  Any feedback on this would be helpful - it may be that we need to provided a new version of the ppm-encoder.

  • Hi All, I've been using APM to control my own designed quad since version 2.0 with APM1, I must say, quite succesfully. Improvements from one version to the next are always noticeable and if you follow instructions and handle everything from construction to configuration carefully it always works very well.

    I have now an APM 2.5 and decided to move from V.2.9.1b to V.3.0.1. I notice right away with compassmot calibration that I had a very hard magnetic interference (over 100%) that took me some time to find and end up being easier to solve than I thought. I have a long cable from the battery to my distribution board going under the APM. I just placed the battery differently and now the magnetic feel is out of reach (12% on compassmot).

    The quad flies very good under "Stabilize", "Alt-hold" and "Loiter" probably even better than it did with V.2.9.1b. Normally flying very gentle but very firm at the same time and never getting unstable even when I move the sticks very hard. However, when I execute a mission to test "Auto", it goes to the first waypoint very precise and nicely, turns to head to the next waypoint with no problems but then pitches forward violently, starts to oscillate and looses altitude. Switching back to "Alt-hold" or "Stabilize" gets it to rest again.

    I'm attaching logs from this test fly a couple of days ago hoping that someone can give me a clue on what's going on. As I said, my quad is own designed with 12x4.5 props, 1000kv and 210W brushless, 620mm between motors and 1.8Kg total weight.


    2013-09-13 20-20 2.log
This reply was deleted.