Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi all.

    I had a crash yesterday after flying in loiter simple mode.  I was doing pirouettes whilst flying in a large circle.  I noticed that the copter started banking quite a lot so I stopped the pirouettes and the copter became unresponsive and crashed twice.  Here is a link to the on-board video https://www.youtube.com/watch?v=hwLTbjDAzsg  I did not have telemetry running but have got the onboard log that I will attach.

    I don't know why it would not respond to radio and I tried all modes before it crashed.  It could be pilot error but it seemed like the apm got bogged down and would either not respond or was running very slowly.

    I would appreciate if someone could have a look at the log and see if there is anything obvious in it.

    Andy.

    2013-11-09 16-04 2.log

  • hi guys..

    so i solved my pulsing and wobbling problem... turns out it was an esc that was going bad.. after replacement all is fine..

    i then loaded rc-5 and ran auto tune... everything is actually working great..

    loiter, rtl etc..

    I have a few concerns tho...

    1) The tuned values work well when there is no wind.. in the wind it gets blown around like a sail...

    2) Alt hold drops alt as I am moving forward...

    3) i cant seem to yaw in place in stab or in loiter mode.. using the default PIDs it yaws in place fine in stab but NOT in loiter...  

    Can anyone give me some input on what PIDs and other params to check for 1,2,3..

    here is a screen shot of my current PIDs after auto tune..

    PiDs_autotune_RC5_09_11.jpg

  • I have built a new quad and tuning is going well apart from a small problem with throttle in alt hold. When the quad is in alt hold mode you can see it move up and down a small amount very quickly and a fast rpm change on the motors. How can i tune this out have tried tuning all the throttle and alt PIDs with no luck.

    Throttle.png

  • Hi Randy and Leonard,

     

    Attached herewith my log on AC3.1-RC5. So far I have no complain, fly so well even though I have a motor issue. :)

     

    By the way can you check if I have an acceptable vibration on board?

     

    thanks.

    2013-11-10 18-51 3.log

    2013-11-10 18-51 3.log.gpx

    https://storage.ning.com/topology/rest/1.0/file/get/3692876835?profile=original
  • Hi Randy & Leonar

  • Today first flight on my new Okto frame (MK square type) with Kit APM 2.6 + uBlox with Compass, T-Motors MT2216-900Kv, Graupner eprop 11x5, Esc's HK F40 SimonK, battery 4s.

    Problem:
    With total weight 3.7 Kg, On stabilize Okto fly smooth, very fine, Hovering throttle is on 450, the weight is right.
    When I switch on Althold the motors pulsating and OKTO doesn't keep the altitude.
    On Stabilize the motors are OK.

    If I remove weight (800gr) and leave only the batteries, now total weight is 2.9Kg
    Now when I switch in AltHold the motors runs smootly, okto keep altitude and it flies well.

    Here graphs Throttle_IN and Throttle_Out (you can see first flight with high weight - 3.7Kg, land, second flight with only battery - 2.9Kg, land, another flight with High weight etc.)

    ci6x.png


    Here graphs of the same fly of vibrations accXYZ: ( vibrations are smaller in the flight without weight)

    5ivt.png

    Here video of this fly. (you can see motors pulsanting on AltHold)

    https://vimeo.com/78992335

    I tried to edit PID Throttle_ACCEL_P Throttle_rate_P without good results;
    I tied to edit Altitude_Hold_P and I noticed high frequency motors pulse at low value (0,500) and a bit low frequency motors pulse at big value (2.000). 

    My Question:

    vibrations on the Z axis could be the cause, even if they are between -5 and -15 ?

    Ciao - Giuseppe

    2013-11-09 15-41 1.log

    2013-11-09 15-21-20.tlog

  • Where can i find the pixhawk release topic?

  • Developer



    All with APM Copter V3.1 RC5, please watch at 1080p.
    Sorry but the Youtube video encoder is a horrible thing, the quality of the original source is much higher.
    90% of the shots were taken in Loiter with Simple, the filmer controls tilt/roll of the gimbal and yaw of the multirotor.
    Here my "Speedvision", used to create this clip:

     

    3692875948?profile=original
    Bests, Marco

  • Hi Randy,

    I urgently need your brain to help me understand what's going on after radio f/s. Bare in mind I have an rx which in PPM mode doesn't behave exactly as most of the rx's. My rx doesn't switch of PPM in case the tx is lost (e.g. switched off). Instead it just outputs empty PPM frames which the APM ppm decoder interprets as 0.9ms pulse (i.e. -150% = 900 displayed in MP) on all channels. This leads to a two seconds delay (radio.pde) as there is a hard coded timeout of 2000ms in the code before switching to RTL if f/s is set.

    But this is not my problem. As already mentioned in a post about the ppm encoder it is the very scary behavior after RTL is initiated by radio f/s that is bugging me. Keep in mind when radio f/s in initiated in my setup all channels including aileron, elevator and rudder are fixed at 900. As soon as RTL is truely initiated after the two seconds delay, the copter starts tumbling and yawing as you would see let's say in stabilize mode with the sticks fully deflected.

    My only explanation is that during RTL pilot control is still possible. And it looks for the APM as if the sticks are fully deflected in my case APM does what it is commanded to. Full roll/pitch and yaw.

    Please have a look at the attached log. After a 3 min.flight I landed and made the worst beginners mistake. I switched off the tx with obviously the APM still armed. No blame on the APM here. It did what it had to do. Sequence of events:

    - after landing and throttle to zero I switched off the tx (most likely still armed)

    - about two seconds later the copter took off on it's on and climbed rapidly to about 50ft (I guess my set RTL altitude).

    - Then it started yawing at full rate while tumbling as if roll/pitch controls at maximum.

    - I tried to regain control by switching on the tx again and flipping my mode switch between stabilize and loiter.

    - Regained control in loiter then stabilize, copter was immediately leveling and stopped yawing

    - Landed scared but safely

    Is my assumption true that pilot control is still enabled in RTL true? In radio initiated f/s? 

    Thanks for your help

    Michael

    Atlanta glitch 2013-11-07 19-16 32.log

    https://storage.ning.com/topology/rest/1.0/file/get/3692875350?profile=original
  • I've come across an uncommanded movement while in loiter mode twice now in the last week. Running RC5 on a moderate sized (3.2kg) quad.

    Most of the time loiter will work well, but the first time the other day I noticed the copter was moving quickly backwards in loiter when I had all sticks centered. I had to quickly switch into alt hold mode and bring it home. A subsequent flight after that didn't have issues with loiter that I could see.

    Again today I was in loiter, looking at the fpv screen, and looked up and the copter was about 15m away from where it previously was, and accelerating sideways. Had to quickly switch back to alt hold and save it.

    I'm pretty sure I have the vibrations well under control. Am running an external mag, and the gps receiver is raised up above the equipment platform.

    Here are the logs - first flight - uncommanded movement around line 8000 - pitch in shows no input, but there are two sharp downwards pitch spikes: 2013-11-04 11-17 281.log

    dhyn.png

    second flight - uncommanded roll movement to the left around 10:05:30: 2013-11-08 09-57-46.tlog

    id3a.png

    Dropbox - Error
    Dropbox is a free service that lets you bring your photos, docs, and videos anywhere and share them easily. Never email yourself a file again!
This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…