Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Guys, Randy,

     

    Just a simple question: is there a difference between a radio f/s initaited RTL and a mode switch initiated RTL?

     

    Thanks,

    Michael

  • Regarding RTL bug, here is a clip describing the behaviour. (you also have the .log file, the clip is the last RTH issued in log)

    The copter is well tuned as you can see in previous clip with autoland

    2013-12-10 18-31 43.zip

  • At Evening. I had test flight with Arducopter 3.1-rc8 Duo Quad. They are very stable with Loiter modes and RTL.

  • Arducopter 3.1rc7 radio failsafe with RTL autoland and auto-disarm - 1 minute flight

    raw video on dropbox here:

    https://www.dropbox.com/sh/pmwgdi6guv02f4p/a_lHe1oiDE

  • With regard to my problem loading newer versions to my X8...

    Good news:

    I changed computers and got the firmware to load. No problem, went through all of the steps right away. After the load it does a verify, and the only thing I could see was that the verify slowed down quite a bit as it progressed, but did finally terminate, without errors.

    Bad News:

    I am still not able to connect with MAVLink (on either computer). I can see the Mission planner polling, and on the first poll, the card responds, but it doesn't respond again after that.

    A small caveat..... Since I don't want to put my X8 out of commission, I'm testing on a second board which is a (gulp) CRIUS v2. Just to clarify. Initially I tried to load the 3.1 rc7 (at the time) directly to my X8, which didn't work. After trying several times, I went to this clone so as not to leave me without the X8.

    So is this a (generic) issue with the clone, and should it be safe to try to load my X8 now,

    Please any ideas welcome.

  • I thought I'd try out the HIL (hardware in the loop) version of  3.1RC8 and FlightGear to test out the hardware and simulate flying. (This is the first time I've tried using this by they way.)  I followed these instructions: http://copter.ardupilot.com/wiki/hil-quad/

     

    What functionality should work with HIL? I noticed that I couldn't calibrate the compass or accelerometers and that lots of the parameters weren't changing in the Flight Gear HUD. The altitude value didn't change even though I could use the R/C to arm and fly the quad to high altitudes and change the pitch, roll and yaw of the model even though the HUD text values in FlightGear and the MissionPlanner didn't change. I did see changes in the MP's Roll and Pitch graphical display.   (Are most using the software in the loop approach to simulate flying and test firmware as described here. )


    Here's what the HIL setup looked like for me:

    3692896728?profile=original

    3692896639?profile=original 

  • Hi Randy,

    My quad seems to loose control during stable mode.  See logs.

    I take off in stabilized mode and as I throttle up, the quad continues to elevate and becomes non responsive to

    negative throttle.  The result was a crash (not too bad).  What is the problem?

    Ardcuopter 3.1 rc7

    2013-12-08 21-10-28.rlog

    2013-12-08 21-10-28.tlog

  • So glad we WILL be at 3.1 soon so all those that keep posting the wrong rev number will be right and we, the others, won't have to keep thinking to realize that they are still using 3.0.1.... ;-O

  • Hi, got 3.1rc7 done autotune and things are great!

    I got all flight modes working fine and i'm happy with apm 2.6 performance.

    I like althold mode to fly around but would like the gps lock feeling that loiter gives you when you stop. althold tends to drift a bit

    Is it possible to get loiter mode to fly like althold does(more snappy feeling)?

    What i have found is that loiter(default pids for loiter) it tends to have a rocking swinging feeling(like a boat) when you full forward or when you stop.

    when i go full forward it tilts fast forward but level out very fast(and continues leveled out) and when i release the controls it tilts backwards fast then tilts forward fast then levels out(swinging motion).

    Now is this normal in loiter mode? Because after all this time i can't seem to find any videos on the net with people flying fast in loiter all that i see is people using it to stay in the same place.

    Any info on this subject would be great!

    There hasn't been any great info for loiter tuning on the net that would be very helpful the wiki explains loiter pids but i just cant get my head around it.

    Autotune sorted out the rest :) 

  • Developer



    All with APM Copter V3.1 RC7, Youtube video compressor is horrible, pm me if you want to evaluate the quality of the full raw file.
    For other info see the description in the video page.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race with @a1k0n at @diyrobocars We both decided jumping over the wall was the way to break the 11s lap time. Th…
Aug 14
More…