Developer

ArduCopter-3.0 ready for wider use

ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

http://ardupilot.com/downloads/?did=63

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3691031698?profile=original3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691032069?profile=original

3691032034?profile=original

4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

http://copter.ardupilot.com/wiki/common-ppm-encoder/

http://copter.ardupilot.com/wiki/common-ppm-encoder-apm2x-atmega32u2/

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions        http://www.youtube.com/watch?v=33Tl_rjhQEE
AC 3.0 "Live" Compass Calibration  http://www.youtube.com/watch?v=DmsueBS0J3E
AC 3.0 CompassMot Setup                http://www.youtube.com/watch?v=0vZoPZjqMI4
AC 3.0 Pre-Arm Checks                      http://www.youtube.com/watch?v=gZ3H2eLmStI
AC 3.0 Fence                                         https://www.youtube.com/watch?v=HDnGdo54o-4
AC 3.0 Maiden Flight Checks             http://www.youtube.com/watch?v=NOQPrTdrQJM

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am currently running 3.0.1rc1 and have had a slight issue on my last 2 flights. During a loiter at around 30m the altitude suddendly started to increase as though I had increased the throttle and as a consequence had to throttle back to around 25% throttle before it started descending. I then landed while I still had good control. However looking at the Tlogs of both flights around the time of the issue the altitude remains pretty contant as you would expect in loiter and does not register the altitude increase but it does show the CH3 (throttle) output increase from aroud 1560 to around 1700 which would explain the real world altitude increase.

     

    Andy.

  • Developer

    Hi all,

    I just put together a blog post describing our proposed ACRO mode for ArduCopter next.

    I am looking for early feedback from those game to give it a go. And discussion from ACRO enthusiasts.

    http://diydrones.com/profiles/blogs/acro-for-ardupilot-3-1

    Thanks.

  • Very good work on Arducopter 3. The improvements have been great so far.

    I have only one small problem remaining, I get bad GPS data on initial take off. I have run the compassmot and got a result of 17%. My ACC graphs have around +/- 1. Shortly after the take off (<30 sec) my GPS position returns to normal. I can then loiter for as long as I want with no problems. I have attached a .tlog (see from 24-50%). Is there any way to fix this?

     

    2013-06-28 08-18-33.tlog

    https://storage.ning.com/topology/rest/1.0/file/get/3692759186?profile=original
  • Hi, Just like to say ... BRILLIANT ! updated to 3.0.0 last week .... loiter rock solid (neo 6 v2) even in 12 - 16 mph wind, circle mode, really works well ..... Well done all responsible ...I am having great fun with this !

    Incidentally My controller is stuck on the top with two layers of double sided foamy type tape ....(I have ordered some moon gel) ...but all seems well ....? so I think I am going to leave it.

    Oh is it just me or is live compass calibration a real pain ? I nearly fell over last time I did it !

    I see with Waypoints .. you don't have to put extra one in now ..... (I wish I had know this it nearly landed on me)

    Good job though 

    A

    P6192256.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3692759197?profile=original
  • Double post. Sorry.

     

  • Joined the fun and installed V3.0.1-rc1 on a new 3DR APM 2.5 for a flamewheel F450 quad. Everything at default, except rate Control P 0.158 and the recommended WPNAV_ACCEL to 100 and Loiter PID to 0.2 .  I must say the first thing I noticed is switching to Loiter is very smooth.  CompassMOT is still at 107%, working on reducing it.

    Both RTL and Loiter works, however with a few unusual behavioral.
    1. Duplicated the same scenario 3 times.  The RTL just rises to the specified height and stays put for almost 20-25 seconds, before it heads back, but it does return home, which is promising.  While returning back the copter does not always face front, it can come back facing 30 degrees away.  My test was 220ft (67m) away.
    2. Same problem that a few people reported.  It tends to yaw (rotate clockwise) on stabilize or loiter, any suggestion on how to tune the yaw?.  Did not yaw on 2.19b.  Re-calibrated ESC and Level. Reviewed GitHub. 

    I have been following Randy's and Marco's videos a long time, thanks all.

  • First, Marco, I'm a huge fan, I appreciate your efforts and the time you take in your Demo's....

    I do have tons of experience with the RCTimer F800 M6 (not S800) and I can say the HP4114 motors are extremely well made and have a very low eddy current.... But you still have an EMI issue..... I noticed in your video that your battery is located on top of the frame....My experience is to keep my lipos as far from the FC as physically possible as most LIPO's under current draw emit tremendous EMI.....May I suggest you try same test with the lipo and related wire as far from the FC as possible.

    Thanks for the work you have done and continue to do

    Randy, same respect to you as well

    Kendall

  • Wonder if you could get a normal helicoter to hover like that. If u could Ide be amazed.
  • Hi Randy,

    I’ll not describe the all Via the La Rosa; I’ll jump almost to the end:

    I didn’t get the Loiter and RTL to work, so I load the parameters from a friend with identical setup.

    The quad was Loitering and coming home. It was the last minute of the day and a good ending.

    In the morning I ran to the field and I couldn’t get it armed. I’ve got a message to calibrate the compass.

    After calibrating it was flying but no loiter and no RTL.

    Today I’ve recalibrate the compass and the loiter was ok with few degrees (2-3) of drifting on the Yow.

    RTL, didn’t work.

    Attached the Tlog, I’ll be grateful to get some help.

    Thanks

    Itzik

    2013-06-28 07-55-56.tlog

    https://storage.ning.com/topology/rest/1.0/file/get/3692758255?profile=original
  • I just tried to upgrade to 3.0.1rc1 and got this error. I've seen it before when uploading to previous versions. Is it a sign of a board problem or just usb communication issues?

    3692758209?profile=original

This reply was deleted.

Activity

DIY Robocars via Twitter
Jan 28
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Jan 23
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Jan 23
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Jan 23
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Jan 22
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Jan 21
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
More…