ArduCopter-3.0 ready for wider use

ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link,, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3691031698?profile=original3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.



4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions
AC 3.0 "Live" Compass Calibration
AC 3.0 CompassMot Setup      
AC 3.0 Pre-Arm Checks            
AC 3.0 Fence                               
AC 3.0 Maiden Flight Checks   

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've just upgraded from 3.0rc5 to 3.0.1rc1 and am having trouble getting into terminal via xbee. Normally I'm able to do this within the 20 second limit so I can do my compassmot but it's not allowing me. Just doesn't go into terminal. I'm using 1.2.58.

  • Congratulations on some terrific coding. I am very impressed how exactly two auto missions flew exactly the same pattern.


  • Hi Randy - I hate to bug you but I have exhausted my debug skills and maybe you can spot something in the logs. Basically , my APM 2.0,  3.0.1rc1, x525 quad, UBLOX has been flying great under 2.9.2 - yaw holds even in tough wind, loiter good, missions good, etc.

    I have run the 3.0.1 download several times, run all the calibrations several times, got mag interference down to 14%, balance / level props, calibrate ESCs, and yet every time it yaws to the left - in AH or loiter it turns relentlessly to the left.

    I enabled all logs and did a test flight - what am I missing??  

    Thanks for your great work.

    2013-07-04 15-19 1.log

    2013-07-04 15-19 1.log.gpx

    param 3.0.1 basic setup-2.param

  • Hi.

    Can anyone tell me what the compass offsets are measured in ? is it degrees, radians, or magfield, or even something else? The reason I ask is that since I have had my apm 2.5 I have always had the Z offset up around the -300s whilst the X & Y are down under -100.  This does not seem to affect the flying but it does bug me.  If it is in degrees then #i would have thought my current -311 should be 49 ?

    I notice that very few other people get high figures like me on the Z.

    Oh and it is the same if I use the internal compass, although I use an external one.  I have even taken the compass off the quad and held it a good 6" above the quad and done a calibration but always get a number back in the -300s.

    I am using the latest 3.0.1 RC1


  • Hello randy, I can't seem to find the rc6, when i clicked beta firmwares it uploaded the rc1 only. And can't we use mp 1.2.53 on arducopter 3.0? Because im having lots of problems in the latest version of mp. Chris mentioned that on 3.0 you would have to enable compass orientation manually? Any tips how to do that. Cause i can't arm the motors after upgrading to 3.0 it says enable magnetic something like that.
  • Very happy with V3 on APM 2.5, especially Alt Hold. I cant believe the Stock PIS's are all I needed on TBS Disco with NTM 750 Kv. Easiest setup yet. Thank you


    Is the loiter 'rush' due to GPS? I replayed my flight (hovering) and saw that the GP suddenly went East 100m and I recovered and then S 100m. Was a bit of wind around. Very glad I turned down the PID's as instructed. Are the GPS Glitches, GPS glitches or V 3 Glitches?


    I could get my compassmot to 39% with only a 5mm move,

    Pretty happy with my Vibes and some new props will smooth it out even more


  • Hate to ask this but I was always taught no question is a stupid question. I'm going to be updating to V3.0.1-rc1 tonight, Do I have to redo the compassmot again? And the "live" compass calibration, accel calibration etc?

  • Hi

    Has anyone got the hex files for v3.0.0, v3rc5, v3rc6 and v3.0.1rc1 for a quad with APM2.5. I wil not have a net connection so need the hex files to upload via mission planner as custom firmware. I have looked on firmware.diydrones but dont know which of the various hex files were the ones released for download via mission planner.



  • Hi all,


    I'm hoping the crowd can hope me with this one as it's making my holiday less fun and I'm short on time to work through all avenues myself.


    In recent times I've only been able to get one in ten flights off the ground.

    When things are not working my roll, pitch and yaw all slowly wobble about their axis, even though my quad is sitting perfectly still and level.  This is despite raw values of x*, g* and m* sitting still.


    I've attached two logs, one of this working nicely, one of them not (+IMU).


    I'd really appreciate a second eye run over them as I travel to see if someone can spot something I can't.


    FYI: I have switched compassmot off as the value returned was huge (150%) and yet I've never noticed a toilet bowl style issue.  I'm not in a position at the moment to work on isolating the board from the PDB.


    Best regards,





  • 3DR quad frame, 3DR 850kv motors, 3DR 20A ESC, APC 10x4.7 propellers. APM 2.5 running V3.0.1-rc1. uBlox GPS. 3DR radios. Mission Planner 1.2.58.

    More than 30 sucessfull flights with 3.x.x software, rock solid loiter, flying +20 WP missions without any problems or issues.

    Tested GUIDED mode for the first time today. First fly-to-here WP without any issues. Imidiate loss of controll and crash on activaiting the second fly-to-here WP (right click on the map in Mission Planner).

    Examining the logs it looks like something happend at line 7305...

    Crash damage:  one arm, two motors (bent shaft), total loss of the 3DR radio on the quad (broken PCB, lost the antenna)

    2013-07-03 23-13 3.kmz

    2013-07-03 23-13 3.log

    2013-07-03 23-13 3.log.gpx

This reply was deleted.


Santiago Perez liked Santiago Perez's profile