ArduCopter-3.1 released!

After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.


The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)


How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter


If you haven't seen it recently, please check out the ArduCopter wiki.


Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I think the main problem is that the altitude (50m) of the first command of the mission was not taken into account, the copter has not climbed 50m before the next command,

      WHY ????

      Instead an altitude of 25m at a speed of 90km / h hitting a tree which destroyed 60% the copter

      3702474312?profile=originalmission file is here:

      Dropbox - Error
      Dropbox is a free service that lets you bring your photos, docs, and videos anywhere and share them easily. Never email yourself a file again!
  • Hi,

    had strange thing today.

    I was testing today 3.1.2.

    In Acro was all ok. Stabilize looked also OK.

    made some flying. But from some moment it started behaving strange. 

    It all loked like chanel mapping (roll and pitch) changed during flight. Maybe something with mixer. 

    I've got a lot of luck that i get back.

    Can some one look at log. All strange things started at about id in log ~7500 (i think, but not sure):

    First, i didn't know what is going on. But when it was back it hapened again. Now I know it only happens in stabilize.

    The strangest thing that this does not happen immediately after switching to stabilize, and only after some time.

    2014-02-23 12-58-54.log
    • the problem could be you rx failure

      • Hmm, don't think so.

        When i did get back and realized what happened, tried some flying acro. All was ok.

        But when changed to stabilize, after some while it happened again.

        In acro all is OK.

        • Developer

          It'll be caused by simple mode + compass error I think.  The most common cause of compass interference is from the power wires below the flight controller.

          ACRO doesn't use simple mode which would explain why the problem wasn't there when in that flight mode.

          Setting the COMPASS_ORIENT parameter incorrectly could also cause the problem.  It should be 0 if using an internal compass, 8 if using an external GPS+Compass module.

          • Hi Randy,


            What should be the COMPASS_ORIENT parameter with the 3dr external gps/compass and the pixhawk?

            • Hi Peter,
              I have the same set up. If you have your pixhawk and gps/compass module alligned and mounted normally (=arrow pointing same direction and both arrows visible from above), then you don't have to select any orientation. Just select "Pixhawk" in the compass configuration tab and it will work (did for me). 
              But it gets tricky I think when you change this standard configuration and when you don't allign the two modules...


            • Developer


                  8 which is equivalent to Roll-180.  I think this is mentioned on the wiki here.

              • Thx

  • Hello everyone , I come to you with a big worry since version 3.1

    Someone could help me about this problem since I dragged the updated version 3.1 and supp.

    I have two quads frame TBS . version 2.9 and 3.0.1 they work very well any particular problem .
    As soon as I upgrade to version 3.1 and supp , I have a very big concern for stabilization and sustain flight. Drastic reduction of autonomy, engines 3 and 4 very hot as they are requested.
    On the advice of Randy , I changed engines + ESC + Battery 4S. Keeps flying is better, but always with that of balance engines 3 and 4.

    if I go back to version 2.9 or 3.0.1 , no more problem with the engine whatsoever battery 3S or 4S . and of course the self returns to his predictions :)

    frame both react in the same way , by cons are now different in ESC and engines.

    Thank you in advance for your help, because there despite some changes in the settings , can not find the problem that occurs in the same way on both frame .....

    2014-02-23 10-31-45 8.log
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21