Bad AHRS - Pixhawk

Pixhawk, Arduplane 3.2.2.

Hello guys,

having a problem to make EKF to work. 
As soon as I put the EKF_ENABLE 1, the massage "BAD AHRS" appears on my Mission Planner screen. I couldn't find any similar topic on other forums so you're my last chance =)

I thought that it's might be a hardware problem, but both of my Pixhawks acts the same. The IMU pin legs connections on PCB are also look fine. All the initial calibration were made.

I also had an idea that it might be a wrong EKF_ or AHRS_ parameters problem, but I varied them without any successful result. 

Both IMU seems to work according to log file. But most of EKF'1-4' logs shows zeros. Since it was recorded indoor so I turned off the "AHRS_GPS_USE 0", but even with its on and outdoor the result is the same - "Bad AHRS"

I also noticed that INS_PRODUCT_ID turns to "0", saying that IMU is unknown, but not 5 as it should be for Pixhawk.

Please help, I spent the 2 days solving this problem without any results!

Here are the Parameters and Logs.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thank you so much for the answer.



  • ice-o-l8 said:

    BAD AHRS SOLVED.

    Mission Planner,

    ' Flight Data '

    ' Pre Flight ' tab,

    (far right) click ' Edit ',

    change ' GPS Status '  ' {value} >= 3 ' from ' 3 ' to ' 1 ',

    or ' 2 ' if you have two gps'.

    ' SAVE '

    Now ' Verify GPS ' will turn green on ' Pre Flight Check List '

    " BAD AHRS " SOLVED.

    ice-o-18, Thanks to you, my brain overheat temp is sinking into the green for the first time in three days.

    I'd appreciate a line or two explaining your thinking that brought you to the solution. Maybe I can learn something.
    Jim

    Bad AHRS - Pixhawk
    Pixhawk, Arduplane 3.2.2. Hello guys, having a problem to make EKF to work.  As soon as I put the EKF_ENABLE 1, the massage BAD AHRS appears on m…
  • BAD AHRS SOLVED.

    Mission Planner,

    ' Flight Data '

    ' Pre Flight ' tab,

    (far right) click ' Edit ',

    change ' GPS Status '  ' {value} >= 3 ' from ' 3 ' to ' 1 ',

    or ' 2 ' if you have two gps'.

    ' SAVE '

    Now ' Verify GPS ' will turn green on ' Pre Flight Check List '

    " BAD AHRS " SOLVED.

    You're welcome ;D

  • 100KM
    Have you carefully gone through the documentation? Unfortunately apm is no longer supported. There are many low cost boards (cheaper than apm).
  • I'm still in the process to understand how everything works, and I'm stuck with my RC controller. I've bought the Spektrum DX6i controller but I don't  know how to connect it to my apm board (see picture). It must be something very simple but I could find the answer on the web or on youtube. https://reviewsdash.net/best-fishing-drones/

    The 10 Best Fishing Drones to Purchase in 2019
    Looking for the Best drones, we reviewed drones with almost every categories and picked The 10 Best Fishing Drones to Purchase in 2018, just for you.
  • Gus

    I also have this problem. However I can arm by disabling the INS bit in parameter ARMING_CHECK.

    Andrew

    Gus said:

    Hey Hein I dont have an external compass no just gps and the Pixhawk. I didnt realise u needed or could get an external compass. I can not arm with the error so ca not get in the air. Even with the internal gps off.
    Any chance you can explain how you arm and any other pointers you may have. Its really strange as the really cheap boards dont have this issue and this was exspensive.
    Bad AHRS - Pixhawk
    Pixhawk, Arduplane 3.2.2. Hello guys, having a problem to make EKF to work.  As soon as I put the EKF_ENABLE 1, the massage BAD AHRS appears on m…
  • 100KM

    Hi Gus - are you flying copter or plane? If copter - you need a compass - then you just need to make sure everything is calibrated and take it outside- the AHRS error should disappear. With plane (with all compasses disabled), you'll still have the error on the ground outside, but just ignore it.

  • O and I have recalibrated everything also. Even did a setup from scratch, and loading param file.still nothing. I also cleared the entire preflight check list. Still nothing.
    Cheers
  • Hey Hein I dont have an external compass no just gps and the Pixhawk. I didnt realise u needed or could get an external compass. I can not arm with the error so ca not get in the air. Even with the internal gps off.
    Any chance you can explain how you arm and any other pointers you may have. Its really strange as the really cheap boards dont have this issue and this was exspensive.
  • 100KM

    Are you using a compass? I get this using planes without compass and makes sense that I get the error, because the AP can't determine heading while stationary without a compass. As soon I take off the error disappears. If you have a compass, it might be a calibration / variation issue. 

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
xemone liked Max Gilson's profile
Aug 31
More…