Bad AHRS - Pixhawk

Pixhawk, Arduplane 3.2.2.

Hello guys,

having a problem to make EKF to work. 
As soon as I put the EKF_ENABLE 1, the massage "BAD AHRS" appears on my Mission Planner screen. I couldn't find any similar topic on other forums so you're my last chance =)

I thought that it's might be a hardware problem, but both of my Pixhawks acts the same. The IMU pin legs connections on PCB are also look fine. All the initial calibration were made.

I also had an idea that it might be a wrong EKF_ or AHRS_ parameters problem, but I varied them without any successful result. 

Both IMU seems to work according to log file. But most of EKF'1-4' logs shows zeros. Since it was recorded indoor so I turned off the "AHRS_GPS_USE 0", but even with its on and outdoor the result is the same - "Bad AHRS"

I also noticed that INS_PRODUCT_ID turns to "0", saying that IMU is unknown, but not 5 as it should be for Pixhawk.

Please help, I spent the 2 days solving this problem without any results!

Here are the Parameters and Logs.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Same issue have run through everything. But it seems there has always been issues with this and were told its not GPS  the settings are to strict repower. Looking below is questions from 2015 and Ive seen them going back to 2014 so there must be a definitive answer seeing as though its been happening since the inception of the board.

    PLEASE HELLLLLP!

  • I made several attempts to calibrate the compass and the error persisted. After reading in some forums the similar experience of a colleague, where he solved the problem by downgrading to the first firmware version for arduplane. I did the same and my problem was solved. With this older version of firmware running perfectly on my plane, the only thing that has changed is that the engine is always armed, so be careful with the throttle stick as the engine starts as soon as you move the stick.
  • i had the same thing, and performed an accell calibration, and it fixed it. 

    if it happens often, apparently, re-arming with the plane still fixes it for some, but this is the long term solution. 

    hope my experience helps others. 

  • @Hisham - So to fix the AHRS problem, you just turned off the internal compass?

  • Hi lately i Have did 3 test flights regardless of the compass variance and bad ahrs i have. All safe landing and recovery.

    since the bad AHRS flag went off after 40sec consistently, i assumed like other Avionics on an airplane we have 7 mins to realign the INS IRS and gyro. so i gave it a go call.  the only problem i had was with the Compass alignment keep on getting compass variance, by crosschecking with actual compass the primary compass seems to giving out correct reading +- 2 degree which is acceptable for flying. gps hdop was good.. so i turn off the 2nd onboard compass. ARMed  and There she goes. though from time to time   I had a compass variance flag due to  EKF. 

  • I'm about ready to throw away a brand new Pixracer because I can't get rid of this error.  I've tried all of the fixes listed here and elsewhere and it continues to happen.  It's really starting to piss me off.

    I left the Ardupilot world over three years ago because I couldn't get beyond compass problems on the then new Pixhawk, but recent hardware and software looked interesting so I decided to give it a try again.  But wasting a weekend on this probably is about ready to drive me away again. We REALLY need some way to get more info about these errors and what's causing them.  Does anyone know if it's caused by the IMU, GPS, barometer, magnetometer, phase of the moon????  How can we debug these things?

    I'm running the latest release Plane firmware on a new genuine Pixracer with AUAV.co GPS and other accessories.

  • i have this problem running arduplane on pixhawk, runing the same firmware..only is mine shows up after powering and it goes away after 40sec. consistantly.

  • I'm with the same version of Fw and same problem as yours. Is there a solution? Any firmware that corrected this error?



    Mike said:

    I have this same Bad AHRS in plane 3.7.1 MP 1.3.43.

    Done all the stuff suggested. Recalibrade, power down/up, etc.  Only time it doesnt happen is when I take the plane outside.

    Any updates from anyone else?

  • I have this same Bad AHRS in plane 3.7.1 MP 1.3.43.

    Done all the stuff suggested. Recalibrade, power down/up, etc.  Only time it doesnt happen is when I take the plane outside.

    Any updates from anyone else?

  • Airplane 3.6.0 has solved this problem. For me it has totally gone away.

This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
Oct 22
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
Oct 22
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Oct 22
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Oct 22
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…