Bad AHRS - Pixhawk

Pixhawk, Arduplane 3.2.2.

Hello guys,

having a problem to make EKF to work. 
As soon as I put the EKF_ENABLE 1, the massage "BAD AHRS" appears on my Mission Planner screen. I couldn't find any similar topic on other forums so you're my last chance =)

I thought that it's might be a hardware problem, but both of my Pixhawks acts the same. The IMU pin legs connections on PCB are also look fine. All the initial calibration were made.

I also had an idea that it might be a wrong EKF_ or AHRS_ parameters problem, but I varied them without any successful result. 

Both IMU seems to work according to log file. But most of EKF'1-4' logs shows zeros. Since it was recorded indoor so I turned off the "AHRS_GPS_USE 0", but even with its on and outdoor the result is the same - "Bad AHRS"

I also noticed that INS_PRODUCT_ID turns to "0", saying that IMU is unknown, but not 5 as it should be for Pixhawk.

Please help, I spent the 2 days solving this problem without any results!

Here are the Parameters and Logs.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • 1.make sure you do the compass calibration outdoors
    2. you're GPS probably has a compass/Magnetometer in addition to the one built in your board.

    so you need to turn off one of them because you're probably getting 2 different values which creates an error.
    in the setup, go to mandatory hardware, click on compass calibration and uncheck the other compasses. then do the calibration.
    Web Server's Default Page
  • https://youtu.be/e5bHx59k_I8
    follow this
  • Thank you so much for the answer.



  • ice-o-l8 said:

    BAD AHRS SOLVED.

    Mission Planner,

    ' Flight Data '

    ' Pre Flight ' tab,

    (far right) click ' Edit ',

    change ' GPS Status '  ' {value} >= 3 ' from ' 3 ' to ' 1 ',

    or ' 2 ' if you have two gps'.

    ' SAVE '

    Now ' Verify GPS ' will turn green on ' Pre Flight Check List '

    " BAD AHRS " SOLVED.

    ice-o-18, Thanks to you, my brain overheat temp is sinking into the green for the first time in three days.

    I'd appreciate a line or two explaining your thinking that brought you to the solution. Maybe I can learn something.
    Jim

    Bad AHRS - Pixhawk
    Pixhawk, Arduplane 3.2.2. Hello guys, having a problem to make EKF to work.  As soon as I put the EKF_ENABLE 1, the massage BAD AHRS appears on m…
  • BAD AHRS SOLVED.

    Mission Planner,

    ' Flight Data '

    ' Pre Flight ' tab,

    (far right) click ' Edit ',

    change ' GPS Status '  ' {value} >= 3 ' from ' 3 ' to ' 1 ',

    or ' 2 ' if you have two gps'.

    ' SAVE '

    Now ' Verify GPS ' will turn green on ' Pre Flight Check List '

    " BAD AHRS " SOLVED.

    You're welcome ;D

  • 100KM
    Have you carefully gone through the documentation? Unfortunately apm is no longer supported. There are many low cost boards (cheaper than apm).
  • I'm still in the process to understand how everything works, and I'm stuck with my RC controller. I've bought the Spektrum DX6i controller but I don't  know how to connect it to my apm board (see picture). It must be something very simple but I could find the answer on the web or on youtube. https://reviewsdash.net/best-fishing-drones/

    The 10 Best Fishing Drones to Purchase in 2019
    Looking for the Best drones, we reviewed drones with almost every categories and picked The 10 Best Fishing Drones to Purchase in 2018, just for you.
  • Gus

    I also have this problem. However I can arm by disabling the INS bit in parameter ARMING_CHECK.

    Andrew

    Gus said:

    Hey Hein I dont have an external compass no just gps and the Pixhawk. I didnt realise u needed or could get an external compass. I can not arm with the error so ca not get in the air. Even with the internal gps off.
    Any chance you can explain how you arm and any other pointers you may have. Its really strange as the really cheap boards dont have this issue and this was exspensive.
    Bad AHRS - Pixhawk
    Pixhawk, Arduplane 3.2.2. Hello guys, having a problem to make EKF to work.  As soon as I put the EKF_ENABLE 1, the massage BAD AHRS appears on m…
  • 100KM

    Hi Gus - are you flying copter or plane? If copter - you need a compass - then you just need to make sure everything is calibrated and take it outside- the AHRS error should disappear. With plane (with all compasses disabled), you'll still have the error on the ground outside, but just ignore it.

  • O and I have recalibrated everything also. Even did a setup from scratch, and loading param file.still nothing. I also cleared the entire preflight check list. Still nothing.
    Cheers
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
yesterday
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
yesterday
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
yesterday
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
yesterday
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Sunday
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Sunday
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
DIY Robocars via Twitter
RT @a1k0n: Fully autonomous wipeout in the corkscrew at Laguna Seca @selfracingcars today. Got some tuning to do; this car is very fast, bu…
Oct 13
More…