Not many people know but we have an piece of open source software for controlling an Antenna Tracker.  It's been built by Tridge (Arduplane lead developer) for use in the outback challenge.

Sadly we have no documentation and, as far as I know, nobody except Tridge has used it.  Still given Tridge's track record on building great software I suspect it works well and if it doesn't, I'm sure we can fix it.  So to not let this piece of code go to waste, I'd like some help from people who are interested to give it a try and help me figure out how it works.

Here's the little that I know:

  • It runs on any of our supported board (APM1, APM2, PX4, Pixhawk, Flymaple and perhaps VRBrain)
  • For APM1/APM2 users building the code is as easy as opening our hacked ArduinoIDE and selecting File > SketchBook > Tools > AntennaTracker and then building in the normal way.  For PX4/Pixhawk, our autobuilder doesn't automatically build a binary but I can provide one if people are interested.
  • It can control a Pan and Tilt gimbal like this or this found on
  • It may or may not require a GPS
  • It must somehow receive vehicle position updates from the ground station which has the telemetry radio that is connected to the vehicle. Maybe through a USB cable.  Tridge probably uses the python ground station, MAVProxy, to passthrough the vehicle position data to the AT but perhaps we can get MichaelO to build out a similar feature in Mission Planner.
  • I imagine this antenna tracker could also be used to keep a camera focused on the vehicle which might be good for easing the burden on creating videos of our vehicles.

So if you want to give it a try please do and stick any findings, questions or issues below. Alternatively Issues can go into the issues list.

I'll start sticking things into the wiki as they become clear.

Views: 57876

Reply to This

Replies to This Discussion

I'm often using ctrl+f
You need to select speed and com and click TWO TIMES- the first doing nothin then click again.
You can test you setup with x-plane (demo or not) and mavlink stream with ctrl+f.
It was what I used for optimizing my dev tracker

By the way, Michael Oborne has been building multi-vehicle support into the mission planner.  Below is a picture of what it looks like with an antenna tracker and a quad attached.  The user interface isn't done yet so for the moment there's a system selector box that appears so you can switch between the two vehicles.  Both vehicles show up on the Flight Data screen's map.

How do I bring up that SysidSelector Box?

HI All!  I'm in the process of tuning my PT785-S Pan & Tilt System with a LCOM 900Mhz and a 5.8Ghz BiQuad antennas.  I've posted pictures in my photo album if your interested.


@iskess, I know my reply is late as your post is dated back on the 11th, but the latest beta version of the Mission Planner has the option to select either the airframe it sees or your antenna unit once you initialize a telemetry connection.  I do not know if there are other ways to bring it up.

First I want to explain that I built a Antenna Tracker using the PT785-S system from Servo City and installed a Pixhawk, Lea-6H 3DR GPS/Compass, and two 3DR 900Mhz radios.
The first Radio is in Telem1 port and works fine when connecting Mission Planner via USB cable and is receiving data from multicopter.

My issue is that I followed the limited steps in the "Antenna Tracker – Connecting with GCS" section at ... -with-gcs/ website but I'm not able to connect my laptop 3DR Radio to the second 3DR Radio plugged into Telem2 port. I set up all radios with SiK 1.9 firmware and altered the NET ID to 33 for both units.

I did note that when the 3DR radio is connected to my laptop and power is observed on it that both radios green LED switches from blinking to solid.

So my issue is this. How do I connect Telem2 radio on antenna tracker to laptop radio in order to perform remotely all the functions I would be able to do if a USB cable was connected directly to antenna Pixhawk unit?

Some updated photos of the Antenna Tracker with my custom built BiQuad 5.8ghz antenna, receiver, and SD DVR recorder.

I made another attempt to get this tracker working today. Remember I'm using the tracker only for video. I have an APM 2.5 on the tracker attached to MP via USB. The laptop has the 3DR radio, receives the MavLink from the aircraft and should pass the position on to the tracker. My understanding is no proxy mode needed since MP doesn't get its data from the tracker. I used ctrl+F and 2nd Mavlink to get both the tracker and the aircraft connect at the same time. I can see both on the map, and switch between them at will. So far so
good. Now how do I make the tracker work? What mode do I use? Scan, Auto, Manual? I tried them all to no avail. I don't know how to use them, the wiki doesn't describe them. The tuning page looks nice. I tried the test function and nothing happened. What is supposed to happen? What is the slider supposed to do? I'm assuming the the built in Tracker function does not apply here and is only for Maestro and Ardustation, it this correct?
I'd like to know a way to test the tracker to make sure MP is controlling it. I hoped that that Manual Mode or the tuning "test" would do that.
Can someone who has this working share some basic knowledge about MP Tracker functionality?
Thank you.

Edit: I just found a wiki page I somehow missed that describes the modes. Not sure why it's not working for me. Manual mode did not release the servos so I could manually position the tracker.

I have the same issue as Doug. The antenna tracker will only connect to the computer over USB. Using TELEM2 is no go. I got the antenna more or less tracking while connected to USB. Getting it to work wireless would be really nice.

This is a bit frustrating.

The problems are following:

  • the proxy mode works only if the tracker is connected to the GCS over USB,
  • you can't change the mode of the aircraft.

The second one is a very serious issue.

So I figured out how to get the antenna tracker (AT) working. I would use the ctrl+f "Mavlink" option in Mission Planner to forward the data to the AT. I'll go out and test it when it stops snowing.


Which board are you using?  APM or Pixhawk?

What do you mean, you can't change the mode of the aircraft?  If you change it the AT stops working?  Are you using ArduCopter?  If 'yes', I highly recommend upgrading to AC3.2 because there's an issue in AC3.1.5 that it doesn't check the target of a mode change request from the GCS.   So if you use the MP to change the mode of the AT, AC may also try to change to that mode.

I'm using a Pixhawk.

While connected to Arduplane through AT proxy I can not change the mode of the airplane in MP.

Issue in github -->

I just tested the AT with MP mavlink forwarding. It doesn't seem to work. When I made the connection with AT it came to life and started it's scan pattern, but was not able to find the airplane. When I ended the connection the AT returned to its parking position. I think this means that it received the data, but something was missing.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service