Replies

  • Im getting the pwm values to show up correctly but no matter whether the "rssi enable raw" box is checked or not does not matter as it only will show raw.  Ive tried every version of the CT tool i can get my hands on.  Any help would be great because im hitting my head on the wall right now.

    • Hy i have some question here.

      I put my ezuhf channel 8 on link

      Than i take my minimosd extra and said channel 7  and said 1100min to 1900max

      Next i connact a cable from ezuhf ch8 to apm 2.6 channel8 .

      (Chennel 1,2,3 are servos and throttle and 8 is modes (manuel stable rtl)

      When i put on my minimosd it says -99%

      But it doesnt mather if i connact the cable or not.. now it says always -99%

      I also tried RSSI instade of LINK in the UHF settings also i testet RSSI Raw enable .. nothing changed

      To i have to change some settings in the APM to?

      I was watching the servo channel konfiguration in the apm-mission planer and if i turn on the radio it says 1794 ... turned of it says 1074 so i can totaly see it changes something on channle 7 in the settings,.. but the OSD can´t see it :(

      • @RcFox

        Just to clarify you will need to use the EzUhf config tool. On the 2nd screen theres a drop down for each and every channel. Basically pick channel 8 and in the dropdown pick rssi or link. This means that the ezuhf will send that on that channel which the APM/PH can read.

      • Hi rcfox, see if you can change the channel assignment in your transmitter so you can configure channel 8 in ezuhf to send the RSSI/LINK.  AFAIK the current minimosd firmware will only read channel 8 on the mavlink messages.

        If you cant change channels in your transmitter and if you still have channel 7 on your ezuhf set to LINK/RSSI then plug in the servo cable coming in from that to the input channel 8 of your APM2.6.

  • I used to use the CTool 2.3 it looks like the latest one 2.3.2 fond int:

    http://code.google.com/p/minimosd-extra/downloads/list

    has this already, I can see the "RSSI Channel" with pull down values of MAVLINK RSSI and Channels 5 to 8. The RSSI Min and Max values can now be also set to a max of 2000.. will try tonight!

    • I also have a EZHUHF Rx along with a Mavlink OSD.  I have set channel 8 in the Immersion tool to output RSSI, and then flashed the latest MinimOSD-Extra copter firmware to the Mavlink board.  I am getting weird PWM readings after checking the "Raw RSSI" checkbox (a higher PWM when my Taranis Tx is off versus powered on???).  Do I need to reverse channel 8 to correct this?  If not,  any thoughts on what I might be doing wrong?  Also, I saw the option for outputting the Link quality versus the RSSI in the Immersion tool.  I assume it will also display a percentage value of the link quality similar to RSSI?? 

      • Hi Glenn, can you perhaps tell me how you got EZUHF RSSI/LQ to work on APM/MavlinkOSD? I don't get any reading on the OSD screen. 

        I set up LQ out on Ch7 of my EZUHF Rx, and run PPM out on Ch1. I've tried picking up the LQ through the PPM stream, and also tried picking it up through a separate wire going from the Rx to A0 on the APM (after enabling A0 as RSSI input). No luck.

        Also, what should the MavlinkOSD RSSI input be set to? Mavlink RSSI or Ch7?

        Thanks for any help!

        • I know it says you can choose the channel in the CT, but only Ch8 works.  So you have to output to Ch8 instead of 7 and then you should be set.  The CT should be set to Ch8

          • Thanks, I'll try it on Ch8. After many hours of trying to get it to work, there's some light at the end of the tunnel!

            • Yes, I am outputting the RSSI/LQ via Channel 8 on my EZUHF Rx and have it plugged into the 8th Input on the APM 2.5 (where you plug in your ESC's if you are flying a multirotor).  At first I tried RSSI and I am still getting 5-digit percentages for RSSI??  I switched over to LQ and then re-run my PWM's (Min & Max) and it seems to be working (0% with Tx off and 100% with Tx on).  One strange thing though - next to the LQ percentage I also get a "2%" showing up??  i.e. "Radio symbol then LQ%2%"  It is working nonetheless but strange.  I am running the latest pre-release firmware for a copter so maybe there are a few bugs??

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…