Hello Everyone,

i actually continue to have serious issues getting APM to work in e.g. Loiter.

Here, you can see a video with the usual behaviour: http://youtu.be/3HDaQzrht9w

Out of 20 times i tried, loiter worked two times. - In between one time it worked and the next one, i did nothing than to change the battery.

I always waited to have GPS lock, always lifted off in stabilize and then switched over to loiter. Also, i use Auto-Inclination and the latest software as of yesterday.

It's really frustrating to see APM not working as it should - it has cost me by now by far more money and time it would have to buy a WKM with 50 waypoints even.

I have also constructed a special copter due to it crashing so often to use crash bars - see picture below - these are only 1/4 of the aluminum bars which i have destroyed up to now and 1/2 of the props which i have shredded.

Is it really not possible to get this thing flying in loiter ?

If there is somebody here to help with this, i would highly appreciate it.

- If i need to pull logs or settings from the craft, i would be very happy to do so.

Can somebody please help with this one ?

Cheers Florian


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Gonna bump this old thread instead of making a new one as I am having issues now with my drone after a small crash and now its behaving exactly like the original posters.  When switched into loiter it will go into about a 30degree bank in either left or right and continue sideways until i switch it back into stab and correct.  It does not respond to any stick movements once it gets put into loiter.  It does seem to maintain height though unlike the OP.  Twice out of about 30times Ive tried it (since the crash) it must have gone into failsafe  mode as it just did a soft straight down landing(I have fail safe set to land)

    Like I said mine use to work flawlessly until what I thought was a very minor crash (was hovering very close the ground when a carbon boom snapped and it fell maybe 2ft onto soft grass)

    Here is a quick video of the very first time testing loiter.  https://www.youtube.com/watch?v=CLvAClUurv8

    As well from 1:20 to about 1:40 You can see how it use to loiter in the following video.(you can see it drop a short distance when i flick it as I had it ascending while flicking the switch.


    Any Ideas or suggestions?

  • The opening post sounds very familiar to me.

    I haven't gotten my Arducopter Hexa to work like it should have.

    And I do have a more or less basic setup.

    After months of trying to get the multicopter to fly like I want it to (including loiter, RTL, etc.), finally I gave up on it.


    I bought a DJI Naza & Gps instead.

    And you know what, it flies right out of the box!

    Loiter in heavy wind stays in a square box of 1m.  RTH (RTL) works perfectly every time, it autolands within a square box of 1m.

    I can finally use my hexa for the purpose I bought it for: reliable AV/AP!


    I'll still use the Arducopter, I'll put it in my little quad just for fun and means of experimenting.  Maybe I'll have more luck with the quad.

  • Hi Randy,

             thanks for your answer.

    Actually I have 2 problems with the MAG.

    With the motors off, I do the calibration (from MP or Flying) and North is awfull off. Even worth is that (still with the motor off) y  turn the copter around and starting pointing to the North, South is like 80 degrees to the CCW. I cant get North and South to be at 180°.

    On the other hand as soon as I start the motors the compass goes crazy.

    Im in Argentina and my declination is -38,25.

    Is any one out there that got the mag to work on Soth Amerika?


  • Hi Florian

    I would be interested in what happens when you fill in your Quads stats into this calculation sheet, it's not perfect but a fair guide on where you may be going wrong on weight vs power, just a thought :-)


  • I have two APM2's, move them around a couple of quads and a Bixler. They both work perfect in Stabilize mode but one refuses to fly in Loiter mode. Tried to load new firmware and fly it with standard parameters on the 3DR Quad, no joy, siwtched to the other APM2 and did the same, perfect Loiter. Could it be a hardware problem? The one not loitering has also a message about no logging, card missing (Something like that)


  • Hi,

      would it be possible to get a cable about 20cm to connect the APM2 and daughter board? It might be nice to have the possibility to have magnetometer away from magnetic fields and at the same time been able to correct desviation on the mag calibration by rotating the pcb as I can do on my NAZA controller....

    I know we can order gps and mag separated but this have an impact in $$.


  • If your craft is over powered, just add another battery to weigh it down... !!...

    The motors really need to spin up to be stable and to have things work right.. 

    I had that problem on many tri / quads...  I used 4S and 900 kv with 12x3.8 = BAD...

    Now  4S 600kv 12x3.8.... much much better

    Eddie Weeks

  • Developer

    Hey Florian,

        Sorry you're having so many troubles.

         I had a look at your logs and a couple of things are trouble.  The problems with alt hold are caused because you have a slightly over powered quad.  So when you're engaging alt hold, your "throttle cruise" (the throttle required to keep your quad level) is quite low.  Low enough that in fact, your throttle is immediately below the dead-band that the alt hold routine uses.  So when you engage alt hold unfortunately you need to immediately move your throttle to the middle position.

         The other bad thing is your sonar.  I think you should disable it and/or check out the wiring because it's giving quite bad results.  Probably best to check it using the CLI menu (use the Arduino Serial Monitor or the MissionPlanner's Terminal screen, then type "test", "sonar" and make sure it changes as you change the distance to the nearest object in the sonar's field of measurement).

         By the way, when things start going wrong like that...switch it back to stabilize mode and retake manual control.  Whenever I'm trying something new, I'm always ready to switch back to stabilize mode the moment anything starts going wrong.  I have a lot less crashes this way.



  • Attached are the logs - the one where it crashed and also for comparison the logs with the only time it worked.

    Can somebody please please help ?



This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21