MinimOSD not getting APM updates

Hi Guys!

I recently received my brand new Arducopter quad D direct from udrones as listed here. I got the OSD/FPV option. My FPV seems to be working fine, but the minimOSD doesn't appear to be getting APM updates. It does initialize and connect to the apm, but it never updates its data values.

I did read on one of the wikis here that since I don't currently have a telem radio connected and the OSD tx isn't connected to the APM telem RX, I need to tell the APM to auto send updates. I think I did that - here's my config params for SR3:


I'm starting to wonder if this is wired correctly?



I know it's hard to see here, but the pinouts look like this:

apm telem pin1 -> osd +5

apm telem pin2 -> osd rx

apm telem pin5 -> osd gnd

I can't find anything that tells me what the apm2.5 telemetry pinouts are, so that's why I just wrote pinX, where 1 is the leftmost pin when looking at apm2.5 with the writing right side up (that is, output pins are at the top). This is how it came wired from udrones, so I was assuming it's correct, but I'm not sure what else it could be.

My OSD thinks it's running 2.0:


and it does seem to get it's initial connection with apm working, but then it never gets updates:


I can't try updating the minimOSD firmware as I don't have the ftdi->usb connector. I just ordered one from 3dr, but I don't know how long that will take to get here (incidentally, Chris - why don't you guys ship that cable with the OSD package from udrones? Or at least suggest it as an add on when somebody buys the minimOSD - we're going to need it at some point for firmware updates). It doesn't really seem to me like that would be the problem though, as it is getting a connection to APM.

If I knew which pin on the apm2.5 telemetry port was the rx I could try wiring that up to the OSD tx and see if that works - does anybody know which pin that would be?

Thanks for reading. Any suggestions appreciated!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey, regardless of firmware version on the minimosd I was getting this same issue where OSD info would not update unless I connected to the ground station with telemetry modules. Same apm, but on 1 occasion I could use the i2c port plugged into the minimosd and it would update fine without having to connect to the ground station. Another occasion, same apm, I wasn't getting updates through the i2c port and I set a 10 sec delay on the telem_delay parameter and osd updating correctly again without having to connect to the ground station. Now this last occasion I was having the same issue again with the same apm and I was back to osd not updating, while using i2c port unless connected to ground station. What I am using now that works is a y cable with tx split from telem port off apm to rx on the telem module and rx on the osd. Then, and this took me a min, but make sure to turn delay back down to 0 on telem_delay parameter. Now I have an updating OSD without having to connect to the ground station. Last suggestion... let the APMs die and just go pixhawk   ;P

    Jake Mogensen said:

    Guys please help, i have the exact same setup but my osd will not update.. and yes i did change the params. My minimosd is running extra 2.2 out of the box..

  • Guys please help, i have the exact same setup but my osd will not update.. and yes i did change the params. My minimosd is running extra 2.2 out of the box..

  • This worked for me. 

    Issue: no updates just all static numbers on the OSD. 

    Fix: Bad Y-Cable from - it has one fine pitch connector APM, then a 0.1" connector for telemetry (which worked), then a 3 pin 0.1" connector for the OSD.

    Cut the Green wire (RX on OSD) and wired to the Yellow wire (RX on Telemetry). Worked like a charm.

  • MR60

    In short to make it work:

    -if you have a telemetry air module connected In parallel with minimosd, then the cable going from APM to minimosd must only have three wires: 5v, gnd, APM tx to minimosd Rx,

    -if you do not have a telemetry air module, then the cable from APM to minimosd has 4 wires, same as the three of previous case + a wire linking APM Rx to minimosd tx.

    • Many Thanks man! This solved my issue with OSD. The wiring on the knock-off Y cable was inverted, tx&rx after this everything worked well!

      Make sure that it is Positive(red)+tx(green)+rx(yellow)+Ground(black) and make sure that TX goes to Rx on minimosd and Telemetry


  • Just adding my experience and what I did to fix.


    I am using Ebay purchased items but are the like to 3DR products.

    Have APM 2.6

    MinimOSD (ebay:

    Mavlink AirRadio (ebay:

    APM OSD+Mavlink Y cable (ebay:


    Connected everything and got OSD but no updates. Changed params as suggested above but still didn't get any updates. Researched the Y cable and realized it was not made correctly. I added a cable to the TX side on the APM to the RX side on the MinimOSD and dada! Worked!


    Hope this helps. This is my from setup experience. You may check your setup and use this as a reference.

  • Mike - How did you get the FPV to work ? 

    I have the same as you - with the FPV/OSD option ...



  • Hello friends.

    I'm having a problem exactly as described in this post.

    I have a minimOSD v1.1 setup like it was when i've bought my hexa RTF from 3drobotics at udrones. I have videofeed. I have a small lipo 2200mah 3S just for the video system.

    I've bought a FTDI cable and I've been able to configure the OSD panel layout and update the firmware. Nice.

    Having the connection between mission planner and the APM 2.5 was the way for the minimOSD to end that "waiting for mavlink heartbeats" and booted showing the expected screen. Again perfect.

    The problem was that the OSD never updated the values in the screen.

    After reading Dimitri's oppinion I gave a try to minimOSD-extra, but the problem was the same, it just didn't updated the values, just blinking those warnigs "No GPS Fix!" and Low RSSI",. In the Flight Data tab of the Mission Planner all data shows correctly.

    I've changed the parameters suggested by Miguel at "Advanced Params>Adv Parameter List", and then I've found out a very serious problem. After changing the values and pressing "Write Params", when I press "Refresh Params" just to be sure that they were written, I find that nothing has changed!!!!

    I've reloaded Arducopter's firmware, and it was wortless. The only difference was that in the "Hardware Options" appears now and OSD option with a button of "Enable Telemetry" that Paul Mikesell said in this post too, but it doesn't make nothing too.

    The big problem here seems to be those params that I can't change permanently for once and for all.

    Is there a way to access the parameters directly without Mission Planner, or something, to make those params changes permanently?

    I'm already very tired of this and feel like making a freekick to the whole equipment. PLEASE HELP! :´-(

    Thank you
  • I think you'll need to enable some SR0 params aswell as per this by Miguel.
This reply was deleted.