Good afternoon everyone.
I recently finished my 3D-Printed X4 frame, and have installed all required (Pixhawk) electronics. Everything is working great, and I have done a successful test flight; But.. The GPS seems to be unwilling to work with the Pixhawk unit.
I am getting the "No GPS Fix" message on Mission Planner, even after leaving the unit outside for nearly an hour in an attempt to acquire GPS satellites. I have followed the manuals instruction, and I am certain I have proper connection between the M8N and the Pixhawk.
In the Mission Planner program terminal, I'm seeing a repeating "Need 3D fix" followed by code. I've also tried connecting via u-Center 8.2 and there is no GPS information whatsoever. I really am lost, and have been researching this since 8AM today. (Almost 12 hours..)
Does anyone have any idea what's going on?
Any help would be greatly appreciated.

Views: 13701

Reply to This

Replies to This Discussion

Do you see any lights flashing on the GPS? If so the RX and TX wires may be crossed in the connector. Finally you may just have a bum gps. I've spent most of my day troubleshooting GPS and telemetry issues just to come down to one wire in the connector not working.

There is a solid blue light displayed on the GPS.
I've tried connecting via u-Blox's u-Center program, and the Packet Console tells me something alone the lines of, "Unknown", within lines of code. I would tell you exactly, but now it seems as if there is no information being relayed via the u-Center consoles..
I've also talked to u-Blox directly, and he's just as lost as I am.
The "processor" on the GPS is u-Blox, but the circuit board is unknown from some company in China. This is where it's difficult for him to asses what the issue is.
In regards to the wire (plug) setup where it plugs into the Pixhawk, it looks identical to images I've seen online.
It's difficult to see the connection on the circuit board itself, as for it's covered with glue. I'm about to take off that glue though, and check to see if there's anything suspicious.
From what I've read, the M8N GPS unit is simply plug-n-play with the Pixhawk. I have no idea why this one isn't working, well, I do have somewhat of an idea; It's from China, and there's no quality control. They pump that shit out of the factory like pancakes, and not every board is perfect. Unfortunately, the Chinaman I purchased the whole bundle from has been unresponsive since I've given him the complaint about the GPS. The money really isn't a huge issue, seeing as these M8N's sell for $20-$50 on eBay.. But it's still irritating.
I really appreciate your response Rob, and I would love to solve this problem.
I've attached an image below, maybe it'll give you an idea with what I'm working with..


Did you try, on an open sky area see, moving your gps as far as you can from the copter? can you share a photo how is installed on your frame?

As stated in my initial post, I left the unit outside for over an hour. The positioning of the GPS in relativity to the frame is not the cause of the issue..

Do not waste your time. Ask for a refund, if not possible, start a paypal claim and buy another one.These modules are cheap because of a total lack of quality control. Most of them work, some are just lemons.

I recently got a bad M8N as part of a knock-off pixhawk package from ebay.  It actually worked for a few minutes but then stopped working.  The GPS itself was clearly working since the blue light indicated a signal lock, I even used u-center to check the baud rate which very spottily indicated it was functioning, but then went dead...I figure it was something wrong with the tx circuit but didn't want to waste any more time with it. Seller was unresponsive..pretty frustrating.  I ended up just ordering another one for $25 or so from a different seller that took about a month to arrive (luckily I had other crafts I could cannibalize from in the meantime).  The annoying thing isn't necessarily the cost or even that the seller wouldn't respond (they churn these things out with no quality control - I accept that risk for the price).  The annoying part is just the wasted time troubleshooting it...there's always a billion reasons it may appear to not be working via mission planner (interference, pixhawk problem, wiring problem, firmware incompatibility, etc. etc. etc...) and you don't want to blame it on brand new faulty hardware without checking into those billion other things somehow. :)

Yeah, I'm a bit worried about the Pixhawk unit I got too.
I've flown it quite a bit now, but in alt-hold, it bounces up and down and is UNABLE to "Altitude-Hold"..
$25 for a GPS, well, fine. But $200 for the GPS, Pixhawk, and a few accessories that may or may not work; That's a bit intimidating seeing as I have less than a week before eBay considers this a "Done Deal"....

I don't see the GPS antenna.  Is it on the backside of the board?  Also, you could take a couple of minutes and wire it to an arduino or even just an FTDI usb to serial cable to see if data is coming across.

The GPS is on the back of the board, yes.
I also do not own an arduino, and don't have the equipment to wire the GPS to an FTDI.
I wasn't expecting to need anything else, considering this was supposed to be Plug-n-Play, with minor setup in Mission Planner.

If it bounced up and down, the baro is working. Check if there is foam on the baro. When you have done this go to copter pids and play with altitude hold P pid until you have a satisfactory result. 

You know, I've been looking it up a bit. It could be a few variables such as prop wash. I also have to open up the board and check to ensure nothing is blocking it.
I'm just about finished with my scratch built carbon fiber frame. Itching reaaaaal bad, covered in carbon fiber.. At least I wore glasses.


This is the first, and last, time I'm going to be working with carbon fiber.
I've done a lot of fabric work, and have even sewn together many R/C paragliders, but carbon fiber is a whole different beast.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service