new APM flavor released: APM Mini Pro

I just noticed this at the Chinese on-line retailer,


They are pricing the bundled versions attractively.  Obviously made to compete against the APM micro 3.1

Flight controller

FC bundled with power supply

FC, power supply, GPS unit

If anyone makes the leap, perhaps you could keep us informed on your experiences.

Happy flying all!!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Radio Failsafe and PPM Encoder.  We have integrated hundreds of these in Quad and Hexa Copters with great results, One problem we often encounter is with the PPM Encoder not running current firmware. With older firmware the PPM Encoder does not recognize PWM hold  as lost link and trigger failsafe. You may need to flash current firmware if you are using transmitters such as FlySky Th-9X.

  • So it seems that I still have an issue that I can't put a finger on. When plugged in to the computer, the copter flies fine. When unplugged, there seems to be a bit of a delay in my throttle response and then, BANG! It just takes off uncontrolled / uncontrollable. Anyone deal with anything like this?

  • Thanks Bill. I had the Batt_Volt_Pin set wrong in the parameters. After changing that to 13 (for APM) it allowed me to arm. However, when I tried to fly, it was very sporadic with no control over it. Fortunately, after flipping the switch to Acro mode, I was able to get the motors to stop turning and bring it down in a safe location. Obviously something is a muck in my settings. 

  • Having retired the CX-20, I rebuilt using a FLIPFPV frame, mini APM Pro FC, and Turnigy 9x. I've had a few successful flights prior to upgrading from the Cheerson radio transmitter to the Turnigy. Now that the Turnigy has been connected, the FC preflight checks. What's weird is that when it's plugged into the Mission Planner, it passes all checks, arms, performs motor/compass calibration and everything. When unplugged from the computer, I get a FAILSAFE message and can't arm it.

    The lights on the APM are solid green and blue/purple flashing.

    GPS (Neo-7N) has solid green and blue flashing, which I believe indicates power and GPS lock.

    Recap: Why can I arm, connect and control while plugged in to Mission Planner and not while unplugged?

    **Side Note** I after I typed that, I wondered if it would allow me to connect even if I wasn't connected to Mission Planner. So I disconnected MP, plugged in the USB, plugged in the battery, and it worked. Now I'm wondering if it's some kind of power issue.

    • Developer
      When plugged into USB the battery fail safe is disabled. "I get a FAILSAFE message and can't arm it." check you fail safe setup. has the instructions
  • Can anyone confirm if this PRO board can use dual redundant power suppler: power module + UBEC because in forum he says it could be powered from two power source without solder/cut jumpers on board?.  I had problem with mid air reboot on this mini pro board.  Here's the link:

  • Thanks for the answers, but I don't see anythink I do wrong.
    I can fly the quad but is not so solid as my NAZA copters. The APM is flying with movements up and down. Tried several settings, is always be able to fly, but I miss a straight movement.
    Hopefully someone comes with "the solution".
  • My apm flies rather well (f450 frame). Is doing the missions as porogrammed. But I do not succeed doing the autotune.
    I do not seeing the copter movements. I do not see changing the settings.
    When I start autotune I get a message, but never get a message the autotune had ended.
    who has an idea where I have to look?
This reply was deleted.


David Hori liked Isabella Domi's profile
Jan 12