Pixhawk causing motor sync issues.

I believe I have a problem with my Pixhawk and was hoping for some help.  Also posted this on rcgroups.

The issue is that when my speed controllers are hooked up to the Pixhawk they exhibit a bad sync issue.  However when they are connected to my old APM (3.1) or just a receiver directly they do not exhibit these symptoms.  This has resulted in 4 crashes now until I just tonight narrowed down the issue to the Pixhawk.

Can anyone advise what is going on?  Here are the specs of my setup:

Afro 30A ESC's with SimonK firmware (have tried all versions, and made my own with various parameters)

Tiger MT2216-9 1100kv motors

4S 3700mah battery



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • there is a person who posted a video on youtube and it uses a pixhawk with afro esc on a octocopter and has no problem ... I posted a video commantaire on ca and my replied that flashed the latest firmware for the Afro esc with usb linker HobbyKing. I just this linker and I'll update puts esc African to see if it suits the problem. I had also return on esc with firmware Blheli who works well with the pixhawk (esc sunrise himulti) that are similar to fast esc SimonK firmware.

      Here the video:

      Octocopter pixhawk afro esc


      quad heavylift afro esc:


      Hexa pixhawk afro esc 


      • Hi Touotune06, i'm Giuseppe from video Octocopter with Pixhawk.

        A few days ago I also had a crash with ocotcopter with Pixhawk and Afro30a,

        here video:


        I flew 17 times in few days, with high payload without problems, and now I'm investigating the cause.

        Looking at the log, it seems mechanical failure of esc/motor 8, but it was a strange behavior (you can see at log RCOUT)  
        At the end of the flight, I put the Throttle to the max and probably happened Bug stability (I use 3.1.2) during the flight but still I can not explain what happened before.

        I can not say that it is loss of sync, but I follow with interest.

        Best regards - Giuseppe


        • Sorry to hear that you had the problem too. octocopter your fly so well ...
          I was envious to have the same result, and voila you encountered the same problem. I can apris a better used Mission planner and I looked to RCout outputs and for me the logs tell me that RCout 2 had a problem.

  • Bonjour.
    Après mon premier vol avec pixhawk (et mon premier crash trop) je me rends compte que j'ai le même problème que vous. une accélération soudaine mon quadcopter a un moteur qui est désynchronisation et l'accident était inévitable. J'aurais dû faire le test avant le premier vol parce que j'avais déjà vu votre problème ici.

    Voici le sujet que j'ai créé hier de mon problème.
    J'ai joint le fichier journal de l'avion et la vidéo de l'accident filmé depuis le sol par un ami. Heureusement il n'y avait pas de dégâts

    http://diydrones.com/forum/topics/my-first-flight-in-pixhawk-it-end ...

    my configuration:

    4x sunnysky x4110s 580kv

    4X prop 15x5.5 carbon dji type

    4x esc HK Afro 30A

    3dr Pixhawk and last firmware

  • I think I'm noticing a similar problem. I hooked up my Pixhawk over the weekend for the first time. I can calibrate my ESCs fine. When I hold the safety switch and arm it for the first time, throttle behaves as expected. 

    It's when I then disarm and hold the safety switch again that the ESCs start emitting a beep every second or two. Is this ESC sync as well?

    Video of power up, safety switch on, arming, throttle up, disarming, safety switch off then the ESC beeps.


    Perhaps related, I have a FrSky D8R-II PLUS running d8r-XP firmware for cppm. I'm starting to suspect this as the culprit but figured I'd post here anyway.

    Attached log from run in the video.

    Running stock 3DR simonk 20a escs and the 880kv motors.


    • No, that has nothing to do with ESC sync.  That happens because when you push the switch again, it turns off the PWM signal, so the ESC's are beeping to tell you they are not getting a signal.  This is normal.

      • Oh, thanks Rob! I did suspect that but couldn't find anything online about it and didn't want to fly without knowing. Legend.
        • I actually do caution against pushing the button a second time... makes me a little nervous.  I'm pretty sure most ESC's are programmed to not do anything after booting up, until they receive a valid signal.  But it's not clear that all will be well-behaved if the signal disappears after they have armed and run the first time.

          I'm not saying this is a problem, but... I'm cautious until I know more.  I usually just leave it armed until I pull the battery connector.

          • HI Rob,,,  can you have a look at my crash thread 


            It may be the same problem.. I have logs and video of a crash during landing approach,, and you can hear the motors "hunting" a bit,, right before the model goes nuts...  I'm wondering now if a motor fell out of sync??

            Cheers  BOB

          • Yep, good call. I'll be doing the same.
This reply was deleted.