I believe I have a problem with my Pixhawk and was hoping for some help.  Also posted this on rcgroups.

The issue is that when my speed controllers are hooked up to the Pixhawk they exhibit a bad sync issue.  However when they are connected to my old APM (3.1) or just a receiver directly they do not exhibit these symptoms.  This has resulted in 4 crashes now until I just tonight narrowed down the issue to the Pixhawk.

Can anyone advise what is going on?  Here are the specs of my setup:

Afro 30A ESC's with SimonK firmware (have tried all versions, and made my own with various parameters)

Tiger MT2216-9 1100kv motors

4S 3700mah battery

https://www.youtube.com/watch?v=i7_gVoY8q8M

https://www.youtube.com/watch?v=VTK81IANyUE

Views: 46751

Reply to This

Replies to This Discussion

Hi Philip,

Just to be sure I went back to 3.1.5 and that fixed the problem and also returned the throttle response to be smooth instead of strange with 3.2.  After about a minute I lose low end resolution, meaning that if I close the throttle and simply raise it a small amount the motors jump up to about 30%.

Every time I revert to 3.1.5 the problem goes away.

I have tried two Pixhawk boards, several 3DR ESC/Motors and even connecting ESC directly to Rx.  Always exactly the same issue , always motor no.6 always completely fixed by reverting to 3.1.5.

I use 3.2 on my quad and it is fine.  I do not know what the issue is other than I am getting to the point where I am starting to feel it is software related.

I will reinstall 3.2 and send you a video of the problem and also the performance on 3.1.5 before I send you my Y6B.  Would you agree that if I can show that the problem only occurs on 3.2 that something in the firmware is causing a problem and sending my Y6 to you would not really help?  Possible not a bug but something that shows up more in 3.2 and causes a problem that 3.1.5 doesn't..

I have replaced,, bypassed and checked every possible combination and I feel confident in saying it is extremely unlikely to be a hardware issue unless I have three ESC and four motors and two Pixhawk boards with the same exact problem.  I am not trying to have a go just stating that I have tried to find the problem by looking for a hardware solution and have got nowhere.

Usually, when a problem is this hard to solve I find that I am looking in the wrong place.  If is was an ESC/Motor, Wiring (This is a 3DR RTF built in the factory) than surely I would have found the issue.  If there was no issue it would not have flipped and crashed while simply hovering.

xoltri, if you are using the 3DR PDB then the ground on the ESC PDB connector is the same as the battery -ve, there is no difference between battery -ve and ESC -ve so I do not think that there is a "ground Loop" or difference in voltage levels here.  Might be something to do with noise but I cannot think why it is always Motor No.6 for me and is the same with or without the PDB.  Also, 3.1.5 fixes the issue consistently, as consistently as I am having the fault when I try 3.2 on the Y6B

Hi Philip,

Here is a pic of what happens over a few minutes with the throttle just above min.  As you can see motor 1 goes up and 6 drops to THR_MIN.  I close the throttle twice and each time I opened it the RC out jump up keeping the relative offsets.  Is this normal??

Attachments:

Here it is again with RC3 in shown.  RC3 in noise is throttle moving between 1113 to 1115.  This happens on 3.2, on 3.1.5 it is less much less pronounced.

I seem to be able to reduce the chance of loosing sync on motor 6 if I arm and throttle up straight away and keep above 40% which would be normal for flight but it worries me that I can make the motor lose sync, it has caused a crash once and stying above 40% throttle does not always stop the problem.

So far so good with the Spiders; responsive and no sync issues. Tomorrow, weather permitting, the props go on for the real test. Morale is high :)

Looks like you are not level, and the copter is trying to level the copter?

Please enable the EKF and repeat your test....
please PM me your Skype

Yeah it is not exactly level.  One way reads 0.04 if I turn it around it is -0.04, if I move it to another spot it can read as high as +/-0.44 but always well under 0.5 degrees.  I would have thought that such a small level offset was ok as it is almost impossible to maintain exactly 0 degrees in all axis on the bench let alone in the field.

I do not think that the motor offsets is directly a problem but the code attempting to compensate for a small level offset.  On the bench it tries to correct, nothing moves (as it is being held down) and it tries to compensate more.  Repeats this process and the offsets become quite large.  Allowing the Y6 to hover slightly seems to reduce the effect of the offsetting motor gain but don not eliminate it.

I did what you suggested and completely level with EKF on (it has been on for all of the recent tests as I tried with and without with no real difference).  I did notice that the EKF 1,2,3,4 logs were all reading flat lined values so I am not sure if something else is wrong here.

Logging is enabled and exactly the same as my quad which does log EKF values OK.  In fact I have used this quite a lot for tuning etc. on the quad.

Just because I refuse to actually believe that 3.2 is the fault (too many people using it ok and my other quads/planes all work finer with Pixhawk and AP or AC)

I will swap, one more time, the working combination of ESC/motor No 5 into the No6 position, including PDB connections and physical position in the frame. No wiring change there than changing the position of the power connections on the PDB but I will leave all of the ECS to motor connections alone.  This combination has not failed at all so if it does I will be able to lock down the point of failure.

If I can get the problem to move I will know it is the ESC/Motor or wiring.  I have done this with one ESC before but have not been able to make the problem move.  One more try just in case I had two faulty ESC's.

I have also replaced ESC's (No 6) and Motor (No.6).  Thank for your help.  What is frustrating me is that I have tried the normal fault finding stuff like replacing or swapping one component at a time and so far I have always had the same problem.  Normally this would point at the controller but I know that this is very unlikely.  It is repeatable and always on the same motor.

I know I have started to look for causes that are not really viable but that is what happens when you think you have exhausted all of the obvious possible faults.

Anyway, I will let you know how I go with swapping components to see if I can move the fault.

I wonder if I tied the two ground wires from the 6 pin connector to the ground of the power distribution board if that would fix the problem.  But I don't know enough to be sure, and I'm not brave enough to try.

xoltri,

  Did you read this? http://is.gd/y8D7Ny 

Someone said it was gibberish; so take it for what it's worth. There is disagreement of it helping, but nobody has said it would hurt anything. This issue is not confined to DIY. I've seen it discussed at RCG.

When I had problems with Maytech ESC's, I wired a UBEC to the 'AUX OUT' connector because there wasn't enough wire to reach to the other side to the 'MAIN OUT' and I thought both rails were on the same ground circuit. Recently IIRC, someone said the ground is not on the same circuit for 'MAIN OUT' and 'AUX OUT', so when installing the Spiders yesterday I rewired the UBEC to #7 on 'MAIN OUT'.

Because I have since returned the Maytechs, there is no way to prove the rewiring would have fixed the sync problems, but now with the spiders everything seems ok. Had it not rained I would have flown.

Also note I disconnected all + wires from the ESC's when using the 3DR versions, and only used the HW UBEC, plus I am using OPTO now. 

Below is my wiring. It does not loop the PM to the rails, but the HW UBEC is on #7 'Main Out' connector. I say try examples in that thread and see what happens. Note the use of a separate battery in a few of the examples.

Alex,

  Have you noticed a difference in throttle RC_OUT vs RC_IN? When arming, my props spin on the slow side, but just a small throttle movement (one graduation on the stick), the motors seem to spin much faster than they should.

To be honest, I don't recall if it was this way on my stock Y6B.

Is there an adjustment in the parameters that give a smoother throttle response? Or is it inherent with the tx?

I can assure you all the PWM channels ground and power are connected in parallel on the Pixhawk, however Pixhawk does not provide power out to the servos...

There are some ESC's like the KDE, that need 5v to be supplied to the servo rail. These would require that you have a Bec attached to the servo rail.

Thanks I thought that was the case.  As it is an RTF build I am not questioning the wiring, I am sure it is fine and it all makes sense to me.

Good new is that I finally made the problem move to motor no.5 bad new is that it is doing the same thing.

Made the problem move by taking the good (original ESC/Motor 5) and moved it to position 6.  Rewired it to PDB No6 position for good measure.

This fixed No6.  This worked perfectly.

Then, I installed a brand new 3DR ESC (my last one) as ESC No5. and connected it to the original motor 6 which is now in the No5 position.  I was hoping to see if the problem stayed with the No6 chain or moved.  It Moved!!!  Finally.

After three ESC, three motors and several changes of this sort I made the problem move.  Not sure why but when I tried this before the problem did not follow the ESC or Motor.

Now the only thing that was original in this chain was one motor and cable (black) connecting it to the new ESC.

Installed new motor, including wires.  No5 motor now exhibits the same problem.  It will spin up ok but randomly stall, pause, skip and then keep going.  It happens at different RPM.

I am happy that I have finally made the problem move. What confuses me is that this is now the third completely new combo I have put in and I still get exactly the same issue. I did find an original cable with exposed wires, it looked like it has separated the insulation as it was pulled down the arm.  Could this have been destroying the ESC's as I put them in?

So now I guess I should buy another 3DR ESC and see if that fixes the issue.

DG, Short answer, YES.

This happen to me only after a short time armed.  The first time I raise the throttle it is smooth, only happens on the Y6 not my quad's.

As the first time I ramp up is smooth I am guessing that it is not the Tx.  I have tried changing limits and resolution, even tried some EXPO setting but it is always the same.

I actually think this is normal and OK.  It seems to be the code trying to account for small level offsets, not getting anywhere as it is on the bench and adding more power to compensate.

If you lift the machine f the bench and allow it to level itself this gets less pronounced.  Don't fight it if it is leaning over, it will correct itself.  Problem here is that you have to test with props on!!!!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service