Pixhawk PWM input for RSSI (EZUHF)

Gents I need your help.

I recently upgraded one of my 2.6APM powered quads to a Pixhawk.  One of the reasons I went ahead and did this is because the Pixhawk is supposed to take PWM RSSI signals directly (into the Sbus port aka Pin 103) and I could ditch my PWM to analog conversion circuit is used in my APM.

I have verified that my EZUHF receiver is outputting RSSI in PWM form on one of the channels. (it will move a servo appropriately when the RF gets weak or disappears... and it worked fine for the APM as an RSSI input via a PWM to analog conversion circuit)

And, I have hooked up the PWM RSSI output to the Sbus port (pin 103).... it does nothing.  Shows zero RSSI on the OSD no matter what.

I can't find any useful description of how to configure this in the wiki, mission planner or this site.

How do you make a Pixhawk show RSSI from a PWM input on pin 103 as its advertised?

Thanks for your help.

Steve

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Hi Steve!

        Would you mind posting a pic or showing me how to plug the Pixhawk with EZUHF 8ch diversity?

        I've set ezuhf via USB to work as PPM through CH1; however, I'm able to power up the receiver but when I try to bind, I push the bind button, it goes off and never comes back on.... :(

        Am I suppose to connect the ezuhf to RC in pixhawk or SB pin 103?

        I would really appreciate your help...

        Thanks

        Javier

        • Javier,

          The bind procedure on the EZUHF needs to work before anything in the APM/Pixhawk world will work... When the receiver is bound the light on the receiver will ramp up from dim to bright at the rate of about twice per second.  If its not doing this, it's not bound.

          Once you are sure that the receiver is bound (use immersion tools to make sure the firmware of the xmtr and rcv are the same version... and if you are struggling with the bind, it is possible to bind the receiver to the xmtr from within the immersion tools.)

          You also need to make two configuration settings in the immersion tools...

          1) set PPM to come out of channel 1

          2) set the RSSI or signal quality (I prefer signal quality) to come out of channel 8 - no flexibility here... it has to be channel 8.

          with these settings made and the ezuhf bound.... you only need one (three conductor) wire between the ezuhf and the Pixhawk... connect channel 1 of the receiver to the RC input (picture above in this thread)... and voila it works.

           

          • Steve!!! Thanks a lot Man!!

            So, I was able to bind, but I did had to update firmware on my TX up to 1.50...

            I just run a small test and pixhawk its reading ezuhf now :)

            I didn't wanted to get back to u unless I had tried it... I really appreciate your help!

            Thanks!

            Javier

      • There is an easier way. I have a EZUHF and see RSSI on my minimosd but i have a APM. The trick is to config the EZUHF rx to send the rssi as PWM over a channel. It doesnt matter which, just pick one of the high ones like 5 - 8. The APM wont know its RSSI it will think its just another regular channel.

        You can config this using the Immersion config tool. You can then config minimosd-extra to read rssi over that same channel. The minimosd-extra config tool has this option available.

        The only downside is that you lose a channel between the rx and the apm. However i still have 8 channels coming thru i simply connect one directly to my gimbal to control the tilt. I thus end up with 7 + the rssi going to the APM and one from the rx to my gimbal.

        Its simple and works, no extra hardware or fancy analog to digital converter type bits.

        • Ok, I figured it out...MinimOSD to the rescue!

          I needed to update the config tool to 2.4r727 and the corresponding firmware for minim OSD... now my RSSI (link quality actually) shows up on my OSD with no extra hardware.

          This is exactly what I wanted.

          • Hi Steve,
            Wow, the hours I have worked to get RSSI from my pixhawk ( plane, not copter ) on my minim OSD !
            And as of today, still no luck.
            I have been following this thread and have followed all of the steps to achieve RSSI from my Pixhawk to my minim OSD.

            On the minim CT , I set the rssi pin to channel 7, (and accordingly set the RSSI ppm output channel on the receiver to 7 as well )
            Rssi is still reporting a non changing value of -99 on the screen , regardless of the transmitter being on or off.

            I checked the actual output of the rssi by connecting a servo to the no 7 channel and the servo moves when the rssi changes, so I know channel 7 is outputting a proper pwm signal representing the rssi.


            Is there something else you did in MP to effectively get the pixhawk to "see " the rssi ?

            On MP, I tried setting the RSSI pin parameter to " pixhawk" (103) ,nothing. Tried typing in A7 for analog pin 7,nothing. Tried the other "A" numbers in the drop down box, but no changes.

            I am 5 plus hours into this and completely baffled. Your help would be GREATLY appreciated !!

            Mark
            • Mark,

              There a couple of "gotcha's" in the setup.  

              1) this works with 2.4r727... not the earlier releases

              2) despite the ability to select different channels the minim OSD software only works with channel 8.  (I think this is where your problem is)

              3) I feed the PPM sum stream to the pixhawk, not individual channels.  I suspect it will still work with individual channels but my setups are all via a sum stream... 

              There is nothing you need to do in mission planner to make this work.

              I suggest setting the ezuhf signal quality to channel 8 and you will be good to go (other than calibrating it.)

              A couple other suggestions...  I prefer signal quality to RSSI because it is possible to have really strong signal strength but poor signal quality... this happens when you have things like the camera putting out noise on the 433MHz band.

              To find zero and 100% set the minimosd to raw first and write down the numbers that appear when you switch the transmitter on and off... this will give you the figures to calibrate full and null signal... then go back into minim OSD put those figures in and remove the raw number switch... 

              Sorry for the frustration on this, but it can be made to work

              • Thanks again for your help Steve. I have it performing on the bench as per the RSSI extremes , that being the 900/1600 pwm metrics. I flew it this afternoon and experimented with the RSSI failure points by putting the EZUHF into attenuation mode ( switching from hi to low power while holding the bind button down ) and then flying out low (400 feet )about 1/2 mile in auto mode. The rssi got to about 30%, but did not trigger failsafe. I found by gripping the EZ UHF antenna with my hands at the 3,000 foot mark, , I got the rssi numbers up to around 50 to 60%, and around at 65 percent DID trigger failsafe. I repeated it three times , and would say 65 percent is where rssi is going to indicate failure. I will try , as you suggested, the link quality metrics tomorrow and report my findings. Thanks again for your help !
              • I found that ezuhf RSSI has a pwm range from about 990 to 1600 - but inverted so 100% is no signal an 0% is full signal.

                Using ezuhf LINK (link quality) the pwm range is 1050 go 1790 and gives 0% for no signal (transmitter turned off) and 100% for full signal

                would be great if the reading could be inverted in the config tool. I tried giving the higher pwm value as min and the lower as max but this does not work.

                • Rob: did you solve the problem of inverted values?, in my case, RSSI and Link Qty gave me the same inverted numbers, big number for transmiter off, and small one for full signal, your experience with this matter would be frankly appreciated.
This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…