Pixhawk with low KV motors unstable/crash

Round two on flying the quad successfully failed. On the first flight with just easy flying, the quad starts wobbling all over the place until I force it down quickly. Now on run two after a complete flash of the firmware and re setup. During an auto tune it did the same thing. But not actually during the tune as it was paused when I was re-positioning the quad. My guess is the stock pids are two high for the low kv of the motors. I'm not too knowledgeable on adjusting the pids with the Pixhawk but will certainly take some suggestions on where to set them to help it fly better and survive an auto tune. I'm fairly certain it's the stock pids because it is a little unstable just flying it around. I'ts like it can't respond fast enough with the low KV motors and large props. I linked a video of the last couple of minutes before the crash during the auto tune. 

Tarot 650 Ironman

Pixhawk with 3DR GPS

T-Motor 3508-29 380KV

15" 5.5 props

4S 5200

AUW 1590g

Crash vid - https://youtu.be/vA_LnW36m6A

Log file - https://www.dropbox.com/s/68fkzq0ik3o55ke/2016-04-12%2017-24-43.bin?dl=0

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Err. EKF_CHECK-2

    Err. EKF_CHECK-0

    Err. 24-1

    Err. CRASH_CHECK-1

    Someone else will have to tell you what this error codes mean..i am no expert,check at bottom of this page

    http://ardupilot.org/copter/docs/common-diagnosing-problems-using-l...

    I think vibrations on Z was responsibile for EKF to fail #define ERROR_SUBSYSTEM_EKF_PRIMARY 24

    3702328922?profile=original

    Diagnosing problems using Logs — Copter documentation
  • Thank You

    I´ll be posting there.

    Here is my data log

    https://www.dropbox.com/s/rmyef6rgua48zng/2016-11-26%2018-40-21.bin...

    Thanks again

    Emin Bu said:

    Tom Kopp,You should post your questions here http://discuss.ardupilot.org together with dataflash logs

    POSTED LINK WITH YOUR LOGS DOES NOT WORK

    This is new web where all developers "live"....no answers from them here

    Maybe my post on tuning big multi with low KV can help

    http://discuss.ardupilot.org/t/heavy-y6-adventure-thru-3-4-rc-with-...

    Can you post your BLHeli settings?

    One shot and oneshot 125 turned off?

    Are you sure you calibrated ESC properly?

    Dropbox - Error
    Dropbox is a free service that lets you bring your photos, docs, and videos anywhere and share them easily. Never email yourself a file again!
  • I use 330KV Tmotors on Afro ESCs from HK on a 4Kg quad and there are no issues. I ran autotune with the recommended reduction in frequency (see the ardu manual for that) and it all works nicely.

  • Tom Kopp,You should post your questions here http://discuss.ardupilot.org together with dataflash logs

    POSTED LINK WITH YOUR LOGS DOES NOT WORK

    This is new web where all developers "live"....no answers from them here

    Maybe my post on tuning big multi with low KV can help

    http://discuss.ardupilot.org/t/heavy-y6-adventure-thru-3-4-rc-with-...

    Can you post your BLHeli settings?

    One shot and oneshot 125 turned off?

    Are you sure you calibrated ESC properly?

  • In my opinion that kind of setup in general requires higher PIDs, not lower... try to make an auto tune with reduced filter hz to 10 and try to play around with the auto tune aggression paramas

  • As a matter of fact i was curious if my simon k would work with the low kv motors... I have 4 of the xrotor 40A in my stash at home ;) 

  • And as I noted in that ardupilot thread, if you want good, worry free ESCs for low KV motors on heavier rigs, the Hobbywing Xrotors work great.  And no, I wasn't paid for that.  :)

  • I read in the forums that it was an issue with low Kv motors and ESC with SimonK Software.

    http://discuss.ardupilot.org/t/arducopter-3-2-1-autotune-problems-w...

    Seems that my ESC can´t be re-program I use 30A Opto Oneshot 125 Spider ESC.

    Here is a Link to my Log file

    https://www.dropbox.com/s/rmyef6rgua48zng/2016-11-26%2018-40-21.bin...

    Thanks

    Niels G. said:

    Thats strange.. I used AT yesterday and it was just perfect. 

    I fly a Tarot x4 with 40A Opto ESC SimonK

    22x5,5 CF Props and 5008/ 330KV Motors on 6s

    Put AT aggr to 0,06 and the gyro filter to 10hz

  • Thats strange.. I used AT yesterday and it was just perfect. 

    I fly a Tarot x4 with 40A Opto ESC SimonK

    22x5,5 CF Props and 5008/ 330KV Motors on 6s

    Put AT aggr to 0,06 and the gyro filter to 10hz

  • I just have the same problem!! Crashed five times. When I use autotune the quad goes unstable.

    Did you solve it???

    Thanks in Advance

    Tarot 650

    Pixhawk with 3DR GPS

    14" x4.7" Carbon Fibre props

    6S 5000

    Spider 30 Amp Opto ESC

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…