PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Has anybody gotten a Spekrum satellite receiver to work with the Pixracer? I saw the discussion about the sbus/hott issues on the first page that have been fixed and Phillip's comment that he tested "spektrum ppm" and it worked. However, myself and @Fabrice have had some issues with the spektrum satellite, see here. Mission planner shows all zeros on the radio calibration page and the status pane. Also, Mavproxy reports RC_CHANNELS_RAW messages with all zeros as well.

    I've got the latest 3.3.4-pixracer firmware, have bound the satellite to the transmitter using the standard AR8000 receiver, solid orange on the receiver and the radio failsafe is disabled. It could easily still be a mistake in my setup but I haven't found it yet.

    Also, I tested a build of master (3.4-dev) on my PH1 and everything worked fine with the satellite receiver. 



  • With Pixracer, and Copter-3.3.4-pixracer does the LED on the safety switch blink when unarmed  or does it remain solid red  at all times?



    • It remains solid/armed at all times. 

      • Thanks, Scott.

  • Has anyone successfully calibrated their ESC's with APM/MP and the pixracer? 
    I don't want to spend a lot of time trying to figure out my issue, if it's simply not working. 

    (otoh, it's my first time w/ blheli ESC's, so maybe something is different w/ them?)
    I've discovered my manual calibration via PWM must be different than the PPM signal through the controller.. I have a dead spot between motors spinning at idle, and spinning via throttle.   Thr_min does not seem to be the issue (but I'm open to advice, if someone thinks it could be settings related).

  • Seems like a bad current sensor. Bridge current sense pin with the voltage sense pin and see if you register current. Both at 0 to 3.3 volt inputs.
    • Bridging the voltage, which is at about 860mv shows about 28amps in MissionPlanner. 
      It sounds like this might not be arducopter related, so I'll email you tomorrow, and can do any other testing then.

  • Hi,

    is the latest development FW (Copter V3.4-dev from March 1, 2016)

    compatible with PixRacer?

    Or do I have to use the Copter 3.3.4_rc4 pixracer?




    • Developer


      "latest" (aka "master") will also work.  We did the fixes in "latest" as a first step and then back ported them to Copter-3.3.4.

      In general I'd prefer if people used the official release (i.e. Copter-3.3.4-pixracer) because it's been more thoroughly tested.  I've got a big set of changes that will go into "latest" in about a week and I worry that "latest" could be a bit unstable for a few days at least.

      • Where can we get Copter-3.3.4-pixracer...or is that still to come?

        Thanks, Ed,

This reply was deleted.