PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Quick question - when you say 'hard mount' do you mean mounting the PixRacer directly to the frame without any vibration padding or foam under it?

    Phillip Kocmoud said:

    I hard mount my PixRacers and vibration has never been an issue. Do you have logs to share and some photos? At this point I cannot even begin to speculate.
  • Developer

    As a side note, I think it's best to move ardupilot support over to the support forums.

  • Ok, I removed it from the frame and it still has the compass offset warnings and I also notice that it says gyros are still settling now and then also... I think it's a lost cause.

  • Yeah, I'm still not sure, I've tried QGroundControl and it shows that both my compasses are not exactly good. Next steps are to remove the flight control from the frame and try it. I'll got it from you Phil a long time ago. As I said, it's not even seen a test flight yet. I'll let you know what happens.


  • @Philip

    The latest QGC master has the health indicators when you use the onboard calibration of ArduPilot Copter (3.4.4/3.4.3) wired

    Usually the 3rd compass is quite problematic specially on X, but the 2nd compass (1st is the external) manages to get reasonable results. This has been a recurring issue but not a show stopper...


  • Don, this is awesome. I just did a compass cal last night with the most recent stable release of QGC and did not see this feature? Opps, I guess this is specific to the APM firmware!

    In my experience bad compass calibration on a Pixracer is most associated with the buzzer being too close to the flight controller. Try removing it as a test or moving it as far as possible away from the flight controller.

    If the compass is bad and you received it from me, contact me for a replacement.


  • The internal compasses on a PixRacer can be a pain. If the quality is bad you need to turn one or more of them off usually. If you use QGroundControl to do onboard compass calibration at the end you will be shown a quality report for each compass. You can then use this information to determine if you want to turn one or more of them off. Hopefully after that you are still left with one good compass! Docs:


  • Usually this means something magnetic or large metal is close by messing with the compass.  Have you tried removing it from the copter and setting it on a table and try and calibrate it from there?

  • I can't seem to get the compass to act right, no matter what I do it tells me the compass offset is too high. I recently just tried to update to the latest firmware 3.4.4 and still no luck. Haven't even seen a flight with this board yet... starting to think the only way to get this board in the air is if I throw it. I don't have a GPS on this thing so there's only the onboard compass. Any assistance would be great.

  • Yup, sent you a PM. Thanks, Ed,

This reply was deleted.