Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Quick question - when you say 'hard mount' do you mean mounting the PixRacer directly to the frame without any vibration padding or foam under it?

    Phillip Kocmoud said:

    Edgar,
    I hard mount my PixRacers and vibration has never been an issue. Do you have logs to share and some photos? At this point I cannot even begin to speculate.
  • Developer

    As a side note, I think it's best to move ardupilot support over to the ardupilot.org support forums.

  • Ok, I removed it from the frame and it still has the compass offset warnings and I also notice that it says gyros are still settling now and then also... I think it's a lost cause.

  • Yeah, I'm still not sure, I've tried QGroundControl and it shows that both my compasses are not exactly good. Next steps are to remove the flight control from the frame and try it. I'll got it from you Phil a long time ago. As I said, it's not even seen a test flight yet. I'll let you know what happens.

    compass.png

  • @Philip

    The latest QGC master has the health indicators when you use the onboard calibration of ArduPilot Copter (3.4.4/3.4.3) wired

    Usually the 3rd compass is quite problematic specially on X, but the 2nd compass (1st is the external) manages to get reasonable results. This has been a recurring issue but not a show stopper...

    regards

  • Don, this is awesome. I just did a compass cal last night with the most recent stable release of QGC and did not see this feature? Opps, I guess this is specific to the APM firmware!

    In my experience bad compass calibration on a Pixracer is most associated with the buzzer being too close to the flight controller. Try removing it as a test or moving it as far as possible away from the flight controller.

    If the compass is bad and you received it from me, contact me for a replacement.

    Phil


  • The internal compasses on a PixRacer can be a pain. If the quality is bad you need to turn one or more of them off usually. If you use QGroundControl to do onboard compass calibration at the end you will be shown a quality report for each compass. You can then use this information to determine if you want to turn one or more of them off. Hopefully after that you are still left with one good compass! Docs: https://donlakeflyer.gitbooks.io/qgroundcontrol-user-guide/content/...

    3702341659?profile=original

  • Usually this means something magnetic or large metal is close by messing with the compass.  Have you tried removing it from the copter and setting it on a table and try and calibrate it from there?

  • I can't seem to get the compass to act right, no matter what I do it tells me the compass offset is too high. I recently just tried to update to the latest firmware 3.4.4 and still no luck. Haven't even seen a flight with this board yet... starting to think the only way to get this board in the air is if I throw it. I don't have a GPS on this thing so there's only the onboard compass. Any assistance would be great.

  • Yup, sent you a PM. Thanks, Ed,

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
21 hours ago
DIY Robocars via Twitter
21 hours ago
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
DIY Robocars via Twitter
RT @chr1sa: We've got a record 50 teams competing in this month's @DIYRobocars @donkey_car virtual AI car race. Starting today at 10:00am…
Nov 7
DIY Robocars via Twitter
Nov 6
DIY Robocars via Twitter
RT @a1k0n: Car's view, using a fisheye camera. The ceiling light tracking algorithm gave me some ideas to improve ConeSLAM, and having grou…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: To get ground truth I measured the rug, found the pixel coordinates of its corners, calibrated my phone camera with my standard…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: @DIYRobocars is back in December, but outside. Time to reinvestigate ConeSLAM! I rigged up a quick and dirty ground-truth captur…
Nov 5
More…