Taranis / FrSky X8R Sbus issue with Pixhawk

Hello Folks:-)

I have a big problem to get the Pixhawk running with my Taranis plus and the X8R receiver.

Here I already posted the Issue.

What I have:

Taranis Plus with Firmware 2.0.17 and latest  internal XJT non_EU  update.

X8R Frsky Rx also with latest non_EU update.

3DR Pixhawk and a clone from belize

Arducopter 3.3-rc7 (also test 3.2.1)

What I did:

I flew many hours with my small grasshopper 250 very well with my old Futaba with Jeti TX system. The Jeti Rx has a CPPM out. The System is stable in all phases and all Modes.

Now I want to give my Taranis plus a try which I bought in 12/2014. So connected the X8R SBUS direct to the RCin from the Pixhawk and calibrated the Radio in Missionplaner with no problem.

The Issue:

The Copter flies, with the FrSky system, in stabilize as usual and very good. As soon the Mode changed to Alt.hold, Pos.hold or RTL the copter get some wobbling or unstable attitude if a interference coming up. The interference can come from a gust, or a RC input. Special when  switch in Autotune the Copter become very unstable, sometime he fall out of the Sky.

Once it was possible to complete the Autotune in roll and it gives me a PID from P=0.01;I=0.01!!

I also switched off the Tx during a fast forward flight, as the RTL command came the copter wobbles very heavy, which It not does with the Jeti Rx!

What I tried to solve:

Changed old to new Firmwares on the Rx,Tx and Pixhawk, 

Tried another Pixhawk, another Rx and a D4R-2.

Changed the PID in a lot of direction (I´ve experiences in tuning PID´s)

Changed in between, with exact the same setup, to my old Futaba/Jeti system without any Issue!

I've setup the system from the scratch, several times.

Bind the Tx/Rx in differend modes several times.

Had a look on the sbus out with a Oscilloscope to check the Signal.

Now I´m at the end of my knowledge and need help from the Forum to figure out the problem.

I´ve seen that the sbus signal goes to another input of the STM32F100C8T6B (IO CPU) in the Pixhawk. So maybe the Firmware of that CPU has a bug. Does the IO CPU will be update with the Firmware from the Missionplaner, or is in the STM32F100C8T6B a fixe Firmware?

I know the beaver is strange and unbelievable but true!
May be there is someone from Germany who has the same setup and like to help me personal.

All constructive inputs are welcome!

the test Copter:

3691224123?profile=original

here is a log from the Autotune with AGGR 0.05

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Now I can confirm the Issue!

    With a second Taranis I had the same issue but only in my flying Area!

    After flashing the XJT Tx and the Rx with the new eu-Firmware the problem was solved!

  • I guess I could find the Problem!
    In my Flying area are to many 2,4Ghz devices that course the interferences, even when the RX is off and the Copter fly Automission or RTL.
    I flashed the XJT and the Receiver with the new EU-Firmware! But still I've to fulfill more test to be sure.

    Thanks for all the hints!

  • Do you have foam over the baro?  Something had to change between receiver changes.  Have you tried the jeti again to see if the instability still happens?

    • Yes, foam over the baro! I´m always swap between Jeti and Taranis to see the different

  • Today I finished my Alien560 Copter.

    There is more place for all the Items. Just for testing I separate Radio/Rx from GPS/Compass.

    But unfortunately I have the Same Issue! After switching in Autotune the Copter crash.

    With the Jeti system I've no Issue withe the same setup!

    here the log

    and the Pic of the testing Copter

    3702047313?profile=original

    Dropbox - Error
    Dropbox is a free service that lets you bring your photos, docs, and videos anywhere and share them easily. Never email yourself a file again!
    • It will help your RSSI to move your antennae to be at 90 degrees with one on its flat side and the other on its edge... (See pic) It will probably not help your issue though... I have the same setup running same FW and all is good. Sorry to hear you are still having problems.
      IMG_20150716_191121.jpg

  • I experienced a similar problem with a APM on a mini 250 racing quad.

    I could fly fine in stabilize mode.  As soon as I went to altitude hold or GPS the copter would act very strange not holding altitude well and typically jumping up a bit as soon a AH was engaged and then falling to the ground.

    The issue was the close proximity of the props to an exposed flight controller.

    The pressure from the props confused the barometer.  Looking at the logs this could be seen.

    I did a quick and dirty test by enveloping the flight controller completely in a tape shield and it flew much better.

    The props are creating a negative pressure when they spin up.  The flight controller is above the props so it can see the negative pressure above the props.  It would then try to slow the motors and since lower pressure would be seen as a increase in altitude ending in a flop on the ground.

    This could be what you are seeing.  Normally the flight controller is much further away from the props in most copter and is not affected in the same way.

    • But then it would have the same behavior with the Jeti TX/RX, right? This is not the case

  • I don´t have a Camera

  • MR60

    Your setup must have something special because 99% of the people on this forum fly with a taranis,x8r and a Pixhawk without issues. Are you sure you connect the CPPM servo cable at the right ports of your receiver and Pixhawk? How is the receiver powered? How is Pixhawk powered?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
yesterday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Wednesday
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Wednesday
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Wednesday
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: What a great way to connect why @diyrobocars community is so valuable and important! Have to start somewhere @IndyAChallenge…
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: https://t.co/GwkbSBjdGa
Oct 23
More…