Dedicated to developing hardware and firmware for autonomous aquatic vehicles.

256 Members
Join Us!

Before Posting an Issue

Hi All,

Before posting an issue or a problem in the ArduBoat Discussion Forum, please check the wiki table of contents, review the firmware release notes in the subforum, and search that subforum for existing answers to your question. Help avoid duplicate threads by finding other members with the same issue and their solution.

When formulating your post, use a descriptive title such as "rover will not navigate to waypoints in the Auto mode" (not "HELP!" or "Problem").

Please include the following information to help diagnose your query:

  • Describe the problem you are having. What is the expected verses the observed behavior?
  • Provide hardware information such as the brand and version of your autopilot, GPS, radio, and compass, as well as any other pertinent details about your rover setup.
  • What version of the APM: ArdurRover2 firmware version are you running?
  • For navigation issues, provide your tlog and/or dataflash log. Click here for instructions on retrieving a dataflash log.

TCIII

You need to be a member of diydrones to add comments!

Join diydrones

Comments

  • Richard;

    Check the little battery on the GPS and make sure it did not get dislodged and short something out.  No blue light, no GPS fix.

    Regards,

    David R. Boulanger

  • Admin

    @Richard,

    Did the GPS break loose from its mount during the crash?

    If it did, you might want to open it up and check to see if any of the surface mount components broke away from the pwb.

    Is MP able to connect with and show a HDOP value of any kind.?

    If you do not get the flashing blue led in a clear sky, there is definitely a component problem with the GPS module.

    I have had several Rover crashes where the GPS/Compass module was impacted and it was always the compass that did not survive the impact unlike the GPS which came out just fine.

    Regards,

    TCIII AVD

  • Will impact affect my UBlox LEA6?

    A while ago I bought a Relentless (640mm) power cat and installed my APM 2.6, 3DR radio and my UBlox LEA6 into the boat along with a Orange LRS 433Mhz RX.

    All works well but the driver is a bit  . . . well, crap!

    During my learning I lost control of the boat, at full throttle (of course), and the boat slammed square into the side of the big boat I was standing on. I mean SQUARE! It hit just below the shine on the big boat and drove it's self under the big boat to the point that half of the boat was submerged and the throttle was still stuck on full, trying its best to get under the big boat.

    I did eventually get things under control and to my surprise the there was minimal structural damage to the boat.

    Everything seems to be working as normal but the GPS. I can't seem to get a fix. The compass works, if I unplug the compass it tells me I have a bad Compass and when I connect it the compass performs as well as the compass on my phone.

    The red led on the unit is lit but the blue led is not lit.

    Would the impact cause the GPS to fail?

    Is there any thing I can try to fix this?

    Thank in advance guys,

    RS

  • @ Richard  Yes, you can try this: http://www.rcgroups.com/forums/showthread.php?t=1688780

  • hi Thomas solved it!

    RC3 trim was the problem. it was at 1934!

  • After reading Grant's comment below and the info at the link, it occurs to me a potential short term workaround may be possible by setting a simple mission using a waypoint with the delay command and a DO_JUMP. 

    For example, we set the desired loiter location as a waypoint, and then have a delay for example, 600 seconds. After 10 minutes, it executes the DO_JUMP command returning to the waypoint and then waiting another 10 minutes. 

    Not quite as good as a true loiter function as wind/current can vary - but if it works it would get the job done. 

  • Thank you for the reply Grant.  It is active loitering that would be very useful for boats.  I will look forward to the beta release with active loitering.

    Regards,

    David R. Boulanger

  • Developer

    We already have a loiter at waypoint functionality in the beta release.  See this discussion here:

    http://diydrones.com/group/ardurover-user-group/forum/topics/rover-...

    I have written the code for the active loitering but it still needs some work so is only in my repo at the moment here if your interested:

    https://github.com/gmorph/ardupilot/tree/rover-return-to-loiter-way...

    Should be in the beta soon.

    Thanks, Grant.

  • Admin

    @Patrick Shuss,

    Start here

    Regards,

    TCIII AVD

  • How would adding the loiter function to rover be accomplished?
This reply was deleted.
E-mail me when people leave their comments –

Taking the boat round Manoel island.

Hey everyone I'm new here and my thing is USVs. Looking forward to sharing some more cool stuff in the future with you guys and I even sell this thing, And I even just sell the outboard system on its own so check it out.https://www.youtube.com/watch?v=U7ZYi0H6JVk20190403_145513.jpgScreen Shot 2019-09-14 at 2.30.40 PM.png

Read more…
0 Replies

Rudder control for kontiki

Hi all,I want to install a rudder on to my kontiki, which is like a submarine which floats on the surface and takes a fishing line out to sea.I am thinking of using an apm 2.8 with gps (because thats what i have) to drive a 20kg servo. The gps should point at a point about 3km out from the beach and the kontiki should follow that course until the timer turns off.I would be grateful for any advise how to go about this.

Read more…
3 Replies

How to connect 2 Brushless Motors and 1 rudder

Hi, I'm new to Pixhawk. I'm making a boat. I do have 2 brushless motor with ESC and 1 servo which is connected to the rudder. How can I connect them to the Pixhawk 2.4.8. What changes should I bring in the parameters? From readings, I come to know that servo should be connected to RC1 and motor to RC3. But what should I do when I have 2 motors, which are kept in both the ends. Thank you

Read more…
1 Reply

ASV Hydrographic project

Dear All, My name is Alfonso and two weeks ago i started my project to catamaran boat finalizated to hydrographic survey (first step only Single beam echo sounder and RTK Gps+datalogger) in lake and near shore. My configuration have only two motors and no rudder.My Hardaware consist in:1. Catamaran (1.60*1.0m )2.N.2 Trusther T2003.N.2 ESC Bluerobotics Basic4. Pixhawk PX45. radio telemetry6. N.1 Power Module (buy to bluerobotics)7. Taranis X9DPlus + receiver XR88. Radiolink Gps+compass9. N.2…

Read more…
1 Reply