How to assign a receiver channel as a pass-thru Pixhawk ?


I would like to configure two radio channel of my receiver to pass-through Pixhawk on its RC aux channels (that is the RC9 to RC14 aux PWM outputs).

I found in mission planner the RCx_FUNCTION parameter which allows to define that RCx will be used as a pass-through output. But the question is how do you allocate which receiver channel will be passed through it ?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thank you for the link. Interesting post there with lot of info :)

    Hope to enlighten me there

    Mike Kelly said:

  • @Mike Kelly: kindly explain how?  Also please confirm the channels are still fully programmable from the Pixhawk/Mavlink protocol (passthrough sounds like it won't do anything)?

  • Passthrough by definition is RCinx to RCoutx but now you can map just about any channel to any other channel. Like Ch6 to ch9 (aux1 on the Pixhawk).

  • Wait, since the AUX ports start with RC9, does that mean that unless your RC has 9 channels or more, you cannot control the AUX ports from your RC?

    I have a 6-channel RC.

  • It is a very good function, but it would be great if you could choose the channel at your RX

    If you want to use the aux channel instead the one of the 8 main ones you choose pass Thru channel number 8 at your receiver to Out number 9 (aux 1)

    Thanks to any one it is improving this great Autopilot


  • Is anyone else having issues with pass-thru on RC14? I have up to RC13 working just fine but for some reason RC14 is not outputting anything. I can see the pwm value change in Mission Planner but nothing is coming out of the pins. I have my gimbal tilt hooked up to RC13 using pass-thru and it works fine along with LED's and such using pass-thru on RC9-12, and now I want to connect gimbal yaw to RC14. Everything is assigned the same values for RC9-14 under RCx_FUNCTION and same goes on the Taranis TX. Is there something I am missing about RC14 pass-thru output?

  • Here is an update after I have done my tests yesterday. I can confirm that passthrough works, at least for my needs, which is passing through radio signal to gimbal controller (Martinez with Alexmos in my case) to control camera pitch. I had connected my receiver via SBUS to the RC input in the Pixhawk. I was able to pass through channel 8,9,10 just for the sake of the test. Camera movements were smooth and nice just like it would have been connected directly to the Gimbal controller. Note that my test was done NOT in flight.

    Interesting observation was that without a GND connected from Pixhawk to Gimbal nothing worked. When I then linked GNDs camera started to pitch :)

    3DR, Can you get this put up on a Wiki so that other can use the information? Please fill in if I have missed anything!

    Hope this helps others.


    Passthrough is a feature of a Pixhaw which allows you to pass the signal from the receiver through the Pixhawk and out to on the Pixhawks PWM and AUX outputs. Pixhawk does one-to-one mapping of the radio channels to it's outputs (PWM signal) which can be illustrated like this:

    RadioChannel1 -> PixhawkOutput1

    RadioChannel2 -> PixhawkOutput2


    RadioChannel7 -> PixhawkOutput7

    RadioChannel8 -> PixhawkOutput8

    RadioChannel9 -> PixhawkAUX1

    RadioChannel10 -> PixhawkAUX2


    RadioChannel14 -> PixhawkAUX6

    To enable and use passthrough feature follow these steps.

    1. Connect RC receiver to Pixhawk using the guide on 3DR Wiki

    2. In the Mission Planner set the RCx_FUNCTION paramerter to "1" for the RCx channel channel number you want to pass through. E.g. RC8_FUNCTION=1 will pass through Radio channel 8 to Pixhawk PWM Out 8. RC10_FUNCTION=10 will do the same for Radio channel 10 and pass through on AUX.

    3. Save parameters in the Mission Planner 

    4. Arm your Pixhawk (press and hold arm button) .

    IMPORTANT. You GND pin from Pixhawk output rail should be connected to your servos,gimbal_controller or whatever device you want to connect to and to it's GND pin.

    NOTE: AUX5,AUX6 pins are by default disabled(only AUX1-AUX4 enabled by default). You can enable them (if needed) by setting BRD_PWM_COUNT=6 in Mission Planner.


  • Olex I am curious how did you achive that? That will be my backup plan in case if passthrough to motor out will not work.

    How do you setup for example to passthrough RC8 fed via SBUX to AUX1 ?

    • RC8 can only go to motor #8 output. The RC and AUX numbers map to each other - RC9 can be output to AUX1, RC10 to AUX2 and so on. I can look up the exact parameters I used when I get home from work later today.

This reply was deleted.