I spent a lot of time to connect quadcopter to simulator.

I tried the AC 3.0.1Beta HIL firmware, after flashing I've done setup - reset

but the calibration radio does not start

then i go to advanced parameters and load my previous calibrarion data using compare paramerers button

after that i see green bars of radio.

next problem ac 3 cant be armed in hil mode with activated pre-arm check parameter. I deactivated this option

i try xplane 9 & 10 simulators with qro-x model

when throttle stick in down position simulator show 5% of throttle

if throttle stick up - simulator show 20% of throttle and do not move

i change throttle channel gain, sim show throttle > 60% and model starts to fly

in low throttle stick position sim show 50% of throttle and continue going up

then i check roll-pitch control - its work fine

but main, not solved problem in auto mode arducopter always have rotation at heading, it flies away in a spiral - never does not reach the waypoint

maybe someone had a successful experience with a simulator, tell me what the simulator is working properly and what settings should be applied

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Don't know if need help becaus it's an old post but what i do :

    I download first the "regular" firmware 2.74 for ex - make radio calibration and AFTER THAT  Idowload the same firmware but HIL version at the bottom of the screen and no need to calibration - thats works fine !

  • Alexey,
    I tried the same with same results, throttle cannot be set correctly. I cannot find the exact tutorial any more which explains what parameters X-Plane has to send. Actually I never managed to get the HIL up and running for a quad and X-Plane. Plane worked, but quad not, not with version 9 neither with ver 10.
    It's a pity not being able to test missions in X-Plane, the aerodynamic, physical and weather model is simply the best.
  • Developer

    I'm not sure the arducopter HIL stuff works since we added inertial navigation to the code.  I use to use AeroSimRC but gave up because it's accelerometer stuff didn't seem accurate.  Michael Oborne is actually more the expert on the inercation between the mission planner and the simulators.

    I now rely on the python simulator that tridge wrote which is also used by the autotester.  I can't run that directly on windows though so I run it on an Ubuntu virtual machine running on my windows box.  We don't have any instructions on setting that up unfortunately although most of it works if you can get the build with make working on the ubuntu machine.  Sorry, I know this is not an ideal situation - a simulator is very important for testing your developments before pushing them into the air in a copter but documenting the set-up hasn't reached the top of my to-do list yet.

    • Hi randy,

      I have the same question for Trad. Heli. I  have connected APM 2.5, DX8 and receiver to my pc. Now mission planner and X-plane are wotking together. But I need to calibrate it correctly. Heli is flying in X-plane. But Sticks are not working properly.

      Do you have a manual or param file to load?

This reply was deleted.