Motor spin slow than others

Hello, all , im working with APM 2.5, in X configuration, when i arm the APM, one motor (motor 4) spin slow than others 3.

When i calibrate the ESC's in automatic mode, all spin with same speed and work fine, but when
 i arm the APM and test, motor 4 speed slower. 

I changed the motor, but this continue...

Some configuration?

Any help?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello,

    I had the same problem and here's some tips to get it fixed.

    1. Verify the motors connections and ESC calibrations (If it seems ok for you, go to the second step).

    2.  With Mission Planner, look at the artificial sight and check if the copter is at level when it is on the floor (Your copter might try to compensate a wrong level by accelerating some motors). If the copter is not at level, check the APM 2.5 position or, if the APM is correctly placed, recalibrate the MPU. To recalibrate the MPU, you have to use the test given in Mission Planner (Configuration -> Arducopter Level)

    That's all i can tell for now.

  • Hello all if i change the output s3 to s4  (and s4 to s3) now motor 3 work bad and 4 fine, so may be the ESC ?

    is a new Hobbywing Skywalker Quattro 20A x4

    I repeat that all motors work fine in calibrate ESC mode single or automatic.

    Im testing without props, im checking the motor force comparing with finger..., now i can stop motor 3 with my finger, others not...

    Cables to motors are:

    Black to B
    Red to A
    Yellow to C

    i change A to C to change the orientation.

    What strange.. some help?


  • I find that on spool up prior to takeoff one motor may spool slower. Once at takeoff speed and as it leaves the ground all is OK.
    I too think it's just adjusting against sensor inputs that aren't familiar while in contact with the ground. May also be an effect of ground resonance. Just my guess.
    • ^This happens quite frequently with my quad. I won't be willing to take my chances, but my guess is as soon as you leave the ground, your motors should spin evenly then. Just to test, you can take all your props off, and start spinning the motors, then tilt the vehicle around by hand. The motors closest to the ground should speed up and the ones furthest should slow down. If it's the other way around, you should check your X-configuration: 

  • Sounds like the connection between the ESC & motor is bad remove bullets & join connections directly together. setup your motors & ESC in CLI mode. turn on radio first set throttle to max power on copter to program ESC REMOVE PROPS !!

  • have you calibrated the accelerometer?

    • Thats a good point!

  • When I bench test my octocopter I have a similar issue.

    But with props on testing while under the restraint of my hand It's fine.

    I think its just the apm trying to work out what is happening and slowing a motor down to try get some sensor input
This reply was deleted.