Motors spin slowly at min throttle on Arm

I have calibrated the ESCs, installed the latest firmware and followed setup procedures by the book; The props start spinning the moment the APM is armed. I am using the APM 2.0 with a 3.1 Arducopter V Quad setup. What do i need to check? If it is of any use, PWM values range between 937 and 2097 when calibrating the radio. Could that be an issue?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • mot_spin_arrmed.jpg

  • Hi Randy,

    I see this was changed and lowest value is low, you cannot turn it off. Is this true?



    Randy said:


         Yes, if MOT_SPIN_ARMED is zero the props will completely stop if you put the throttle at zero in Stabilize or ACRO even if you're flying.  In other flight modes where the autopilot has control of the throttle (AltHold, Loiter, etc) they will keep spinning.

         This does mean that in Stabilize, Acro the pilot needs to be a little careful but it also gives you full control of the motors in case something bad happens and you need to shut the motors down.

    Complete Parameter List — Copter documentation
  • Hi,

    I have a Quanum Nova. I have just replace a broken FC. I did all the calibration, included the Radio Calibration. When I armed, in Stabilize mode (Manual mode for Nova), the motors don't spin. Rising the throttle motost start spinning, but when I put the throttle at minimum, the motors don't stop.

    There is a parameters that I can tune to make the motors stop when the throttle is at its minimum?

    Thank you!


  • I haven't used my tricopter for almost 2 years, I have just repair it, installes the latest firmware.

    I lost time to figure out why my tricopter keep spinning when it worked perfectly 2 years ago.

    Basically, it's not a bug, it's a feature. I think mission planer warn us about that but I just closed the pop-up without really reading, my fault :D
  • Developer

    I think almost every other multicopter autopilot on market does the same.. If you put throttle to zero == motor stops. It used to be same way on earlier Arducopter softwares too. Some looong ago we had slow spinning when armed while me and Jose were writing original ArduCopter code but it was removed as many people asked that. Now it's back and people can choose which way they want it to be. 

    At least I want them to spin. A lot easier to know/remember that your motors are armed :)

  • A related question. If you do set MOT_SPIN_ARMED to zero (which I don't), will the props stop in flight in Acro or Stabilize modes if the pilot suddenly puts in zero throttle stick ?

    PS. I like to see the props turning slowly when the copter is armed as a safety feature.

  • on 3.1, the motors are supposed to spin when armed (safety feature). it can be adjusted/turned-off using mot_spin_armed or video on it here:

  • Hi Naren,

    That's normal for the new firmware version 3.1. If you want to disable the motor spin after arm, find "MOT_SPIN_ARMED" in the full parameter list and set it to zero.


  • Try a few clicks of 'down' trim on the throttle to get below the ESC threshold point.

    It won't hurt your operation, probably.


This reply was deleted.