Dedicated to the exchange of useful information between members using the Arduino or other families of processors for autonomous rovers.

633 Members
Join Us!

Before Posting an Issue

Hi All,

Before posting an issue or a problem in the ArduRover Discussion Forum, please check the wiki table of contents, review the firmware release notes in the subforum, and search that subforum for existing answers to your question. Help avoid duplicate threads by finding other members with the same issue and their solution.

When formulating your post, use a descriptive title such as "rover will not navigate to waypoints in the Auto mode" (not "HELP!" or "Problem").

Please include the following information to help diagnose your query:

  • Describe the problem you are having. What is the expected verses the observed behavior?
  • Provide hardware information such as the brand and version of your autopilot, GPS, radio, and compass, as well as any other pertinent details about your rover setup.
  • What version of the APM: ArdurRover2 firmware version are you running?
  • For navigation issues, provide your tlog and/or dataflash log. Click here for instructions on retrieving a dataflash log.

TCIII

You need to be a member of diydrones to add comments!

Join diydrones

Comments

  • MR60

    @Tom,Niall, thx for your advice's. What online shop sells this e-maxx chassis and NEU motor?

  • @Niall, that's great. Made my day:)
    You should paint some spots on the robot and replace the beep with a bark - would sound less like a south African taxi and more like a herding dog. I like your design.
    Thanks for sharing.
    Antonie

  • @Hugues,

    I built a custom robot for my farm a few years ago. The farm is all grass and has some slopes but no really rough terrain and after a few attempts I found that a 2 wheels driven by 11 amp wheelchair motors worked very well. FarmBoz Youtube

    If I can be of any further assistance let me know.

  • Admin

    @Hugues,

    Forget the Wild Thumper as it uses the motor sleeve bearings to support the wheels.

    I would go with a 4WD chassis like the Traxxas 1/8 scale E-Maxx with the brushless NEU motor and four wheel independent suspension with bearing supported half shafts.

    You might even want to consider a 1/5 scale 4WD chassis that can carry bigger batteries for longer range and has a suspension that can get over the field furrows:-)

    Regards,

    Tom C AVD

  • MR60

    Hello,

    I have to investigate on a rover platform for a customer who will use it in agriculture fields & forests dirt. What platform would you advise me to investigate : a wild thumper ? a tank tracked chassis ?

    thx

  • Thanks, Mark and Grant.

    I removed Mission planner, APM2, QCGround control. Re-loaded Mission Planner and now its all working again.

    Good to know about the Geo Fencing (the large circles I see in Mission Planner).

    Thanks again guys

    RS

  • Richard, in your comment regarding Geo-fencing around airports. Is that the info you see in Mission Planner and others alike? I dont know if its a real geo-fence or just the 5 mile circle around the airport showing the no-fly zone? That was my understanding I didn't hear anything about it triggering a failsafe etc. I could see no fail safe's setup and a airport geo fence just dropping drones out of the sky.

  • Developer

    Hi Richard.  I don't know what the password prompt is.  I think there are instructions to install in administrator mode - is that the prompt your seeing?

    Whilst the circles are drawn around the airports I don't believe anything is enforced.  They are there to alert users they shouldn't be flying in that space.  I have only tested in SITL but I can fly straight into the circle and over my local airport no problem.  Not something I would do in a real vehicle!

    Thanks, Grant.

  • I also notice that there is now geofencing (been away a while) around airports.

    I don't really know how this works I assume it executes return to land if you fly into that zone?

    If so how does that effect us rovers?

    I live near an Airport in Auckland, it is used once or twice a month (on a good month). We have a golf course on it. 

    So to me it seems a little strange that we can play golf on the air field but I can't use my rover.

    Any info would be much appreciated?

    Cheers,

    Richard

  • Has anyone else come across this:

    I have just installed Mission Planner (msi latest version) and now if I hit "initial setup" or Config/tuning i am asked for a password.

    I have never had this before.

    Has anyone had this or more importantly how can I get rid of it?

    Cheers,

    RS

This reply was deleted.
E-mail me when people leave their comments –

New rover advice

Hi, i am looking to build a new rover, but i need some advice on the chassis. I like the 4wd chassis/tank look and prefer it over the crawler/rc look.are those any good though? most people recommend crawlers.I am looking to get something from banggood, any advice will be highly appreciated. thanks

Read more…
0 Replies

skid steer vehicle steering uncontrollable

Hi all, I have a skid steer robot using a pixhawk cube, one 1x15 roboclaw motor controller and a dagu wild thumper 4 wheel chassis. I have skid steering working so far, testing motor c and motor d tests works as described and the vehicle can be controlled in manual mode. However, upon using any mode other than manual mode the rover wants to shake and pivot on the spot, and it seems the steering PID controller oscillates and these oscillations get larger. i have tried everything but it is still…

Read more…
1 Reply

Traxxas X-Maxx ROVER ESC advice

Hi,I have converted a Traxxas X-Maxx into a rover using the Pixhawk Cube 2 controller kit with a Here GNSS.I swapped out the original X-Maxx remote controller for an X6R receiver and Taranis QX7 radio.latest version of ArduRover firmware installed as of 8/11/18.  The rover has an EZRun Max6 ESC. The problem now is the ESC control over the transition into reverse. The ESC is currently set to it's Running Mode Option 2: "Forward/Reverse with Break", AKA the "Double Click Method".What this mode…

Read more…
0 Replies

Help! No throttle or steering response!

Hi all.I know this is an Adurover group, but Thought I would reach out and try my odds for some help as I'm perplexed by this problem. I have a Traxxas X-Maxx set up with a Pixhawk Cube 2.1 and the Here GPS. I'm using a Tarranis X7 remote controller and a X8R Sbus Receiver. I'm using QGroundControl with the latest, Pixhawk 1.8.0 Firmware with the Generic Rover airframe profile installed. As instructed, I have Steering servo wired into Main 2 and Throttle ESC wired into Main 4. Sensors are…

Read more…
2 Replies