• From 3DR support

    Load ArduPlane Firmware, then go back and load ArduCopter firmware again and perform all the calibrations all over again (radio calibration, accelerometer calibration, and compass calibration). Below are instructions to do this.
    1. Connect your vehicle to the computer using the USB cable, Open Mission Planner (Do not hit connect button)
    2. Load a totally different firmware (for example, ArduPlane) >> Go to Initial Setup >> Install Firmware >> Select ArduPlane V3.2
    3. When it's done. Reboot the vehicle (Unplug and replug the USB)
    4. Repeat the steps but now load exactly the Firmware that you want to use (ArduCopter)
    5. When it's done. Click the Connect button on Mission Planner
    6. Load the parameters for your vehicle. Go to Initial Setup >> Mandatory Hardware >> Frame type and choose Iris+ from the drop down menu. Look at the photo attched for assistance.

    To make sure you are calibrating the accelerometers correctly I recommend you watch a video, link provided below:

    Also can you calibrate the compass? I will provide the link below:

    Also the radio calibration, link provided below:

  • I have reset all settings as described by Todd Harper, but the propellers still wont spin up upon arming. Is this a radio issue? How would one reset the radio?

    • Have you tried re-calibrating your ESC? 

      3DR IRIS - Re-Calibrating the ESC

      After updating parameters, only one direction spun for me, & the other two props had no response.  After re-calibrating ESC's, the issue went away.

      Good luck.

  • Hi Todd / Vu,

    I've installed the upgrade kit from IRIS to IRIS+, & followed the steps for updating the parameters.  The last step 'Write Params' gives no confirmation that parameters were written?  I may be approaching this wrong, but when leaving the Config/Tuning window to, say, Initial Setup, and then returning to Config/Tuning then Full Parameter List, the drop down at the right, that was previously 3DR_Iris+.param, has changed back to 3DR_AERO_M.param.  I would assume this is insignificant, but after calibrating everything via the wizard, only black props work.  Are the updated parameters not making it to the Pixhawk? & did I inadvertently load the Aero_M parameters when I updated firmware?  I think it's a simple solution, but I'm just not seeing it.


    • Todd / Vu,

      Simple solution = calibrate ESC...


  • 3D Robotics

    Hi Keith,

    To clarify, you want to reset to the original IRIS settings or factory IRIS+ settings?

    • I was wanting to set back to original iris+ settings

  • Easy to do, follow the steps in this write-up

    Mission Planner Parameter File

This reply was deleted.