Tarot gimbal problems

I'm having some trouble setting up the Tarot gimbal on my Iris (ordered both at the same time).  I set everything up according to these instructions:


Orange and brown wires are connected properly (I triple checked this) and the red lead is left off.

When I plug in the flight battery the gimbal (which has a GoPro Hero3+ Black attached to it) tilts 45 degrees to the right, shudders/ jitters for a few seconds, then slowly rolls downwards and keeps rolling until the motor cable wraps around the motor and then stops because the cable does not have any slack left.  The yellow LED is illuminated at first then the blue LED flashes while the gimbal is rolling.

The Iris is on a smooth level surface when I plug in the flight battery, and I'm not touching the transmitter at all.  Ch6 knob is turned completely counter clockwise when I plug in the flight battery.  Any ideas on what's going on here?  Thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I went ahead and updated to V1.5 and it's working well for me, too.  I did that because the Tarot download website stated that 1.5 cured vibration problems.  I did notice, however, that doing that changed the tilting motor power back to 35 (from the 25 it was set to in 1.4) which I had read elsewhere was also causing problems.  So, I changed that back down to 25, hit Enter (after typing in 25), AND clicked Write Settings to Flash.

    AND, on the advice of 3DR support, I followed the procedure detailed here ( http://copter.ardupilot.com/wiki/common-tarot-gimbal/ ) under the heading Configuring the Gimbal, item 6a, 6b and 6c.

    I also found that I had vibrations when tilting down to the lower limit until I used Mission Planner, Initial Setup tab, Radio Calibration to calibrate CH6.

  • I had this exact same problem.  After much fiddling, switching back and forth from 1.4 to 1.5 numerous times, I finally found the Upgrade Note in the gimbal software's User Manual folder for V1.4.  Check it out.  (The tricky part is that the file describing the process noted below is NOT included in the V1.5 software.)

    The short of it is that you need to do the Sensor Calibration.  Point the camera straight up and make sure it's level in both directions (I used a drafting triangle), then click the Sensor Calibration button.

    After that, make sure to calibrate CH6 in Mission Planner.

    • THANK YOU Kevin.

      Now I understand how I got it to work after tweaking everything.

      I must have tried the calibration in the process.

    • Kevin- THANK YOU! Calibrating the sensors with the GoPro facing straight up and level solved the problem.  I also reflashed V1.4 firmware for both the board and the motors.  Ch6 knob for tilt control is also working.  So far bench testing the setup shows the gimbal working correctly.  I didn't even look at the firmware notes.  Thanks again!

  • Have you tried with another servo cable?

    Mine was not working and somehow, I changed the servo cable and it worked.

    Also, maybe I wasn't turning the knob far enough to get the gimbel to move.

    Oh, and in the gimbal configuration soft (the tarot one, not mission planner), have you selected Default Mode: stick position mode?

    And last, but not least, is the gimbal running the V1.4 firmware?

    Hope that helps...

    I almost got crazy with this...


    • Mike- I haven't done anything with the gimbal and motor firmware.  From what I understand on the 3D Robotics Iris page the gimbal should already be configured.  I'm doing a little research now on updating the gimbal and motor firmware.

      mP1-  I'm connecting the wires as per the directions from the link I posted above.  I'll check Ch6 in MP and see what it's doing.  Flipping the other switches (not the flight mode ones) doesn't have any effect on the gimbal.

      Mathieu-  I don't have and single wire servo leads.  I'll have to make or buy extras.  Again, I haven't done anything with the gimbal firmware.  I'm going to try that without having the gimbal connected to the Pixhawk.

      Thanks for all the suggestions- I'll post results after updating the gimbal and motor firmware.

  • Orange top row 2 pins in and brown second row first pin .... and in mission planner servo reversed ....and ch6 all the way left?
    • Bruce- I centered Ch6 (according to the monitor screen on the TX) and the same thing happens.

      Curtis- this is how the leads are wired:


      I moved Ch6 knob all the way to the left and right- same thing happens.

    • Why are you connecting the ground ?

      I would suggest that you try using a servo tester. There are ones with a simple lcd screen and a knob. As you turn the knob you can read the current setting. A centered value is 150, move the knob up and down and verify it does the right thing. If you dont have one of those have a look in mission planner (assuming you have ch 6 hooked up to the apm) that  your knob is truely centered.

      I wouldnt be surprised if you actually have something other than ch6 going to the gimbal and thats why its knocking.

      Does flipping one of your other switches change the gimbals behaviour ?

    • Once mine was acting crazy and it turned out to be a loose set screw on the shaft of the tilt motor.
This reply was deleted.