Lost video feed after 1.0.5 update

Flew yesterday with the 1.0.5 update. All's well (haven't seen the GPS problems so far, even pre-update), but I lost the video feed from my GoPro (Hero 4 Silver). Black screen only in the Android app.

Anyone had the same problem? Found a fix?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I had that issue, 3DR said to reset everything, make sure GoPro was set to medium width and 30 fps. After I did that the video feed started, but it took about 5 seconds. I've changed the frame rate back to 60 after that, not had a problem.
  • Nothing but black screen.
  • Hasn't made a difference for us. Are you able to see any feed - i.e. can you see display in Solo app while making selections?

    • I see the app just fine. And, the app connects to the controller through wifi just fine. So, all connections seem to work as expected, just a black area where the video feed should be (same as Terry Cagg experienced).

      Still no success with 1080/30fps M.


  • I found 24fps doesn't work. Might double check you are on 30.

    • Tried 30 fps and 60 fps, no luck.

      Also tried reseating HDMI cable several times. No dice.

      Does the sequence of turning on the controller, solo, and gopro matter?


    • I've not done an exhaustive test, but it seems to work in a number of different video modes (gopro 4 black) as long as I've completely stopped and restarted the iOS app whenever the controller is restarted. If you're unsure whether the the app has shut down and restarted just reboot the device (I'm using iOS). So long as the app was restarted then it seems ok using more than just 1080/30/M video mode. Stopping/starting the gopro or unplugging/plugging the HDMI cable, or stop/starting the Solo itself, seems to make no difference. It's looks like its between the Solo app and the controller. If the controller restarts then you must follow that with a hard restart of the Solo app and video will come up again, otherwise black screen. Again, not an exhaustive test so YMMV.  

  • I am having a no video feed issue as well, the quad just arrived and I updated to newest version. It flys though no feed. I have tried every sequence suggested and still nothing.
    • I've had to unlatch my camera from the holder, reposition the camera to ensure the HDMI connector was fully seated. Then I had video.
This reply was deleted.