connect telemetry through TCP & UDP

hi Silvio!

i have tried 4G telemetry as like you but i have failed continously to connect

the mission planner with 4G network.

attached pls find the screen capture of my trial.

when i push the connect button under the condition of TCP, it showed "host name" pop-up and i wrote

it accordingly. then next window arose to insert remote port number. so i wrote many port number in the column, for example, 8080 or 8090 or 2000 or 14550 but there was no use and the window's remark was the sentence "trying to connect" or" no heatbeat packets received" or "connect failed".






also i changed the connection mode by UDP again, then pop-up showed as "enter local port" and i again wrote many port numbers as above but failed. pop-up was showed as "waiting for UDP" continously.




which port number is ok to connect the telemetry under 4G networks? or is there another problem to do 4Gmetry?

your prompt reply will be appreciated!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Hi Estratios,

      Thanks for your post.

      Unfortunately I am not using Mavlink as I am using Mission Planner.



    • I am also using MP and not using Qgroundcontrol as I think the APM prefers MP over QGC.

      Any suggestions please post, going MAD!

    • Hi Sterling.

      You dont need level converter when connecting APM tx/rx -> RPI GPIO.  I never used it and it works everytime despite the serial voltage diffrence.

      The drawback is ser2net is only supporting TCP. 

      Did you install the ser2net properly?

      sudo apt-get install ser2net

      sudo nano /etc/ser2net.conf

      % change last lines to
      2000:raw:600:/dev/ttyAMA0:57600 8DATABITS NONE
      1STOPBIT banner

      sudo /etc/init.d/ser2net restart

      sudo nano /etc/inittab
      % add hash to this line
      #T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

      sudo nano /boot/cmdline.txt
      % delete references to ttyAMA0
      % "console=ttyAMA0,115200 kgdboc=ttyAMA0,115200"

      The above will allow you to connect at port 2000 TCP at baud 57600

      I haven’t tried the 4Gmetry way, so i can’t help you with that.

    • Hi Bernt, Thanks for your reply, you have help me on occasions before and it was your site that taught me how to install and use Sakis3g and ModeSwitch.

      So for the APM to RPi GPIO connection I can remove the level shifter and then From the APM to the RPi GPIO: TX > RX, RX > TX, GND > GND pin6?, for the + do I need it. The APM uses the Power Module from 3DRobotic, and the RPi has its own dedicated power supply. You may recognize the image ;-))


      So do I need a power (+) connection? 

      As for Ser2net, I had everything right accept this:

      sudo nano /etc/ser2net.conf

      % change last lines to
      2000:raw:600:/dev/ttyAMA0:57600 8DATABITS NONE 
      1STOPBIT banner

      I had: RPi IP,2000:raw:0:/dev/ttyAMA0:57600 8DATABITS NONE 
      1STOPBIT banner

      I have corrected it:


      everything else I had correct.

      But to lean that I can't connect UDP is really gutting. Don't ask me why but I thought I read somewhere that you could send UDP through the TCP connection . . . Gutted, but wiser.

      Take the positive I am ever so slightly more knowledgeable with RPi and Wheezy.

      So let me take a step back and ask:

      I have a APM 2.5&2.6, RPI, and a 3Grouter, How can I or how would you set up to use Mission Planner over 3G UDP?

      The router has Ether net, Micro USB, and one Serial port.

      Thanks in advance.


    • @Sterling

      RPI & APM need to share the same ground to communicate via serial. Just connect any ground cable from APM to any ground pin at RPI.  IMPORTANT.! Don’t connect + cable between them ONLY ground cable.


      For the ser2net config, you should only have this line without the IP address.

      2000:raw:600:/dev/ttyAMA0:57600 8DATABITS NONE 
      1STOPBIT banner

      Then connect your MP to RPI ip adress at TCP 57600

      The only way i was ever able to get UDP working was using TTL to Ethernet adapter  OR mavlink. But mavlink uses allot of RPI CPU and the telemetry was much slower than TTL to eth adapter.


      If you insist using UDP ( same as me :) then go for ttl to eth adapter, fast and almost none cpu usage. 

      Currently I’m using Navio+ and RPI2, this eliminates all the hassling with adapters and wires. Very convenient and you get great support at

      You are much welcome to my site, just pm me and i can help you getting this stuff up and going.


      As said, i haven’t tested the 4Gmetry way, so i don’t know if that way is better or not. Ask Silvio for help and he will probably assist you.

    • @Egeland, thank you so much. I'll look for a TTL to ethernet adapter and see how I get on. I will let you know via your site.

      Great site.

      Cheers again,


  • hey i just did the 4gmetry like a week ago,I used qgroundcontrol though and i set udp connection . loacl port should be the default 14550.Make sure you enable the telemetry in the port that you chose.for me was telem2 port on the pixhawk and i used a uart to usb(usb to serial connection) cable to connect pixhawk with my odroid computer.

    If you need something more and i can help you please let me know.I had many troubles establishing the mavlink over internet with the 4Gmetry idea.

    • Hey as i know the usb to serial cable has a kind of" logic" implement on the board so it transform the usb input to serial output. At least thats what i understood after researching. So using the normal usb to micro usb cable it wont work. For me it didn't and my IT assistant confirmed my theory above.

      As you may see on your cable the usb end is probabluy a bit larger(longer) than the normal usb plugs.

      I think you can find online the cable im talking about but im also possitive in the idea of cutting the one you have. Make also sure that you cross the Tx to Rx and Rx to Tx.
    • hi Efstratios!

      Really thanks for your advice^^. i think you also had experienced so many trial and errors like me^^.

      yes i have a pixhawk but now i am using APM 2.6, raspberry pi 2 and mission planner and

      my devices was sett up as like your procedure UART-usb cable-APM 2.6 with RPI 2.

      so would you advise me the solution under above device conditions?

      if it is more useful, i will install Qgroundcontrol, but i don't know exactly whether the function

      is same with Mission Planner or not.

      awaiting your reply! (my email is


    • Hey im not the expert on this but i can give you info on the problmes i faced,I do think that mission planner and qgroundcotnrol are quite similar ground stations.what it changes is the compatability with the flight stack that you use,I think for apm is better to use mission planner but the whole procedure should not differ much from qgroundcotnrol.

      1st make sure that your cable is usb to serial.Not just a simple usb cable that you modified.You need a usb to serial cable (looks the same as usb but the logic is different i guess).

      2nd make sure that telemetry is activated on the telemetry port of your pixhawk.In mycase i had to activate from the parameters in order to send mavlink through the telemtry port 2.

      I guess you are using mavproxy right?Is it the mavproxy connected with your pixhawk when you run the mavproxy,py --master ..... command?try to open the console adding --console to check if the connection between the pixhawk and your RPI is on.

This reply was deleted.