Developer

ArduCopter 2.6 released!

Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.

 

The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.

 

Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]

 

Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]

 

Tuning:
PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
 
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).

 

Happy flying!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Bonjour,

    besoin d'aide pour auto trim (APM 1 avec 2.6)pouvez vous me dire ce qui ne vas pas dans ma méthode:

    -Dans un hangar (pas de vent),je décolle 

    -à 3M du sol (sans plus toucher a l’accélérateur) enclenche  auto trim

    - j’essaye de maintenir un assiette stable pendant 1 minute-

    -je pose

    -coupe CH7 

    -j'attends 45 secondes et je désarme

    Au vol suivant je suis toujours obliger de faire de minis corrections pour obtenir le stationnaire,coment s'il vous plait obtenir une stabilité parfaite? comment corriger ma méthode?

    merci de votre aide

  • I'm running a tricopter (2.6 with Robert Lefebvre's yaw control branch) and am finding that my yaw servo will jam hard over to the right when disarmed, and today this led to the servo burning out. I only have one more of these servos on hand, so I'm quite keen to modify the code so that this will not happen again.

    I see in another thread from late 2011 (here) about the same problem, It was mentioned that modifying radio.pde, and in the function void output_min() changing a line  APM_RC.OutputCh(CH_7, g.rc_3.radio_min); to  APM_RC.OutputCh(CH_7, g.rc_3.radio_min + 300);

     

    However it seems in 2.6 the function void output_min() only contains the following:

     

    void output_min()
    {
    motors.enable();
    motors.output_min();
    }

    Is there something I can place in this function to limit the travel of my yaw servo, and if so, what should the line of code be? If I added APM_RC.OutputCh(CH_7, g.rc_3.radio_min + 300); within the function, is this still the correct syntax to have the desired effect?

     

  • For X8 coaxial quads using APM1, how do the channels out put the signal for yaw? The props on each arm in normal flight counter rotate at the same speed. However for Yaw to work the speed for the two props would have to be different correct? Can someone explain how this is configured for the 8X quad and what the props are doing for yaw?

  • Hi all,

    just got back from field with broken tricopter ;o(

    loaded v2.6 (slightly modified for LEDs, others untouched) and tried only basics (STAB, LOITER, RTL, AUTO, RTL ...)

    When switched from RTL to stab copter seemed to not respond and gone away. I switched back to RTL but didn't help and copter fall down in the field. Luckily I found it ;o) (only broken arms and props). From logs I can see the roll (yellow curve) got crazy right before the copter fall down (around 7250).

    Can somebody explain whats going on from log? (log attached)

    3692463516?profile=original

    2012-07-11 13-36 5.log

    https://storage.ning.com/topology/rest/1.0/file/get/3692463442?profile=original
  • Hi,

    If i unsolder compass module from APM1, place it like DJI style with cable and change orientation, do i need to comple code manually with edited module position like manual says:

    http://code.google.com/p/arducopter/wiki/AC2_Magnetos

    or is the new position handled with calibration in MP??

    Regards Jani

  •  

    Hello I am new here,

    My copter flies very well to date (APM2 2.6).

    Unfortunately Loiter is not quite accurate.  What parameters should I change so that the copter stays in one place?

    Thanks in advance.

     

    regards

    Georg 

  • double posting

    sorry

  • 3DR Telemetry vs. USB: I was trying to configure ArduCopter over 3DR Telemetry kit but it works strange: I was able to enable Sonar, but not to disable. Also many other configuration options (like battery monitoring) was not working properly over radio link (tried many times, usually with message: Setting .... failed.). The same changes works over USB without any problems. There are no problems with radio communication - telemetry works perfectly, the only problem is with configuration.

  • Does the code perform any level command on boot up or arm?  I'm finding that the only way to get the horizon to show level in MP is to use the level button in MP.  I've tried the 10sec arm to try and trigger the level and nothing.  If I do the 20sec arm I go into the 45sec in-flight levelling.  Is there a new procedure to force the level in 2.6 via the Tx?  I loaded the 2.6 firmware via MP 1.1.96 Mav 1.0.  

    Even after forcing the level command from MP, after I turn off the APM and turn it on again the level is back out by 20deg or more in the roll.  Boot up and arm does nothing to bring the level back, only via MP.

  • The APM 2 is a thing of beauty, and the platform goes from strength to strength, after the APM 1, I'm just chuffed with the new size, features, sensors etc.

    I can't get GPS lock now though, since updating to the 2.6 FW.

    Best I can get is two sats, even after an hour sitting outside in clear skies. However, as per other forum users, I plug in the USB cable, and I get lock within two minutes.

    After some months sorting out a MinimOSD board issues with help from the great Sandro,  so I can find home when I'm FPV'ing, I'm REALLY keen to get this going.

    What parameters have changed to cause this, do you think?

    Help please!!!!

     

     

    Owen

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…