Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • On the wiki page for data flash logs, http://copter.ardupilot.com/wiki/downloading-and-analyzing-data-log... , it describes how to enable logging of ERR messages.

    On my 3.1-rc5, the cli command 'enable all' in the logs section does not show ERR as a log type. BTW, I am using the quad beta binary downloaded a couple of days ago from within MP.

    Did it move somewhere else?  Can we get the wiki page updated, if it did?

    This all came about because somehow I was stuck with a FAILSAFE on my MP hud, and I went looking to see what was causing it.  I finally did get it cleared, but still don't know exactly what it was from.

    TIA,

    Rick

  • Hello,can you pls help

    I am having a problem..it is a big one,bcs i do not know what it is..

    Yesterday iwe upload 3.1 rc5 to my APM2 and something is very wrong..i did all the prearm cheks and calibrations and also clean instal erase everything...after i arm my Y6 props start to spining normaly(i didnt like how fast so i lower them a bit) and everything seems ok BUT as soon as i raise my throttle motors start to spining eraticly and much faster as they should with given throttle,with fast oscilatons.....newer seen this before in 2yrs except once i we uploaded wrong firmwere for hexa instead Y6,and once somebody put wrong motor connection diagram for y6 on Wiki..so my first question is:are you sure Y6 firmwere is really y6 or something else?did anyone test it?ofcourse my esc and radio are calibrated and props all in right direction....my second question is;since i noticed my main power cable coming out from power harnes is loose somehow i deceided to make it stronger so i put a lot of solder on that conection(i mean a lot,twice as many ussually need it) can this be the reason bcs of internal resistence or something??that is only diference since i had 3.1 rc4 wich use to work normal...i cant think of any other reason(maybe my transmiter sending wrong throttle but i did not change anything on graupner MX20)..can you tell me what logs or tests i should make to determine what is the problem..my two cents go to power harnes but everithing looks ok,i dont have multimetar to check..pls help

    2013-11-06 12-47-05.tlog

    2013-11-06 12-49-00.tlog

  • in AC 3.0 is there a ready function to use just for flying forward? i would need something like that for my quad? who could i ask for that?

  • My hexa just FLY away from me and LOST!!

    arducopter 3.1.rc5

    apm 2.5

     

    gps lock (solid blue led and wait for about 1 minute)

    stabilize - loiter ( not too bad ) - stabilized ( suddenly fall to floor) and motor spin very faster - and fly away-- cannot respon any mode( RTL - stabilized)

    T_T so saddd

  • Hey Randy!
    I am a novice in the subject, but has already got me Dji F450 and F550. I have a problem with the F550. It takes off in full speed to right after a few seconds. I've tried everything, but did not succeed. Could you be so kind and look at my logs.
    Dji F550
    Apm 2.5
    Ecs 30a

    2013-10-28 15-30 15.kmz

    2013-10-28 15-30 15.log

    2013-10-28 15-30 15.log.gpx

  • I've tried to find this answer in the 310+ pages with no luck.

    Is the motor spin on arm option available in RC5?  If so, how do I enable it?  

    Thanks !

  • hi all, I have a question maybe trivial:

    Why with AC 3.1 rc5 (after start-initialization APM 2.5 ), I have the yellow LED solid?

    Calibrations prearm OK.
    The motors arm are started correctly..

    thx

    G.

  •  

    Hello guys!

    I have installed the external mag to the APM2.5
    I cut the trace of the compass on the board but if not I connect the external compass in the Mission Planner keeps moving while I move the quad ... This is normal? Or if well cut the trace of the internal compass and exerternal connected, should not move anything in the MP?

    Regards

  •  

     

     

     

     

     

     

     

  • Developer

    Hi, just a quick question.

    Does APM log or tlog records the RC stick position? 

    Thanks 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…