Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • In order to autotune , alt hold needs to be working fine, but how to properly adjust alt hold parameters?, instructions in the manual are not clear , could somebody turn some light on this ?
    Thanks
  • Hi,
    Just thought I would share some positive news.
    Some time ago, I uploaded V3.0 software to both my hexrotor and quadrotor. After hours and hours of youtubing, backyard hovering and tweaking, I managed to have both machines flying quite well. I had a constant issue of oscillation in loiter mode, to the point of being annoying.
    After much tweaking and a busy few rosters at work; my multirotors made their way to a quiet part of the shed, the same part of the shed shared by other working models, just not working to their full potential because of my own lack of smarts!
    So yesterday, I found myself in the unusual position of being able to log some "shed time" after the usual scratching and fiddling, I grabbed both multirotors from the neglected corner, glared at them, then sat with the ipad to read this forum and see how far behind I had got.
    So, the long story less long.
    Updated both multis to RC05. Radio cal, sensor cal, compassmot, autotune, autotrim. Both models returned high compassmot numbers, both boards spaced further from things.
    The result you ask? Wow. Wow. Wow.
    Both multis now take the podium in my shed! These software changes have absolutely turned my enthusiasm around again!
    Loiter and alt hold are amazing, no more hunting and auto missions are better than I had imagined I could ever achieve.
    I effectively started with a clean slate yesterday and within a few hours I have 2 top flying machines!
    Thanks so much to the developers and to those of you that contribute to these forums!!
  • Developer

    I won't be available much today so there will likely be a 24h delay on the review of those -rc6 related logs but I'll be back looking at them tomorrow though along with giving Emin's another review.

  • Hi Randy,

    I read this for the AC3.1-rc6 release notes "GPS failsafe options to trigger AltHold instead of LAND or to trigger LAND even if in flight mode that does not require GPS"

    Could you explain why checking /triggering GPS failsafe if you're flying in flight mode that does not require GPS ? This could be annoying don't you think ?

  • Machine: X-Quad, 1000kV motors, 30A Esc, APM2.5, 3S 2200mah

     

    Would you guys with skilled eyes lend some insight to my flight and crash logs for rc6?  The first log, '19', was an Auto Tune drifting fight with a fast landing with loss of radio at the end. No real problem. I shut the radio off while the machine was pinned under a car and it simply then tried to RTL. No big deal. But, the second log, '20', was a right hand cranker right into the dirt!

     

    I updated to rc5 yesterday and needed to tune but, today saw rc6 was out. Oh, in rc5 I really liked the props spin when Armed. It startled me at first then I remembered. Very Cool and Very Professional Looking. There was no doubt the machine was ready to slice and dice. :-) Then, today I loaded rc6 --- No prop spin. :-(  How, do you turn it on?  Oh, well - I put forth clear and good logic about professionalism, safety and maturing industry within my earlier pitch. Now, I have to find out how to turn the props back on after I fix my smashed quad.

     

     With rc6 I calibrated Compass, ESCs, Radio, Accel, and went to do the now exciting and famous easy Auto Tune. I went out and tested the quad in an easy hover and a little motion in Stabile mode first to assure things would be manageable then set the quad in Alt Hold at about 15 meters and started Auto Tune. The quad was drifting quite a bit and loosing altitude fast. I kept adjusting and then lost the machine - it just drifted to far away and I quickly landed it because I'd lost orientation to fly it back. No big deal. Started again and did not finish because of sinking altitude. I gave up for a time to fly and raised the quad to ~15 meters again and set Alt Hold. I then handed it to my son.  During this first portion there were two odd instances when the quad quickly cranked about 30-40 degrees to one side (rolled) and I saved it and then it flew stable again. ??? I let my son then fly it around at Alt Hold for a few minutes until the quad began to lean at which point it was not recovered and smashed into the ground breaking two arms. I'm not sure if this was firmware related - because we are noobs (newb) but, my son does think he was putting in counter motions when it crashed. He had been flying it around for about five minutes and did quite well. We both are not really sure the cause but, you will see the logs tell a clearer picture to the skilled eye. In the logs I can see the alt up and down and the ThrIn sure does not seem to match ThrOut.. The crash is very apparent. lol.

     

    So, I finally upgrade the firmware to rc6 - a pull back rev.. LOL.....

     

    2013-11-16 15-54 20.log

    2013-11-16 15-52 19.log

  • I am running 3.01 (not an RC) and tried autotune today and it would not engage. I saw that RC4 had an issue with it engaging but didn't see anything about 3.01 having an issue. Anyone have any suggestions on what to check? I have it on channel 7 and confirmed that it was going high enough in MP. Should I try RC6?

    Thanks

  • I could fly with the-rc6 with on my Quadro and Hexa with no wind today.
    6 batteries without problems. Stab, AltHold and Loiter works very well.

    regards Peter

  • OK...since no one bother to check my issues with crash during autotune on 3.1rc5 few pages back today i uploaded 3.1 rc6,did compasscalibration and compassmot afterwards...since i broke my 15.5x4.5 props yesterday i found i have some 13 and 14 inch so i put 13x4.5 up and 14.5 down since somebody on forum(about 3DR new y6) test that combination(bigger down)..i did not noticed difference except i had to raise throttle mid to 560 from 490...y6 was flying nice except alt hold was not so good...anyway i deceide to run autotune again.....

    1. I started autotune around 10m and during process y6 was raising bit by bit so after some time i was on 20m still autotuning left and right..

    2. after some time (now on 25m..)still doing left and right,y6 did 1 fast lean on right and back but that was almost 90 deegree and back so i lost my nerves and switch to stabilize and land down....

    Third:about the battery issue wich Leonard mentioned it might be a case of autotune failure from yesterday with 3.1rc5 explaind few pages back;there is few issues;my attopilot sensor give me different readings all the time so i never know for real what is voltage except at beggining when i mesure them and at end when i mesure them again..it is ok when i have only VOLTAGE(Not voltage and current), OTHER selected for typ of sensor and then i leave that way,the value i enter stay correct,but as soon as i change to ATTOPILOT SENSOR 180A readings are wrong(and sometimes correct)..

    About batterys;today first set of 6S 8000mAh x 2 ended batt no.1 at 22.12V(from25.18V),batt no2 at 22.09V and it is a bit inflated!!???second set(iwe used during autotune) end up both bat at 22.97V

    one of this to logs is correct one...and first log from test flight i cant download bcs it stops at some point(reading 187438 0)

    2013-11-16 16-45 11.log

    2013-11-16 16-48 12.log

  • Developer

    Hmm...I don't like the number of issues that are being reported so I'm rolling back the MP's beta firmwares version to AC3.1-rc5 until I have some more time to investigate these issues and ensure that they're not related to -rc6.

  • Hi all, 

    I experienced an issue on the first attempt to fly with rc6, I upgraded from rc5 to rc6 keeping the same parameters.

    After arming the engines, they do not start.

    Are initiated only by raising the quad

    Watch the video

    https://www.youtube.com/watch?v=En_ji4FNHc0&feature=youtu.be

    2013-11-16 15-10 39.log

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…